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DAQ Quick Start Guide
This guide describes how to install and configure the NI-DAQ 7.x driver 
software and a data acquisition (DAQ) device, and confirm the device is 
operating properly.

This guide does not describe NI switch module installation. Refer to the 
NI Switches Getting Started Guide to install and configure NI switch 
modules.
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Conventions
The following conventions are used in this guide.

<> Angle brackets indicate function keys.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 
avoid injury, data loss, or a system crash. When this symbol is marked on 
the device, refer to the Read Me First: Safety and Radio-Frequency 
Interference document, shipped with the device, for precautions to take.

When this symbol is marked on a product, it denotes a warning advising 
you to take precautions to avoid electrical shock.

When this symbol is marked on a product, it denotes a component that may 
be hot. Touching this component may result in bodily injury.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. 

italic Italic text denotes a cross reference, an introduction to a key concept, or a 
placeholder for a word or value that you must supply.

monospace Text in this font denotes text or characters you should enter from the 
keyboard, error codes, the proper names of disk drives, paths, directories, 
programs, functions, filenames, and extensions.
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NI-DAQ 7.x Software
National Instruments measurement devices are packaged with NI-DAQ 
driver software, an extensive library of functions and VIs you can call from 
your application software, such as LabVIEW or LabWindows™/CVI™, to 
program all the features of your NI measurement devices. Measurement 
devices include DAQ devices such as the E Series multifunction I/O (MIO) 
devices, SCXI signal conditioning modules, and switch modules. Driver 
software has an application programming interface (API), which is a 
library of VIs, functions, classes, attributes, and properties for creating 
applications for your device.

NI-DAQ 7.x includes two NI-DAQ drivers, each with its own API, 
hardware configuration, and software configuration. 

• Traditional NI-DAQ is an upgrade of the earlier version of NI-DAQ. 
Traditional NI-DAQ has the same VIs and functions and works the 
same way as NI-DAQ 6.9.3, except that you can use Traditional 
NI-DAQ and NI-DAQmx on the same computer. 

• NI-DAQmx is the latest NI-DAQ driver with the following advantages 
over Traditional NI-DAQ:

– DAQ Assistant—a graphical way to configure channels and 
measurement tasks for your device, and to generate NI-DAQmx 
code based on your channels and tasks, for use in LabVIEW, 
LabWindows/CVI, and Measurement Studio.

– Increased performance, including faster single-point analog I/O 
and multithreading.

– Simpler, more intuitive APIs for creating DAQ applications using 
fewer functions and VIs than earlier versions of NI-DAQ.

– Expanded functionality for LabVIEW, including property nodes 
and waveform data type support.

– Similar APIs and functionality for ANSI C, LabWindows/CVI, 
and Measurement Studio, including native .NET and C++ 
interfaces.

– Improved support and performance for the LabVIEW Real-Time 
module.

Who Can Use NI-DAQmx
Install and use NI-DAQmx if the following situations apply:

• You are using Windows 2000/NT/XP.

• You are using only devices supported by NI-DAQmx. Refer to the 
Support in NI-DAQ 7.3 section at the end of this guide for the list of 
supported devices.
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• If you are using NI application software, you must use LabVIEW, 
LabWindows/CVI, or Measurement Studio version 7.x, or LabVIEW 
with the LabVIEW Real-Time Module 7.1 to use NI-DAQmx.

• If you use one of the Measurement Studio .NET languages or a device 
supported only by NI-DAQmx, such as the PXI-4204, NI 4461, or 
NI 6509, you must use NI-DAQmx.

Who Must Use Traditional NI-DAQ
Install and use Traditional NI-DAQ if one of the following situations apply:

• You have a device that is not supported by NI-DAQmx, such as the 
AT E Series multifunction DAQ devices.

• You are upgrading from NI-DAQ 6.9.x and have existing applications 
that you do not want to port to NI-DAQmx now. 

• You are using a version of LabVIEW, LabWindows/CVI, or 
Measurement Studio earlier than version 7.0.

• You are using Visual Basic 6.0.

• You are using the LabVIEW Real-Time Module for the Macintosh.

Note The earliest version of NI application software supported by Traditional NI-DAQ 
is version 6.0. LabVIEW, LabWindows/CVI, or Measurement Studio versions 6.x can use 
Traditional NI-DAQ from the NI-DAQ 7.x distribution.

No Longer Supported in Traditional NI-DAQ
The following items supported by NI-DAQ 6.9.3 are no longer supported 
in Traditional NI-DAQ:

• LabVIEW, LabWindows/CVI, or Measurement Studio application 
software versions earlier than 6.0

• Windows Me/98/95

• Some older devices, such as the 1200 Series multifunction DAQ 
devices, VXI DAQ devices, or remote SCXI devices. Refer to the 
Devices No Longer Supported in NI-DAQ 7.x section at the end of 
this guide for the list of unsupported devices. 

How NI-DAQ Fits into Your System
Figure 1 depicts the measurement system overview, showing the path of 
real-world physical phenomena to your measurement application.

Sensors and transducers detect physical phenomena. Signal conditioning 
components condition physical phenomena so that the measurement device 
can receive the data. The computer receives the data through the 
measurement device. Software controls the measurement system, telling 



© National Instruments Corporation 5 DAQ Quick Start Guide

the measurement device when and from which channels to acquire or 
generate data. Software also takes the raw data, analyzes it, and presents it 
in a form you can understand, such as a graph, chart, or file for a report. 

Figure 1.  Measurement System Overview

NI measurement devices and application software are packaged with 
NI-DAQ driver software to program all the features of your 
NI measurement device such as configuring, acquiring, and generating data 
from and sending data to NI measurement devices. Using NI-DAQ saves 
you from having to write these programs. Application software, such as 
LabVIEW, LabWindows/CVI, and Measurement Studio, sends the 
commands to the driver, such as acquire and return a thermocouple reading, 
and then displays and analyzes the data acquired.
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You can use the NI-DAQ driver from NI application software or from any 
programming environment that supports calling dynamic link libraries 
(DLLs) through ANSI C interfaces. Regardless of the programming 
environment, your DAQ application uses NI-DAQ, as shown in Figure 1.

Step 1. Install Application Software
Install your NI application software. If you are using NI-DAQmx to 
program the DAQ devices in your system, install LabVIEW 7.x, 
LabWindows/CVI 7.x, Measurement Studio 7.x, or the LabVIEW 
Real-Time Module 7.1. You can use NI application software version 6.x 
with Traditional NI-DAQ.

If you have an existing application written with an earlier version of your 
application software or NI-DAQ, make a backup copy of the application. 
You then can upgrade your software and modify the application.

Step 2. Uninstall Older Versions of NI-DAQ
If you are upgrading to NI-DAQ 7.x, uninstall the earlier version of 
NI-DAQ now. Use Control Panels»Add/Remove Programs.

Step 3. Install the NI-DAQ 7.x Software

Insert the CD

Caution Do not install NI-DAQ 7.x if your existing applications include unsupported 
components. Before installing the software, refer to the Support in NI-DAQ 7.3 section at 
the end of this guide.

The NI-DAQ 7.x installer should open automatically. If it does not open, 
select Start»Run. Enter x:\setup.exe, where x is the letter of the CD 
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drive. For troubleshooting instructions, refer to the Hardware Installation/ 
Configuration Troubleshooter at ni.com/support/install.

Install your driver software before installing new hardware devices, or 
Windows might not detect your device, and you might see warnings asking 
you to install the driver.

Choose the API(s) to Install

Caution NI-DAQ 7.x cannot exist on the same system with earlier versions of NI-DAQ. 
When you install NI-DAQ 7.x, the latest version of Traditional NI-DAQ replaces earlier 
versions of NI-DAQ and any support files installed by the earlier version. Earlier versions 
of NI-DAQ are removed when you install NI-DAQmx.

NI-DAQ 7.x contains several drivers and their APIs—Traditional NI-DAQ, 
NI-DAQmx, and NI-SWITCH. You can install any or all of the drivers, 
depending on the devices you are using. Refer to the Support 
in NI-DAQ 7.3 section at the end of this guide to see which drivers support 
the devices in your system.

You can use NI-SWITCH or NI-DAQmx to program an NI switch module. 

Install Support Files
The NI-DAQ 7.x installer detects the NI software installed on the system 
and automatically selects the latest versions of the driver, application 
software, and language support files from the CD, as shown in the 
following example.

 

1. Verify that the installer detected and selected the correct support files 
and version number of the application software and/or language.
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If you install NI-DAQ 7.x before installing NI application software 
version 7.x, you must run the NI-DAQ 7.x installer again to install the 
correct application software support.

2. Click Finish.

3. When the installer completes, a message opens asking if you want to 
restart, shut down, or exit.

• Restart—If you are using a system running the LabVIEW 
Real-Time Module, restart. Download NI-DAQ 7.x to the target 
using Measurement & Automation Explorer (MAX). Refer to the 
Measurement & Automation Explorer Remote Systems Help by 
selecting Help»Help Topics»Remote Systems.

• Exit—If you have more NI software to install, exit and install it.

– If you have an NI 435x device and are using 
LabWindows/CVI, C, C++, Visual Basic, or the 
VirtualBench-Logger, exit and install the software from the 
NI 435x CD.

– If you are using a MXI-3 link from a PC to control a PXI 
chassis, exit and install the MXI-3 software, available at 
ni.com/downloads, before using the DAQ device.

• Shut Down—If you are ready to install your device, shut down.

Step 4. Unpack the Devices, Accessories, and Cables
Your device is shipped in an antistatic package to prevent electrostatic 
damage (ESD) to the device and its components.

Caution Never touch the exposed pins of connectors.

To avoid such damage, take the following precautions:

• Ground yourself using a grounding strap or by touching a grounded 
object.

• Touch the antistatic package to a metal part of the computer chassis 
before removing the device from the package.

Remove the device from the package and inspect the device for loose 
components or any sign of damage. Notify NI if the device appears 
damaged in any way. Do not install a damaged device.

Store the device in the antistatic package when the device is not in use.

For safety and compliance information, refer to the device documentation 
as described in Step 10. Browse or Install Device Documentation.
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Step 5. Install the Devices, Accessories, and Cables
If you have more than one DAQ device to install, install them all now.

If your system includes SCXI modules to connect to DAQ devices, first 
install the DAQ components using this guide; you will install SCXI 
modules in Step 11. Install Signal Conditioning or Switch Devices.

Caution Follow proper ESD precautions to ensure you are grounded before installing the 
hardware. Refer to the specifications document for your device for important safety and 
compliance information.

PCI Devices
Complete the following steps to install the PCI device:

1. Power off and unplug the computer.

2. Remove the computer cover and/or the expansion slot cover.

3. Touch any metal part of the computer to discharge any static electricity.

4. Insert the device into a PCI system slot. Gently rock the device into 
place. Do not force the device into place.

 

Figure 2.  Installing a PCI Device

5. Secure the device mounting bracket to the computer back panel rail.

6. Replace the computer cover, if applicable.

1 PCI DAQ Device
2 PCI System Slot

3 PC with PCI Slot

1 2

3
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PXI Devices
Complete the following steps to install the PXI module.

1. Power off and unplug the PXI chassis.

Caution Refer to the Read Me First: Safety and Radio-Frequency Interference document 
packaged with your PXI chassis or device before removing equipment covers or 
connecting or disconnecting any signal wires.

2. Remove the filler panel of an unused PXI slot. For information on 
slot requirements, refer to the device documentation as described 
in Step 10. Browse or Install Device Documentation.

3. Touch any metal part of the chassis to discharge static electricity.

4. Ensure that the PXI module injector/ejector handle is not latched and 
swings freely.

5. Place the PXI module edges into the module guides at the top and 
bottom of the chassis.

6. Slide the device into the PXI slot to the rear of the chassis.

7. When you begin to feel resistance, pull up on the injector/ejector 
handle to fully insert the device.

8. Secure the device front panel to the chassis front panel mounting rail 
using the front-panel mounting screws.

 

Figure 3.  Installing a PXI Device

1 PXI Chassis
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3 PXI Module
4 Injector/Ejector Handle
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PCMCIA Devices
You can install the NI PCMCIA device in any available Type II PC Card 
slot. Complete the following steps to install the PCMCIA device.

1. Remove the PCMCIA slot cover on your computer, if any.

2. Insert the PCMCIA bus connector of the PCMCIA device in the 
slot until the connector is firmly seated.

3. Attach the I/O cable. Be careful not to put strain on the I/O cable when 
inserting or removing the cable connector. Always grasp the cable by 
the connector you are inserting or removing. Never pull directly on the 
I/O cable to unplug it from the PCMCIA device.

Figure 4.  Installing a PCMCIA Device

USB/IEEE 1394 Devices
Complete the following steps to install an NI device for USB or 
IEEE 1394:

1. Make power connections.

• If you are using the BP-1 battery pack, follow the installation 
instructions in your BP-1 installation guide.

• Some NI devices for USB or IEEE 1394 require external power.

– If your device has an external power supply, verify that the 
voltage on the external power supply, if any, matches the 
voltage in your area (120 or 230 VAC) and the voltage 

1 Computer with PCMCIA Slot
2 PCMCIA Socket
3 PCMCIA Device

4 Shielded I/O Cable
5 Accessory
6 Signal Lines
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DAQCard
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required by your device. Connect one end of the power supply 
to an electrical outlet and the other end to your device.

– If your device has a power cord, connect one end of the power 
cord to the device and the other end to an electrical outlet.

2. Connect the cable from the computer USB or IEEE 1394 port or from 
any other hub or IEEE 1394 device to any available USB or IEEE 1394 
port on the device. Figure 5 shows the USB cable and its connectors.

Figure 5.  USB Cable and Connectors

3. If you have a USB or IEEE 1394 device with a power switch, power on 
the device. The computer should immediately detect your device.

Accessories
Install accessories and/or terminal blocks according to the instructions in 
their installation guides. For SCXI and SCC signal conditioning systems, 
continue with the instructions in this guide through Step 11. Install Signal 
Conditioning or Switch Devices.

Step 6. Power On Your Computer or PXI Chassis
Windows recognizes any newly installed device the first time the computer 
reboots after hardware is installed. On some Windows systems, the Found 
New Hardware wizard opens with a dialog box for every NI device 
installed. Install the software automatically (Recommended) is selected 
by default. Click Next or Yes to install the software for each device so 
Windows recognizes the device.

When the computer recognizes a USB or IEEE 1394 device, the power 
LED on the device blinks or lights up. NI devices for IEEE 1394 also have 
a COM LED, which blinks when the device is detected. For LED pattern 
descriptions for your specific device, refer to the device documentation as 
described in Step 10. Browse or Install Device Documentation. 

Step 7. Launch MAX
Double-click the Measurement & Automation icon on the desktop to 
open MAX.

1 Connector to the Computer or USB Hub 2 Connector to the Device

1
2
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Step 8. Confirm That the Device Is Recognized
Complete the following steps:

1. Expand Devices and Interfaces. If you are using a remote RT target, 
expand Remote Systems, find and expand your target, and then 
expand Devices and Interfaces.

2. Check that your device appears under Devices and Interfaces. 

When a device is supported by both Traditional NI-DAQ and 
NI-DAQmx and both are installed, the same device is listed with a 
different name under the Traditional NI-DAQ and NI-DAQmx folders 
under My System»Devices and Interfaces. 

Only NI-DAQmx devices are listed under Remote Systems»Devices 
and Interfaces. To view Traditional NI-DAQ devices in a remote 
system, select Tools»Traditional NI-DAQ Configuration»Remote 
DAQ Configuration, which opens the Remote DAQ Configuration 
window.

If your device does not appear, press <F5> to refresh the view in MAX. 
If the device is still not recognized, refer to ni.com/support/ 
install for troubleshooting information.

3. Under the folder for the NI-DAQ API you are using to program the 
device, right-click the device you want to test. 

• If the device is under Traditional NI-DAQ, select Properties, then 
click Test Resources in the Properties window. Traditional 
NI-DAQ does not have test panels for the LabVIEW Real-Time 
Module.

1 Traditional NI-DAQ and NI-DAQmx Devices Are Listed
2 Only NI-DAQmx Devices Are Listed 

1

2
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• If the device is under NI-DAQmx, select Self-Test.
 

If you need help during the self-test, open Measurement & 
Automation Explorer Help for NI-DAQmx by selecting Help»
Help Topics»NI-DAQmx. 

4. When the self-test finishes, a message indicates successful verification 
or if an error occurred. If an error occurs, refer to ni.com/support/
install for troubleshooting information.

Step 9. Configure the Device Settings
Configure each device you install:

1. Right-click the device name and select Properties. Be sure to click the 
device name under the folder for the NI-DAQ API in which you want 
to control the device. If you are using a remote RT target, NI-DAQmx 
devices are listed under Remote Systems»Devices and Interfaces.

2. Configure the device properties. To use a device in both Traditional 
NI-DAQ and NI-DAQmx, you must configure its properties in each.

• If you are using an accessory, add the accessory information.

• If you are using a device in Traditional NI-DAQ, you can change 
its default settings for AI, AO, OPC, or Remote Access. Refer to 
your device documentation as described in Step 10. Browse or 
Install Device Documentation, for device default settings.

• If you are using a remote RT target and Traditional NI-DAQ, 
select Help»Help Topics»Remote Systems in MAX for 
configuration instructions for remote RT targets.

For SCXI device configuration instructions for systems running 
the LabVIEW Real-Time Module and Traditional NI-DAQ, refer 
to the Hardware Installation/Configuration Troubleshooter 
at ni.com/support/install. Select Real-Time (RT)»
RT Configuration Wizard»SCXI on RT Systems.
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• For IEEE 1451.4 transducer electronic data sheet (TEDS) sensors 
and accessories, configure the device and add the accessory as 
previously described. Click Scan for TEDS. To configure TEDS 
sensors cabled directly to a device, in MAX, right-click the device 
under Devices and Interfaces and select Configure TEDS.

3. Click OK to accept the changes.

To convert Traditional NI-DAQ virtual channels, scale configurations, and 
SCXI and accessory configurations to an NI-DAQmx configuration, select 
Tools»NI-DAQmx Configuration»Convert Traditional NI-DAQ 
Configuration to NI-DAQmx. The wizard does not convert SCC 
configurations; you must configure SCC information separately in each 
API you want to use. Click Help in the wizard for more information about 
converting your configurations.

Step 10. Browse or Install Device Documentation
The NI-DAQ 7.x software kit includes online documentation for supported 
devices and accessories, including PDF and help files describing device 
terminals, specifications, features, and operation. To find, view, and print 
the documents for each device, insert the Device Documentation CD. You 
must have Internet Explorer version 5.0 or later to use some features of the 
NI-DAQ 7.x documentation, including the help system and Device 
Document Browser. After installation, the browser and device documents 
are accessible from Start»Programs»National Instruments»NI-DAQ» 
Browse Device Documentation. 

If you do not have this CD, online documentation for devices is available at 
ni.com/manuals. The Device Document Browser is available at 
ni.com/support; select Drivers and Updates»Most Popular and the 
NI-DAQ version you are using to open a Web page of Installation 
Instructions. Download NI-DAQ CD 2 and follow the instructions for 
installing the NI-DAQ Device Documentation Browser.

Step 11. Install Signal Conditioning or Switch Devices
If your system includes additional devices, such as signal conditioning or 
switch modules, refer to the following documents to install and configure 
the signal conditioning or switch hardware:

• SCXI signal conditioning modules—Refer to the SCXI Quick Start 
Guide.

• Switch modules—Refer to the NI Switches Getting Started Guide.

• Signal Conditioning Components (SCC), such as SC carriers and 
SCC modules—Refer to the SCC Quick Start Guide.
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The rest of this guide applies only to DAQ or PXI integrated signal 
conditioning devices.

Step 12. Attach Sensors and Signal Lines
Wire sensors and signal lines to the terminal block or accessory terminals. 
Helpful information is available as follows: 

• Signal and terminal connections:

– You can view a connection diagram for NI-DAQmx devices in 
your system through the DAQ Assistant. Click the Connection 
Diagram tab. Select each channel in the task to view the needed 
connections from sensor to connector block. The terminal names 
and numbers for each connection are listed. The Connection 
Diagram tool currently supports analog input measurements and 
most MIO and SCXI accessories.

– E Series Help, device user manuals, and accessory guides are on 
the Device Document Browser.

– Pin assignments also are located in the Device Terminals topics of 
the Measurement & Automation Explorer Help for Traditional 
NI-DAQ and the Measurement & Automation Explorer Help for 
NI-DAQmx, both accessible from the MAX Help menu.

• Sensors:

– Refer to ni.com/sensors.

– If you are using LabVIEW, refer to the LabVIEW Measurements 
Manual packaged with LabVIEW or available from ni.com/ 
manuals. 

– If you are using NI-DAQmx, refer to the Sensors topic of the 
NI-DAQmx Help, which you can access from Start»Programs» 
National Instruments»NI-DAQ»NI-DAQmx Help. 

– If you are using Traditional NI-DAQ, refer to Chapter 5, 
Transducer Conversion Functions, of the Traditional NI-DAQ 
User Manual, which you can access from Start»Programs» 
National Instruments»NI-DAQ»Traditional NI-DAQ User 
Manual. 

– For information on IEEE 1451.4 TEDS smart sensors, refer to 
ni.com/zone. 

• Switches—Switch specifications include a topology of the device.
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Step 13. Run Test Panels
Many devices have a test panel for testing specific device functionality, 
such as the ability to acquire and generate signals. 

1. In MAX, expand Devices and Interfaces»Traditional NI-DAQ 
Devices or Devices and Interfaces»NI-DAQmx Devices. If you are 
using a remote RT target, expand Remote Systems, find and expand 
your target, then expand Devices and Interfaces.

2. Right-click the device to test. Be sure to click the device name under 
the folder for the NI-DAQ API in which you want to use the device.

3. Select Test Panels to open a test panel for the selected device. 
Traditional NI-DAQ does not have test panels for the LabVIEW 
Real-Time Module.

An example of a test panel is shown in the following figure.
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4. Click the tabs to test different functions of the device. Click Help 
for instructions on operating the test panels in NI-DAQmx. Refer to the 
Measurement & Automation Explorer Help for Traditional NI-DAQ 
for instructions on operating the test panels in Traditional NI-DAQ.

5. The test panel displays a message indicating whether an error 
occurred. If so, refer to the NI-DAQmx Help or ni.com/support 
for troubleshooting information. 

6. Click Close to exit the test panel.

Step 14. Configure Any Additional New Devices
If you installed more than one DAQ device, repeat Step 9. Configure the 
Device Settings through Step 13. Run Test Panels for each device. 

Step 15. Configure Channels and Tasks
This step applies only if you are programming your device using NI-DAQ 
or NI application software. 

A physical channel is a terminal or pin at which you can measure or 
generate an analog or digital signal. A virtual channel is a collection 
of settings such as a name, a physical channel, input terminal connections, 
the type of measurement or generation, and can include scaling 
information. In NI-DAQmx, virtual channels are integral to every 
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measurement. In Traditional NI-DAQ, configuring virtual channels is 
an optional way to record which channels are being used for different 
measurements. Figure 6 depicts how to configure channels in NI-DAQmx 
and Traditional NI-DAQ.

Figure 6.  Configuring Channels and Tasks in NI-DAQmx and Traditional NI-DAQ

A task, an important new concept for NI-DAQmx, is a collection of one 
or more virtual channels with timing, triggering, and other properties. 
Conceptually, a task represents a measurement or generation you want 
to perform. You can set up and save all of the configuration information 
in a task and use the task in an application.

In NI-DAQmx, you can configure virtual channels as part of a task or 
separate from a task. Virtual channels created inside a task are local 
channels. Virtual channels defined outside a task are global channels. 
You can create global channels in MAX or in your application software 
and then save them in MAX. You can use global channels in any 
application or add them to a number of different tasks. If you modify a 
global channel, the change affects all tasks in which you reference that 
global channel. In most cases, it is simpler to use local channels.

Configure a Task in NI-DAQmx
When using NI-DAQmx, configure tasks with the DAQ Assistant. You 
must have version 7.0 or later of an NI application software package to 
create tasks and channels with the DAQ Assistant.

• In MAX, right-click Data Neighborhood and select Create New. 
In the Create New window, select NI-DAQmx Task and click Next.

If you are using a remote RT target, expand Remote Systems, find and 
expand your target, then right-click Data Neighborhood and select 
Create New.

NI-DAQmx
Use the DAQ Assistant, accessible from MAX

 or NI application software, to configure 
channels and measurement tasks. 
Refer to the DAQ Assistant Help 
and Measurement & Automation 

Explorer Help for NI-DAQmx.

You have installed and configured your devices.

What API are you using to 
program each device?

Traditional
NI-DAQUse MAX to configure channels. Refer to 

Measurement & Automation Explorer Help 
for Traditional NI-DAQ.

Configure channels and tasks.
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• You also can open the DAQ Assistant directly within NI application 
software:

– In LabVIEW:

• Place on the block diagram the DAQ Assistant Express VI 
from the Express Input palette, as described in Getting 
Started with LabVIEW. 

• You also can place the DAQmx Task Name control on the 
front panel to open the DAQ Assistant. Right-click the control 
and select New Task (DAQ Assistant). Taking an 
NI-DAQmx Measurement in LabVIEW has step-by-step 
instructions for creating a task from the DAQmx Task Name 
control and generating code based on the task. In LabVIEW, 
select Help»Taking an NI-DAQmx Measurement.

– In LabWindows/CVI:

1. Select Tools»Create/Edit DAQmx Tasks. The Create/Edit 
DAQmx Tasks dialog box opens. 

2. Select Create New Task In MAX or Create New Task In 
Project and click OK.

– In Measurement Studio:

1. Open Visual Studio .NET and the project in which you want 
to create a DAQmx task class.

2. Select Project»Add New Item. The Add New Item dialog 
box opens. 

3. In the Categories pane, select Measurement Studio» 
Assistants.

4. In the Templates pane, select DAQmx Task Class.

5. Specify a name for the DAQmx task file and click Open. 

6. Specify whether to create a new task or a project copy of a 
global task you create in MAX. 

7. Click Finish.

The DAQ Assistant prompts you to create a new task:

1. Select an I/O type, such as analog input.

2. Select the measurement or generation to perform.

3. Choose the sensor to use, if applicable for that measurement.



© National Instruments Corporation 21 DAQ Quick Start Guide

4. Click Next. A dialog box opens for the task you have specified, 
as shown in the following example.

5. Select the channels to add to the task. You can select physical channels 
from which to create local channels in the task and add global channels 
to the task. 

6. If your system is configured with a TEDS sensor, click the TEDS 
Channels tab. 

a. Select the physical channel(s). The DAQ Assistant imports the 
setting from the sensor and creates the task. 

b. Click Next. 

7. Type the new task name. Click Finish.

8. Configure measurement-specific settings, timing, triggering, and 
scaling, if necessary. If one or more channels are configured for TEDS 
sensors, some settings loaded from TEDS are not editable.

9. If you want to add a channel for a different measurement type to the 
task, such as temperature channels to a voltage task, click the Add 
button.

a. Select the measurement type to add from the drop-down list. A 
dialog box lists all the valid channels for that measurement type. 

b. Select the channel or channels to add. 
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c. Click OK.

d. If desired, repeat step 9 to add additional measurement types and 
channels.

10. Save the task.

• If you opened the DAQ Assistant from LabVIEW or 
LabWindows/CVI, click OK. 

• If you opened the DAQ Assistant from Measurement Studio, 
select File»Save. 

• If you opened the DAQ Assistant from MAX, click Save Task. 

You now can use the task in an application. 

Configure Global Channels in NI-DAQmx
When using NI-DAQmx, configure global channels with the DAQ 
Assistant.

• To open the DAQ Assistant in MAX, right-click Data Neighborhood 
and select Create New. 

If you are using a remote RT target, expand Remote Systems, find and 
expand your target, then right-click Data Neighborhood and select 
Create New.

In the Create New window, select NI-DAQmx Global Channel 
and click Next.

• You also can open the DAQ Assistant directly within NI application 
software: 

– In LabVIEW, use the DAQmx Global Channel control to open the 
DAQ Assistant. Right-click the control and select New Channel 
(DAQ Assistant).

– In LabWindows/CVI or Measurement Studio, first you must 
create a task as previously described. In the DAQ Assistant, click 
Add Existing DAQmx Global Channels to add global channels 
to your task. You must use MAX to create global channels.

The DAQ Assistant prompts you to create a new global channel:

1. Select an I/O type, such as analog input. 

2. Select the measurement or generation to perform. 

3. Choose the sensor to use, if applicable for that measurement. 
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4. A dialog box for the task you have specified prompts you to select the 
channels to add to the task. You can select physical channels from 
which to create local channels in the task, and add global channels to 
the task. 

If your system is configured with a TEDS sensor, click the TEDS 
Channels tab. Select the physical channel(s). The DAQ Assistant 
imports the setting from the sensor and uses the information to create 
the task.

5. Configure measurement-specific settings. If one or more channels are 
configured for TEDS sensors, some settings loaded from TEDS are not 
editable.

6. Save the channel.

• If you opened the DAQ Assistant from LabVIEW or 
LabWindows/CVI, click OK. 

• If you opened the DAQ Assistant from Measurement Studio, 
select File»Save. 

• If you opened the DAQ Assistant from MAX, click Save 
Channel. 

You now can use the global channel in an application or add the global 
channel to a task.

Configure Virtual Channels in Traditional NI-DAQ
When you use Traditional NI-DAQ, complete the following steps to 
configure virtual channels in MAX:

1. Open the Create New Channel wizard. 

• In MAX, right-click Data Neighborhood and select Create New. 
In the Create New window, select Traditional NI-DAQ Virtual 
Channel and click Finish. 

• If you are using a remote RT target with Traditional NI-DAQ, 
select Tools»Traditional NI-DAQ Configuration»Remote 
DAQ Configuration. Traditional NI-DAQ devices in a remote 
system are listed in the Remote DAQ Configuration window. 
Select Channel and click Add.
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2. Follow the instructions in the Create New Channel wizard to create a 
new channel. For information about configuring channels, refer to the 
Measurement & Automation Explorer Help for Traditional NI-DAQ.

Step 16. Use Your Task in an Application
Complete the following steps to use a measurement task in your 
application. Refer to the DAQ Assistant Help for more information about 
using a task or generating code.

LabVIEW
1. Open a blank VI in LabVIEW. 

2. Place the following constant on the block diagram: NI Measurement»
DAQmx-Data Acquisition»DAQmx Task Name Constant.

3. Select the task from the pull-down menu. 

4. Right-click the VI and select Generate Code»Example. 

5. Run the program from the front panel.

LabWindows/CVI
Refer to ni.com/info and type rddq73 for step-by-step instructions for 
using a task in LabWindows/CVI. 

Measurement Studio
Refer to ni.com/info and type rddqms for step-by-step instructions for 
using a task in Measurement Studio.
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Getting Started Developing an Application

Using Examples
Each API includes a collection of programming examples to help you get 
started developing an application. You can modify example code and save 
it in an application. You can use examples to develop a new application or 
add example code to an existing application.

To locate LabVIEW and LabWindows/CVI examples, select Help»Find 
Examples, which opens the National Instruments Example Finder.

NI-DAQmx examples for Measurement Studio-supported languages are in 
the following directories:

• MeasurementStudioVS2003\VCNET\Examples\DAQmx 

• MeasurementStudioVS2003\DotNET\Examples\DAQmx

Traditional NI-DAQ examples for Visual Basic are located as follows:

• The NI-DAQ\Examples\Visual Basic with Measurement 
Studio directory contains a link to the ActiveX control examples for 
use with Measurement Studio.

• The NI-DAQ\Examples\VBasic directory contains the examples 
not associated with Measurement Studio.

NI-DAQmx examples for ANSI C are in the NI-DAQ\Examples\
DAQmx ANSI C directory.

Traditional NI-DAQ examples for ANSI C are in the NI-DAQ\ 
Examples\VisualC directory.

For hundreds of additional examples, refer to ni.com/zone.

Information about Measurement Applications and Devices
You can find information about your measurement applications and 
devices in the following locations.

LabVIEW
If you are a new user, complete Getting Started with LabVIEW 
to get acquainted with LabVIEW. Select Start»Programs»National 
Instruments»LabVIEW 7.x»Search the LabVIEW Bookshelf.

The LabVIEW Measurements Manual contains API overviews 
of Traditional NI-DAQ and NI-DAQmx and describes measurement 
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concepts. Select Start»Programs»National Instruments»
LabVIEW 7.x»Search the LabVIEW Bookshelf.

Taking an NI-DAQmx Measurement in LabVIEW has step-by-step 
instructions on how to set up a measurement in LabVIEW and describes 
key new NI-DAQmx features and concepts such as the DAQ Assistant and 
tasks. In LabVIEW, select Help»Taking an NI-DAQmx Measurement.

The LabVIEW Help contains a VI and Function Reference section that 
describes the LabVIEW VIs and properties for NI-DAQmx and Traditional 
NI-DAQ. In LabVIEW, select Help»VI, Function, & How-To Help and 
browse the VI and Function Reference book in the Contents tab to find the 
VI reference help section for the NI-DAQ API you are using.

LabVIEW Real-Time Module
Select Start»Programs»National Instruments»LabVIEW 7.x»Module 
Documents»Search the LabVIEW Real-Time Module Bookshelf for 
links to the LabVIEW Real-Time Module documents. 

LabWindows/CVI
If you are a new user, complete Getting Started with LabWindows/CVI 
to get acquainted with LabWindows/CVI. In LabWindows/CVI, select 
Help»LabWindows/CVI Bookshelf. 

The LabWindows/CVI Help contains NI-DAQmx measurement concepts 
and function reference. In LabWindows/CVI, select Help»Contents.

Measurement Studio
The NI Measurement Studio Help contains the NI-DAQmx API overview, 
measurement tasks and concepts, and function reference. This help file 
is integrated into the Visual Studio .NET documentation. In Visual 
Studio .NET, select Help»Contents.

The Measurement Studio Reference contains the Traditional NI-DAQ API 
overview, measurement concepts, and function reference. In Visual 
Studio .NET, select Measurement Studio»Measurement Studio 
Reference.

ANSI C without NI Application Software
The Traditional NI-DAQ User Manual and the NI-DAQmx Help contain 
API overviews. The NI-DAQmx Help also contains general information 
about measurement concepts. The Traditional NI-DAQ C Reference Help 
and the NI-DAQmx C Reference Help describe the C functions and 
attributes. Select Start»Programs»National Instruments»NI-DAQ» 
document title for the NI-DAQ API you are using.
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.NET Languages without NI Application Software
The NI Measurement Studio Help contains the NI-DAQmx API overview, 
measurement tasks and concepts, and function reference. This help file 
is integrated into the Visual Studio .NET documentation. In Visual 
Studio .NET, select Help»Contents.

Note If you use a .NET language without Visual Studio .NET, you might not be able to 
view the NI Measurement Studio Help.

Device Documentation
NI-DAQ 7.x includes online documentation for supported devices and 
accessories, including PDF and help files describing device terminals, 
specifications, features, and operation. To find, view, and print the 
documents for each device, insert the NI-DAQ Device Documentation CD. 
After installing the Device Document Browser, device documents are 
accessible from Start»Programs» National Instruments»NI-DAQ» 
Browse Device Documentation.

NI 435x
When you finish configuring and testing the NI 435x, you can use 
VirtualBench-Logger to control the NI 435x without doing any 
programming. Refer to Getting Started with VirtualBench at ni.com/ 
manuals to learn how to use the features of the VirtualBench-Logger.

Using Traditional NI-DAQ and NI-DAQmx on the Same Computer
Existing applications developed with earlier versions of NI-DAQ will run 
under Traditional NI-DAQ. You can use both the Traditional NI-DAQ API 
and the NI-DAQmx API on the same computer with the following 
restrictions:

• Only one API controls a given device at one time.

– After using a device in NI-DAQmx, you must unreserve all 
NI-DAQmx tasks that are using that device before you can use 
that device through Traditional NI-DAQ. If you use a device 
in NI-DAQmx and then use it in Traditional NI-DAQ without 
unreserving the NI-DAQmx tasks, error code -10461 is returned. 
To unreserve NI-DAQmx tasks, call the DAQmx Clear Task VI or 
functions. 

– After using a device in Traditional NI-DAQ, you must reset the 
device before you can use that device in NI-DAQmx. If you use 
a device in Traditional NI-DAQ and then use it in NI-DAQmx 
without resetting the device, error code -200324 is returned.



DAQ Quick Start Guide 28 ni.com

For SCXI devices, you must reset the communicating DAQ device 
in Traditional NI-DAQ before using it in NI-DAQmx. For 
example, E Series DAQ devices use lines 0, 1, 2, and 4 on port 0 
to communicate with the SCXI module. Error code -200158 is 
returned if you do not reset the communicating device in 
Traditional NI-DAQ before using it in NI-DAQmx as follows:

• Call the Traditional NI-DAQ Device Reset VI or the 
Init_DA_Brds function.

• To reset devices in Traditional NI-DAQ from MAX, you must 
reset all devices at once. Right-click the Traditional 
NI-DAQ Devices folder in MAX and select Reset Driver 
for Traditional NI-DAQ. For a remote RT target, you must 
use the Traditional NI-DAQ Device Reset VI.

• In an SCXI data acquisition system, you must use the same API to 
program all devices—connected DAQ devices and inserted SCXI 
modules.

Refer to ni.com/support for details and instructions about the following 
topics:

• How to add NI-DAQmx code to a Traditional NI-DAQ application

• How to run both Traditional NI-DAQ applications and NI-DAQmx 
applications that use the same device

Troubleshooting
Use the following resources if you have problems installing your DAQ 
hardware and/or software:

• For troubleshooting instructions, refer to the Hardware Installation/
Configuration Troubleshooter at ni.com/support/install.

• Refer to ni.com/kb for documents on troubleshooting common 
installation and programming problems and for answering frequently 
asked questions about NI products.

• If you think you have damaged your device and need to return your 
National Instruments hardware for repair or calibration, refer to 
ni.com/support and search on Sending a Board for Repair or 
Calibration to learn how to begin the Return Merchandise 
Authorization (RMA) process.
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Worldwide Technical Support
Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources at ni.com/support 
include the following:

– Self-Help Resources—For immediate answers and solutions, 
visit the award-winning National Instruments Web site for 
software drivers and updates, a searchable KnowledgeBase, 
product manuals, step-by-step troubleshooting wizards, thousands 
of example programs, tutorials, application notes, instrument 
drivers, and so on.

– Free Technical Support—All registered users receive free Basic 
Service, which includes access to hundreds of Application 
Engineers worldwide in the NI Developer Exchange at 
ni.com/exchange. National Instruments Application Engineers 
make sure every question receives an answer.

• Training and Certification—Visit ni.com/training for 
self-paced training, eLearning virtual classrooms, interactive CDs, 
and Certification program information. You also can register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, NI Alliance Program 
members can help. To learn more, call your local NI office or visit 
ni.com/alliance.

• Declaration of Conformity (DoC)—A DoC is our claim of 
compliance with the Council of the European Communities using 
the manufacturer’s declaration of conformity. This system affords 
the user protection for electronic compatibility (EMC) and product 
safety. You can obtain the DoC for your product by visiting 
ni.com/certification.

• Calibration Certificate—If your product supports calibration, 
you can obtain the calibration certificate for your product at 
ni.com/calibration.

National Instruments corporate headquarters is located at 11500 North 
Mopac Expressway, Austin, Texas, 78759-3504. Visit the Worldwide 
Offices section at ni.com/niglobal to access the branch office Web 
sites, which provide up-to-date contact information, support phone 
numbers, email addresses, and current events.
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Support in NI-DAQ 7.3
Version 7.3 of NI-DAQmx does not yet support the full line of 
NI measurement devices. The next few releases of NI-DAQ will add 
support for new and existing devices in NI-DAQmx and will continue 
to include Traditional NI-DAQ.

Operating System Support
NI-DAQmx and Traditional NI-DAQ version 7.3 and NI-SWITCH 2.3 
support Windows 2000/NT/XP. NI-DAQ 7.x on Windows NT requires 
Service Pack 6 or later.

NI-DAQmx 7.3 supports PharLap only with the LabVIEW Real-Time 
Module 7.1.

Measurement Studio requires Visual Studio .NET 2003, which requires 
Windows 2000/NT 4.0/XP. 

For operating system-specific installation instructions, use the Hardware 
Installation/Configuration Troubleshooter at ni.com/support/
install.

To find and download an earlier version of NI-DAQ that supports other 
operating systems, refer to ni.com/downloads. 

Application Software Support
Table 1 lists the application software versions supported by NI-DAQmx 
and Traditional NI-DAQ. If you are not using NI application software, refer 
to Table 2.

 
Table 1.  NI-DAQ 7.x Application Software Support

NI Application Software

Versions 
Supported by 
NI-DAQmx

Versions 
Supported by 
Traditional 

NI-DAQ

LabVIEW  7.x 6.1–7.x

LabVIEW Real-Time Module 7.11 6.1–7.x

LabWindows/CVI  7.x 6.0–7.x

Measurement Studio  7.x 6.0–7.x 2

1 To use the LabVIEW Real-Time Module 7.1 with NI-DAQmx, you must use NI-DAQmx 
version 7.2 or later.
2 Traditional NI-DAQ does not include a Measurement Studio C++ or .NET interface.



© National Instruments Corporation 31 DAQ Quick Start Guide

Programming Language Support
 

Earlier versions of NI-DAQ support other application software and 
language versions. To find and download an earlier version of a driver, 
refer to ni.com/downloads.

Device Support
For specific device model names, refer to the NI-DAQ 7.x Readme on 
the CD. Table 3 lists the families of devices supported in NI-DAQ 7.3 by 
NI-DAQmx and Traditional NI-DAQ.

Table 2.  NI-DAQ 7.x Programming Language Support

Programming Language

Versions 
Supported by 
NI-DAQmx

Versions 
Supported by 
Traditional 

NI-DAQ

ANSI C 3 3

Microsoft Visual C++
Class libraries
C DLL

7.x 1

6.0–7.x
—

6.0–7.x

Visual Basic 6.0 through ActiveX — 6.0

Microsoft .NET languages 
(C# and Visual Basic .NET)

.NET 1.1 —

1 Requires Measurement Studio version 7.x.

Table 3.  NI-DAQ 7.3 Device Support

Device NI-DAQmx
Traditional 

NI-DAQ

Multifunction DAQ

PCI and PXI E Series devices, such as the NI PCI-6052E ✓ ✓

PCMCIA E Series NI DAQCard-6024E, NI DAQCard-6036E, and NI DAQCard-6062E ✓ ✓

AT E Series — ✓

NI PCI-6013/6014 16-bit basic devices ✓ ✓

NI DAQPad-6015/6016 devices for USB ✓ —

NI DAQPad-6020E/6052E/6070E devices for USB and FireWire (IEEE 1394) — ✓

NI PCI-7041/6040E device for LabVIEW RT ✓ ✓

NI PXI and PCI-7030 device for LabVIEW RT — ✓

S Series NI PXI-6132/6133 and NI PXI and PCI-6143 ✓ —

S Series NI PCI-6110/6111 ✓ ✓

All other S Series such as the NI PXI-6115 — ✓
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Analog Output/Waveform

NI PXI and PCI-6711/6713 waveform ✓ ✓

PCMCIA NI DAQCard-6715 ✓ ✓

NI PXI and PCI-6722/6723 ✓ —

NI PXI and PCI-6731/6733 ✓ ✓

NI 6703/6704 — ✓

AT-AO-6/10 — ✓

Analog Input: PCMCIA DAQCard-AI-16E-4 and DAQCard-AI-16XE-50 — ✓

Counter/Timer

NI PCI-6601/6602 ✓ ✓

NI PXI-6602 ✓ —

NI PXI-6608 — ✓

NI PXI and PCI-6624 isolated ✓ —

High-Precision DAQ: NI 4350/4351 — ✓

Digital I/O

NI 6503, NI PXI-6508, NI 6527, and NI PCI-DIO-96 ✓ ✓

NI 6509/6510/6511/6512/6513/6514/6515/6516/6517/6518/6519 and NI 6528 ✓ —

NI 653X high-speed digital — ✓

PCMCIA NI DAQCard-DIO-24 ✓ ✓

NI DAQPad-6507/6508 for USB — ✓

PC-DIO-24 and PC-DIO-96 — ✓

AT-DIO-32F — ✓

Dynamic Signal Acquisition

NI PXI-4461 ✓ —

NI PXI-4472/4472B and PCI-4472/4474 ✓ ✓

NI PCI-4451/4452/4454 and 4551/4552 — ✓

Signal Conditioning

SCXI-1521/B and SCXI-1600 modules ✓ —

All other SCXI signal conditioning modules ✓ ✓

NI PXI-4200/4204/4220 integrated signal conditioning ✓ —

SCC Series modules ✓ ✓

TEDS devices: BNC-2096, SC-2350 carrier, and SCXI-1314T 
Note: These devices support reading from and writing to TEDS sensors.

✓ —

Table 3.  NI-DAQ 7.3 Device Support (Continued)

Device NI-DAQmx
Traditional 

NI-DAQ
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More Devices in Future Releases of NI-DAQmx
Future releases of NI-DAQ will support additional devices in NI-DAQmx 
that are currently supported only in Traditional NI-DAQ.

Devices No Longer Supported in NI-DAQ 7.x
The following products are not supported in NI-DAQ 7.x—NI-DAQmx 
nor Traditional NI-DAQ—and will not be supported in future versions of 
NI-DAQ. You must use NI-DAQ 6.9.x or earlier to program these devices:

Switch

NI SCXI-1160, SCXI-1161, and SCXI-1163R modules ✓ ✓

All other SCXI switch modules ✓ —

PXI switch modules ✓ —

NI AT-MIO-16F-5 NI PC-AO-2DC

NI DAQCard-500 NI PC-LPM-16/PNP

NI DAQCard-516 NI PC-OPDIO-16

NI DAQCard-700 NI PC-TIO-10

NI DAQCard-1200 NI PCI-1200

NI DAQCard-AO-2DC NI SCXI-1200

NI DAQPad-1200 NI SCXI-2000

NI DAQPad-MIO-16XE-50 NI SCXI-2400

NI Lab-PC and Lab-PC+ NI VXI DAQ modules

NI Lab-PC-1200/AI NI VXI-SC carriers and modules

NI PC-516 NI VXI-TB terminal blocks for VXI bus

Table 3.  NI-DAQ 7.3 Device Support (Continued)

Device NI-DAQmx
Traditional 

NI-DAQ
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Guide de démarrage DAQ
Ce guide décrit les étapes à suivre pour installer et configurer le driver 
NI-DAQ 7.x, ainsi qu’un périphérique d’acquisition de données (DAQ), 
et confirmer que ce périphérique fonctionne correctement.

Ce guide ne décrit pas l’installation du module NI Switch. Reportez-vous 
au NI Switches Getting Started Guide pour installer et configurer les 
modules NI Switch.
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Conventions
Les conventions suivantes sont utilisées dans ce manuel.

<> Les simples chevrons indiquent des touches de fonction.

» Le symbole » vous dirige vers les éléments de menu emboîtés et les options 
de boîtes de dialogue donnant lieu à une action finale. La séquence 
Fichier»Mise en page»Options vous invite à dérouler le menu Fichier, 
à sélectionner l’élément Mise en page et à sélectionner Options.

Cette icône signale une remarque qui vous donne des informations 
importantes.

Cette icône signale un avertissement qui vous indique les précautions 
à prendre pour éviter des préjudices corporels, des pertes de données 
ou un blocage du système. Si ce symbole est présent sur le périphérique, 
reportez-vous au document Read Me First: Safety and Radio-Frequency 
Interference, livré avec le périphérique, pour vous renseigner sur les 
précautions à prendre.

La présence de ce symbole sur un produit indique une mise en garde vous 
conseillant de prendre des précautions pour éviter les chocs électriques.

La présence de ce symbole sur un produit indique qu’un composant risque 
d’être brûlant. Toucher ce produit peut provoquer des préjudices corporels.
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gras Le texte en gras signale les éléments que vous devez sélectionner ou sur 
lesquels vous devez cliquer dans le logiciel, par exemple les éléments de 
menus et les options de boîtes de dialogue. 

italiques Le texte en italiques indique une référence croisée, une introduction à un 
concept clé, ou un texte qui est substituable par un mot ou une valeur que 
vous devez fournir.

monospace Cette police signale du texte ou des caractères que vous devez saisir à partir 
du clavier, des codes d’erreur, les noms propres de disques durs, des 
chemins, des programmes, des fonctions, des noms de fichiers et des 
extensions.

Driver NI-DAQ 7.x
Les périphériques de mesures de National Instruments sont livrés avec le 
driver NI-DAQ, une bibliothèque de fonctions et de VIs que vous pouvez 
appeler à partir d’un environnement de développement, tel que LabVIEW 
ou LabWindows™/CVI™, pour programmer toutes les fonctionnalités de 
vos périphériques de mesures NI. Les Périphériques de mesures 
comprennent les périphériques DAQ tels que les modules d’E/S 
multifonctions de la série E (MIO), les modules de conditionnement de 
signal SCXI et les modules Switch. Le driver est constitué d’une API 
(Application Programming Interface), qui est une bibliothèque de VIs, 
fonctions, classes, attributs et propriétés pour créer des applications pour 
votre périphérique.

NI-DAQ 7.x comprend deux drivers NI-DAQ, chacun avec sa propre API et 
sa propre configuration matérielle et logicielle. 

• NI-DAQ traditionnel est une mise à jour de la version antérieure 
de NI-DAQ. Ce driver comprend les mêmes VIs et fonctions que 
NI-DAQ 6.9.3 et fonctionne de la même manière, sauf que vous 
pouvez utiliser NI-DAQ traditionnel et NI-DAQmx sur le même 
ordinateur. 

• NI-DAQmx est le tout dernier driver NI-DAQ dotés des avantages 
suivants par rapport à NI-DAQ traditionnel :

– Assistant DAQ : méthode graphique permettant de configurer 
des voies et des tâches de mesure pour votre périphérique et 
de générer du code NI-DAQmx basé sur vos voies et vos tâches, 
en vue de l’utiliser dans LabVIEW, LabWindows/CVI et 
Measurement Studio.

– Performances accrues, notamment des E/S analogiques point par 
point et un multithreading plus rapides.
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– Des API plus simples et plus intuitives pour créer des applications 
DAQ grâce à un nombre réduit de fonctions et de VIs comparé aux 
versions antérieures de NI-DAQ.

– Fonctionnalité étendue pour LabVIEW, notamment le support des 
nœuds de propriété et du type de données waveform.

– Fonctionnalités et API similaires pour ANSI C, LabWindows/CVI 
et Measurement Studio, y compris les interfaces natives .NET 
et C++.

– Support et performances améliorés pour le Module LabVIEW 
Real-Time.

Qui peut se servir de NI-DAQmx ?
Installez et utilisez NI-DAQmx si les situations suivantes vous concernent :

• Vous utilisez Windows 2000/NT/XP.

• Vous n’utilisez que des périphériques supportés par NI-DAQmx. 
Reportez-vous à la section Support dans NI-DAQ 7.3 à la fin de ce 
guide pour obtenir la liste complète des périphériques supportés.

• Si vous utilisez des logiciels d’application NI, vous devez utiliser 
LabVIEW, LabWindows/CVI, Measurement Studio version 7.x ou 
LabVIEW avec le Module LabVIEW Real-Time 7.1 pour pouvoir 
utiliser NI-DAQmx.

• Si vous utilisez un des langages .NET de Measurement Studio ou un 
périphérique supporté uniquement par NI-DAQmx, tel que le module 
PXI-4204, NI 4461 ou NI 6509, vous devez utiliser NI-DAQmx.

Qui peut se servir de NI-DAQ traditionnel ?
Installez et utilisez NI-DAQ traditionnel si l’une des situations suivantes 
s’appliquent :

• Vous avez un périphérique qui n’est pas supporté par NI-DAQmx, 
comme les périphériques DAQ multifonctions de la série E au 
format AT.

• Vous effectuez une mise à niveau à partir de NI-DAQ 6.9.x et vous avez 
des applications existantes que vous ne voulez pas convertir en 
NI-DAQmx tout de suite. 

• Vous utilisez une version de LabVIEW, LabWindows/CVI et 
Measurement Studio antérieure à la version 7.0.
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• Vous utilisez Visual Basic 6.0.

• Vous utilisez le Module LabVIEW Real-Time pour le Macintosh.

Remarque NI-DAQ traditionnel ne supporte les logiciels d’application NI qu’à partir de 
la version 6.0. LabVIEW, LabWindows/CVI et Measurement Studio version 6.x peuvent 
utiliser le NI-DAQ traditionnel de la distribution NI-DAQ 7.x.

Ce qui n’est plus supporté par NI-DAQ traditionnel
NI-DAQ 6.9.3 est la dernière version de NI-DAQ traditionnel à supporter 
les éléments suivants :

• LabVIEW, LabWindows/CVI et Measurement Studio de versions 
antérieures à 6.0

• Windows Me/98/95

• Certains périphériques anciens, tels que les périphériques DAQ 
multifonction de la série 1200, les périphériques VXI DAQ ou les 
périphériques SCXI déportés. Reportez-vous à la section 
Périphériques qui ne sont plus supportés par NI-DAQ 7.x à la fin de ce 
guide pour obtenir la liste complète des périphériques qui ne sont pas 
supportés. 

Comment NI-DAQ s’intègre à votre système ?
La figure 1 représente une vue d’ensemble du système de mesure, illustrant 
le chemin à partir du phénomène physique réel jusqu’à votre application de 
mesure.

Des capteurs et des transducteurs détectent des phénomènes physiques. 
Les éléments de conditionnement de signal conditionnent ces phénomènes 
physiques de sorte que le périphérique de mesure puisse recevoir les 
données. L’ordinateur reçoit les données par l’intermédiaire du 
périphérique de mesure. Le logiciel contrôle le système de mesure, 
précisant au périphérique de mesure à quel moment il doit acquérir ou 
générer les données, et sur quelles voies. Le logiciel prend aussi les 
données brutes, les analyse et les présente dans un format que vous pouvez 
comprendre, comme un graphe, un graphe déroulant ou un fichier de 
rapport. 
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Figure 1.  Vue d’ensemble du système de mesures

Les périphériques de mesure et les logiciels d’application NI sont livrés 
avec le driver NI-DAQ, lequel permet de programmer toutes les 
fonctionnalités de vos périphériques de mesure NI, comme la 
configuration, l’acquisition et la génération de données, ainsi que l’envoi 
de données à des périphériques de mesure NI. NI-DAQ vous évite d’avoir 
à écrire tous ces programmes vous-même. L’environnement de 
développement, comme par exemple, LabVIEW, LabWindows/CVI et 
Measurement Studio, émet des commandes au driver, comme celles 
d’acquérir et de renvoyer la lecture d’un thermocouple, puis affiche et 
analyse les données acquises.

Vous pouvez utiliser le driver NI-DAQ à partir de l’environnement de 
développement NI ou de n’importe quel environnement de développement 
qui supporte les appels de DLLs (Dynamic Link Libraries) au moyen 
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d’interfaces ANSI C. Quel que soit votre environnement de 
développement, votre application DAQ utilise NI-DAQ, comme illustré 
dans la figure 1.

Étape 1. Installez le logiciel d’application
Installez votre logiciel d’application NI. Si vous utilisez NI-DAQmx 
pour programmer les périphériques DAQ de votre système, installez 
LabVIEW 7.x, LabWindows/CVI 7.x, Measurement Studio 7.x ou le 
Module LabVIEW Real-Time 7.1. Vous pouvez utiliser les logiciels 
d’application NI de la version 6.x avec NI-DAQ traditionnel.

Si vous avez une application qui a été développée avec une version 
antérieure de votre logiciel d’application ou de NI-DAQ, faites-en une 
copie de sauvegarde. Vous pouvez ensuite mettre à jour votre logiciel et 
modifier l’application.

Étape 2. Désinstallez les anciennes versions de NI-DAQ
Si vous effectuez une mise à jour vers NI-DAQ 7.x, désinstallez d’abord 
l’ancienne version de NI-DAQ. Utilisez Panneau de configuration»
Ajout/Suppression de programmes.

Étape 3. Installez le driver NI-DAQ 7.x

Insérez le CD

Mise en garde N’installez pas NI-DAQ 7.x si vos applications existantes comprennent des 
éléments non supportés ! Avant d’installer ce logiciel, reportez-vous à la section Support 
dans NI-DAQ 7.3 à la fin de ce guide.
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L’installeur NI-DAQ 7.x devrait s’ouvrir automatiquement. Si ce n’est pas 
le cas, sélectionnez Démarrer»Exécuter. Entrez x:\setup.exe, où x 
correspond à la lettre du lecteur CD. Pour consulter des instructions de 
dépannage, reportez-vous à la rubrique Hardware Installation/
Configuration Troubleshooter sur ni.com/support/install.

Installez votre driver avant d’installer de nouveaux périphériques 
matériels ; sinon, Windows risque de ne pas les détecter et vous pourriez 
recevoir des mises en garde vous demandant d’installer le driver.

Sélectionnez l’API (ou les API) à installer

Mise en garde NI-DAQ 7.x ne peut pas coexister avec une version antérieure de NI-DAQ 
sur le même ordinateur. Lorsque vous installez NI-DAQ 7.x, la dernière version de 
NI-DAQ traditionnel remplace les versions précédentes de NI-DAQ et tous les fichiers 
support installés par celles-ci. Les versions précédentes de NI-DAQ sont supprimées quand 
vous installez NI-DAQmx.

NI-DAQ 7.x comprend plusieurs drivers avec leur API : NI-DAQ 
traditionnel, NI-DAQmx et NI-SWITCH. Selon les périphériques que vous 
utilisez, vous pouvez choisir d’installer tous ces drivers ou un seul. 
Reportez-vous à la section Support dans NI-DAQ 7.3 à la fin de ce guide 
pour savoir quels drivers supportent les périphériques installés dans votre 
système.

Vous pouvez utiliser NI-SWITCH ou NI-DAQmx pour programmer un 
module NI Switch.

Installez les fichiers de support
L’installeur NI-DAQ 7.x détecte tous les logiciels NI installés sur le 
système et sélectionne automatiquement sur le CD les fichiers support des 
versions les plus récentes des drivers, logiciels d’application et langages 
qu’il a détectés, comme illustré dans l’exemple qui suit.
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1. Vérifiez que l’installeur a détecté et sélectionné les fichiers support 
appropriés et que le numéro de version du logiciel d’application et/ou 
du langage est correct.

Si vous installez NI-DAQ 7.x avant d’installer un logiciel d’application 
NI de la version 7.x, vous devez à nouveau exécuter l’installeur 
NI-DAQ 7.x afin d’installer le fichier support qui convient pour ce 
logiciel d’application.

2. Cliquez sur Terminer.

3. Une fois que l’installeur a terminé, un message apparaît pour vous 
demander si vous voulez redémarrer, quitter ou arrêter.

• Redémarrer : Si vous utilisez un système qui exécute le Module 
LabVIEW Real-Time, redémarrez l’ordinateur. Téléchargez 
NI-DAQ 7.x vers la cible à l’aide de MAX (Measurement & 
Automation Explorer). Reportez-vous à l’Aide MAX sur les 
systèmes déportés en sélectionnant Aide»Rubriques de 
l’aide»Systèmes déportés.

• Quitter : Si vous avez d’autres logiciels NI à installer, quittez le 
programme et installez-les.

– Si vous avez un périphérique NI 435x et que vous utilisez 
LabWindows/CVI, C, C++, Visual Basic ou le 
VirtualBench-Logger, choisissez de quitter et installez le 
logiciel provenant du CD NI 435x.

– Si vous utilisez un lien MXI-3 à partir d’un PC pour 
commander un châssis PXI, vous devez installer le logiciel 
MXI-3, qui est disponible sur ni.com/downloads, avant 
d’utiliser le périphérique DAQ.

• Arrêter : Si vous êtes prêt(e) à installer votre périphérique, 
sélectionnez Arrêter.



Guide de démarrage DAQ 44 ni.com

Étape 4. Déballez les périphériques, les accessoires et 
les câbles

Votre périphérique est livré dans un sachet antistatique pour 
protéger le périphérique et ses composants contre les décharges 
électrostatiques (EDS).

Mise en garde Ne touchez jamais les broches des connecteurs.

Pour éviter de tels dommages, respectez les précautions suivantes :

• Utilisez un ruban de mise à la masse ou touchez un objet en contact 
avec la masse pour devenir vous-même une référence à la masse.

• Mettez en contact le sachet antistatique avec la partie métallique du 
châssis de l’ordinateur avant de retirer le périphérique du sachet.

Retirez le périphérique de son sachet. Examinez les composants pour 
repérer tout signe d’endommagement. Contactez NI si le périphérique 
apparaît endommagé d’une façon quelconque. N’installez pas un 
périphérique endommagé.

Conservez le périphérique dans le sachet antistatique quand il n’est pas 
utilisé.

Pour consulter les informations de conformité et de sécurité, reportez-vous 
à la documentation du périphérique, comme elle est décrite dans
l’Étape 10. Naviguez dans la documentation du périphérique ou installez 
celle-ci.

Étape 5. Installez les périphériques, les accessoires et 
les câbles

Si vous avez plusieurs périphériques DAQ à installer, installez-les tous 
maintenant.

Si votre système comprend des modules SCXI qui doivent être connectés à 
des périphériques DAQ, installez d’abord les composants DAQ à l’aide de 
ce guide ; vous installerez les modules SCXI dans Étape 11. Installez les 
périphériques de conditionnement de signal ou de commutation.

Mise en garde Respectez les précautions à suivre contre les dommages électrostatiques 
avant d’installer le matériel. Consultez le document des spécifications se rapportant à votre 
périphérique pour lire des informations importantes concernant la sécurité et la 
compatibilité.
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Périphériques PCI
Effectuez les étapes suivantes pour installer le périphérique PCI :

1. Mettez le châssis hors tension et débranchez-le de l’ordinateur.

2. Retirez le capot de votre ordinateur et/ou le cache de l’emplacement 
d’extension.

3. Touchez n’importe quelle partie métallique de l’ordinateur pour 
décharger l’électricité statique.

4. Insérez le périphérique dans l’emplacement PCI. Ajustez-le 
soigneusement pour qu’il soit parfaitement inséré. Ne forcez 
pas le périphérique dans son emplacement.

 

Figure 2.  Installation d’un périphérique PCI

5. Fixez le support de fixation du périphérique au rail du panneau arrière 
de l’ordinateur.

6. Remettez en place le capot de l’ordinateur.

Périphériques PXI
Effectuez les étapes suivantes pour installer le module PXI.

1. Mettez le châssis PXI hors tension et débranchez-le.

Mise en garde Reportez-vous au document Read Me First: Safety and Radio-Frequency 
Interference livré avec votre châssis ou périphérique PXI avant de retirer le couvercle de 
matériel ou de connecter et de déconnecter des câbles de signal.
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3 PC avec emplacement PCI
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2. Retirez le cache de protection d’un emplacement PXI vide. Pour savoir 
quels emplacements utiliser dans le châssis, reportez-vous à la 
documentation du périphérique, comme expliqué dans l’Étape 10. 
Naviguez dans la documentation du périphérique ou installez celle-ci.

3. Touchez n’importe quelle partie métallique du châssis pour décharger 
l’électricité statique.

4. Vérifiez que la poignée d’insertion/éjection du module PXI n’est pas 
verrouillée et qu’elle tourne librement.

5. Placez les bords du module PXI dans les guides pour module en haut 
et en bas du châssis.

6. Faites glisser le périphérique dans l’emplacement PXI à l’arrière du 
châssis.

7. Dès que vous sentez une résistance, relevez la poignée 
d’insertion/éjection pour insérer complètement le périphérique.

8. Vissez le périphérique sur le support de fixation situé à l’avant du 
châssis à l’aide des vis de montage.

 

Figure 3.  Installation d’un périphérique PXI
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Périphériques PCMCIA
Vous pouvez installer le périphérique NI PCMCIA dans n’importe quel 
emplacement de carte PC de type II disponible. Effectuez les étapes 
suivantes pour installer le périphérique PCMCIA.

1. Si nécessaire, retirez le cache de protection de l’emplacement 
PCMCIA.

2. Insérez le connecteur de bus PCMCIA du périphérique PCMCIA dans 
l’emplacement jusqu’à ce qu’il soit solidement installé.

3. Branchez le câble d’E/S. Prenez garde à ne pas appuyer trop fort sur le 
câble d’E/S quand vous insérez ou retirez son connecteur. Saisissez 
toujours le câble par son connecteur quand vous le connectez ou 
l’enlevez. Ne tirez jamais directement sur le câble d’E/S pour le 
débrancher du périphérique PCMCIA.

Figure 4.  Installation d’un périphérique PCMCIA

1 Ordinateur avec emplacement PCMCIA
2 Prise PCMCIA
3 Périphérique PCMCIA
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Périphériques USB/IEEE 1394
Exécutez les étapes suivantes pour installer un périphérique NI de type 
USB ou IEEE 1394 :

1. Effectuez les connexions d’alimentation.

• Si vous utilisez un pack batterie BP-1, suivez les instructions de 
votre guide d’installation BP-1.

• Certains périphériques NI de type USB ou IEEE 1394 nécessitent 
une alimentation externe.

– Si votre périphérique utilise une alimentation externe, 
assurez-vous que la tension sur le bloc d’alimentation 
externe, le cas échéant, est compatible avec le courant secteur 
dans votre région (120 ou 230 VAC) et avec la tension exigée 
par votre périphérique. Connectez une extrémité du bloc 
d’alimentation à une prise secteur et branchez l’autre 
extrémité à l’arrière du périphérique.

– Si votre périphérique est doté d’un cordon d’alimentation, 
connectez une extrémité du cordon d’alimentation au 
périphérique et l’autre à une prise secteur.

2. Reliez le câble entre le port USB ou IEEE 1394, situé directement sur 
le PC ou sur tout autre hub ou périphérique IEEE 1394, et le port USB 
ou IEEE 1394 du périphérique. La figure 5 représente le câble USB et 
ses connecteurs.

Figure 5.  Câble et connecteurs USB

3. Si votre périphérique USB ou IEEE 1394 est équipé d’un bouton 
d’alimentation, mettez-le sous tension. L’ordinateur devrait détecter 
immédiatement votre périphérique.

Accessoires
Installez les accessoires et/ou les blocs de terminaison suivant les 
instructions fournies dans leurs guides d’installation respectifs. Pour les 
systèmes de conditionnement de signal SCXI et SCC, continuez à suivre les 
instructions de ce guide jusqu’à l’Étape 11. Installez les périphériques de 
conditionnement de signal ou de commutation.

1 Connecteur pour l’ordinateur 
ou pour un hub USB

2 Connecteur pour le périphérique
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Étape 6. Mettez votre ordinateur ou châssis PXI sous 
tension

Windows détecte et reconnaît tous les périphériques nouvellement installés 
dès le premier redémarrage qui suit leur installation. Sur certains systèmes 
Windows, l’Assistant Nouveau matériel détecté s’ouvre avec une boîte de 
dialogue pour chaque périphérique NI installé. Installer le logiciel 
automatiquement (Recommandé) est sélectionné par défaut. Cliquez sur 
Suivant ou sur Oui pour installer le logiciel pour chaque périphérique et 
permettre ainsi à Windows de le reconnaître.

Lorsque l’ordinateur reconnaît un périphérique USB ou IEEE 1394, le 
voyant LED d’alimentation clignote ou s’allume. Les périphériques NI de 
type IEEE 1394 possèdent aussi un voyant LED COM qui clignote quand 
le périphérique est détecté. Pour connaître la signification des états de la 
LED sur votre périphérique particulier, reportez-vous à la documentation 
du périphérique, comme expliqué dans l’Étape 10. Naviguez dans la 
documentation du périphérique ou installez celle-ci. 

Étape 7. Lancez MAX
Double-cliquez sur l’icône Measurement & Automation qui se trouve sur 
le bureau pour ouvrir MAX.

Étape 8. Confirmez que le périphérique est reconnu
Suivez ces étapes :

1. Développez la rubrique Périphériques et interfaces. Si vous utilisez 
une cible RT déportée, développez l’élément Systèmes déportés, 
recherchez et développez votre cible, et développez ensuite la 
catégorie Périphériques et interfaces.

2. Vérifiez que votre périphérique apparaît bien sous Périphériques et 
interfaces.

Quand un périphérique est supporté à la fois par NI-DAQ traditionnel 
et NI-DAQmx et que ces deux drivers sont installés, le même 
périphérique apparaît sous un nom différent dans les dossiers NI-DAQ 
traditionnel et NI-DAQmx sous Système»Périphériques et 
interfaces.

Seuls les périphériques NI-DAQmx sont recensés sous Systèmes 
déportés»Périphériques et interfaces. Pour afficher des 
périphériques NI-DAQ traditionnel dans un système déporté, 
sélectionnez Outils»Configuration NI-DAQ»Configuration DAQ 
déportée pour ouvrir la fenêtre Configuration DAQ déportée.



Guide de démarrage DAQ 50 ni.com

Si votre périphérique n’apparaît pas, appuyez sur <F5> pour rafraîchir 
l’affichage dans MAX. Si votre périphérique n’est toujours pas 
reconnu, reportez-vous à la page ni.com/support/install pour 
obtenir des informations de dépannage.

3. Dans la rubrique de l’API NI-DAQ que vous utilisez pour programmer 
votre périphérique, cliquez avec le bouton droit sur le périphérique que 
vous voulez tester. 

• Si votre périphérique est sous NI-DAQ traditionnel, sélectionnez 
Propriétés, puis cliquez sur Tester les ressources dans la fenêtre 
de propriétés. NI-DAQ traditionnel ne comporte pas de panneaux 
de test pour le Module LabVIEW Real-Time.

• Si le périphérique est sous NI-DAQmx, sélectionnez Auto-test.
 

1 Les périphériques NI-DAQ traditionnel et NI-DAQmx sont recensés
2 Seuls les périphériques NI-DAQmx sont recensés

1

2
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Si vous avez besoin d’aide au cours de l’auto-test, ouvrez Aide 
Measurement & Automation Explorer pour NI-DAQmx en 
sélectionnant Aide»Rubriques de l’aide»NI-DAQmx. 

4. Au terme de l’auto-test, un message s’affiche, indiquant si la 
vérification s’est déroulée sans problème ou si une erreur a eu lieu. 
Si une erreur s’est produite, reportez-vous à ni.com/support/
install pour obtenir des informations de dépannage.

Étape 9. Configurez les paramètres du périphérique
Configurez chaque périphérique que vous installez :

1. Effectuez un clic droit sur le nom du périphérique et sélectionnez 
Propriétés. Assurez-vous de cliquer sur le nom du périphérique se 
trouvant dans le dossier de l’API de NI-DAQ que vous voulez utiliser 
pour commander le périphérique. Si vous utilisez une cible RT 
déportée, les périphériques NI-DAQmx sont répertoriés sous Systèmes 
déportés»Périphériques et interfaces.

2. Configurez les propriétés du périphérique. Pour utiliser un 
périphérique à la fois avec NI-DAQ traditionnel et NI-DAQmx, 
vous devez configurer ses propriétés dans les deux rubriques.

• Si vous utilisez un accessoire, ajoutez les informations relatives à 
celui-ci.

• Si vous utilisez un périphérique avec NI-DAQ traditionnel, vous 
pouvez changer ses paramètres par défaut pour les entrées 
analogiques, les sorties analogiques, l’OPC et l’accès déporté. 
Consultez la documentation qui accompagne votre périphérique, 
comme décrit à l’Étape 10. Naviguez dans la documentation du 
périphérique ou installez celle-ci, pour connaître ses paramètres 
par défaut.

• Si vous utilisez une cible RT déportée avec NI-DAQ traditionnel, 
sélectionnez Aide»Rubriques de l’aide»Systèmes déportés 
dans MAX afin d’obtenir des instructions sur la configuration des 
cibles RT déportées.

Pour consulter des instructions se rapportant à la configuration de 
périphériques SCXI pour des systèmes qui exécutent le Module 
LabVIEW Real-Time et NI-DAQ traditionnel, reportez-vous à la 
rubrique Hardware Installation/Configuration Troubleshooter sur 
ni.com/support/install. Sélectionnez Real-Time (RT)»
RT Configuration Wizard»SCXI on RT Systems.
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• Pour des capteurs et des accessoires TEDS (Transducer Electronic 
Data Sheet) IEEE 1451.4, configurez le périphérique et ajoutez les 
accessoires comme décrit plus haut. Cliquez sur Recherche de 
TEDS. Pour configurer des capteurs TEDS qui sont connectés 
directement à un périphérique, faites un clic droit sur le 
périphérique figurant sous Périphériques et interfaces et 
sélectionnez Configurer un TEDS.

3. Cliquez sur OK pour valider les changements.

Pour convertir des voies virtuelles, des configurations d’échelles et des 
configurations SCXI et d’accessoires NI-DAQ traditionnel en une 
configuration NI-DAQmx, sélectionnez Outils»Configuration 
NI-DAQmx»Convertir la configuration NI-DAQ traditionnel en 
NI-DAQmx. L’Assistant ne convertit pas les configurations SCC ; vous 
devez configurer les informations SCC séparément dans chaque API que 
vous souhaitez utiliser. Cliquez sur Aide dans l’Assistant pour obtenir des 
informations complémentaires sur la conversion de vos configurations.

Étape 10. Naviguez dans la documentation du 
périphérique ou installez celle-ci

Le kit logiciel NI-DAQ 7.x comprend une documentation en ligne pour les 
périphériques et les accessoires supportés, notamment des fichiers PDF et 
des fichiers d’aide décrivant les terminaux, les spécifications, les 
fonctionnalités et le mode d’opération du périphérique. Pour trouver, 
afficher et imprimer les documents se rapportant à chaque périphérique, 
insérez le CD Documentation des périphériques. Vous devez avoir Internet 
Explorer version 5.0 ou version ultérieure pour utiliser certaines 
fonctionnalités de la documentation NI-DAQ 7.x, comme par exemple 
l’aide et l’explorateur Device Document Browser. Après l’installation, 
vous pouvez accéder à l’explorateur et à la documentation du périphérique 
à partir de Démarrer»Programmes»National Instruments»NI-DAQ» 
Browse Device Documentation.

Si vous ne possédez pas ce CD, vous pouvez vous procurez la 
documentation en ligne sur les périphériques en allant sur ni.com/
manuals. Le Device Document Browser est disponible sur ni.com/
support ; sélectionnez Drivers and Updates»Most Popular» et la 
version NI-DAQ que vous utilisez pour ouvrir une page Web des 
Instructions d’installation. Téléchargez le CD 2 de NI-DAQ et suivez les 
instructions pour installer l’explorateur NI-DAQ Device Documentation 
Browser.
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Étape 11. Installez les périphériques de 
conditionnement de signal ou de commutation

Si votre système comprend des périphériques supplémentaires, comme des 
modules de conditionnement de signal ou des modules de commutation 
(switch), reportez-vous aux documents suivants pour installer et configurer 
le matériel de conditionnement de signal ou de commutation :

• Modules de conditionnement de signal SCXI : Reportez-vous au 
Guide de démarrage SCXI.

• Modules de commutation : Reportez-vous au document intitulé 
NI Switches Getting Started Guide.

• Composants de conditionnement de signal (SCC), tels que boîtiers SC 
et modules SCC modules : Reportez-vous au SCC Quick Start Guide.

Le reste de ce guide s’applique uniquement aux périphériques DAQ ou aux 
périphériques de conditionnement de signal intégré PXI.

Étape 12. Connectez les lignes de capteurs et de 
signaux

Connectez les lignes de capteurs et de signaux aux blocs de connexion 
ou aux terminaux accessoires. Des informations utiles sont disponibles 
comme suit :

• Connexions de signaux et de terminaux :

– Vous pouvez afficher un diagramme représentant les connexions 
des périphériques NI-DAQmx dans votre système à l’aide de 
l’Assistant DAQ. Cliquez sur l’onglet Diagramme des 
connexions. Sélectionnez chaque voie dans la tâche pour afficher 
les connexions nécessaires entre les capteurs et les blocs de 
connexion. Le nom et le nombre de terminaux sont répertoriés 
pour chaque connexion. L’outil Diagramme des connexions 
supporte actuellement les mesures d’entrées analogiques et la 
plupart des accessoires MIO et SCXI.

– L’aide E Series Help et les manuels de l’utilisateur des 
périphériques ou des accessoires sont compris dans l’explorateur 
Device Document Browser.

– Les affectations de broches sont décrites dans les rubriques Device 
Pinouts de l’Aide Measurement & Automation Explorer pour 
NI-DAQ traditionnel et dans l’Aide Measurement & Automation 
Explorer pour NI-DAQmx, ces deux documents étant accessibles 
à partir du menu de l’Aide MAX.



Guide de démarrage DAQ 54 ni.com

• Capteurs :

– Reportez-vous à ni.com/sensors.

– Si vous utilisez LabVIEW, reportez-vous au manuel LabVIEW 
Measurements Manual livré avec LabVIEW ou disponible à 
l’adresse ni.com/manuals. 

– Si vous utilisez NI-DAQmx, reportez-vous à la rubrique Sensors 
de l’NI-DAQmx Help, accessible à partir de Démarrer»
Programmes»National Instruments»NI-DAQ»NI-DAQmx 
Help.

– Si vous utilisez NI-DAQ traditionnel, reportez-vous au chapitre 5, 
Transducer Conversion Functions, du manuel Traditional 
NI-DAQ User Manual, accessible à partir de Démarrer»
Programmes»National Instruments»NI-DAQ»Traditional 
NI-DAQ User Manual.

– Pour obtenir des informations sur les capteurs intelligents TEDS 
IEEE 1451.4, consultez le site ni.com/zone. 

• Commutateurs : Les spécifications d’un module de commutation 
comprennent une topologie de ce périphérique.

Étape 13. Exécutez les panneaux de test
De nombreux périphériques comportent un panneau de test pour tester des 
fonctionnalités spécifiques à ce périphérique, par exemple sa capacité à 
acquérir ou à générer des signaux. 

1. Dans MAX, développez la catégorie Périphériques et interfaces»
Périphériques NI-DAQ traditionnel ou Périphériques et 
interfaces»Périphériques NI-DAQmx. Si vous utilisez une cible RT 
déportée, développez l’élément Systèmes déportés, recherchez et 
développez votre cible, et développez ensuite la catégorie 
Périphériques et interfaces.

2. Cliquez avec le bouton droit sur le périphérique à tester. Assurez-vous 
de cliquer sur le nom du périphérique se trouvant dans la rubrique de 
l’API de NI-DAQ que vous voulez utiliser.

3. Sélectionnez Panneaux de test pour ouvrir le panneau de test 
correspondant au périphérique sélectionné. NI-DAQ traditionnel 
ne comporte pas de panneaux de test pour le Module LabVIEW 
Real-Time.
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Un exemple de panneau de test est représenté dans la figure suivante. 

4. Cliquez sur les onglets pour tester différentes fonctions du 
périphérique. Cliquez sur Aide pour obtenir des instructions 
sur le fonctionnement des panneaux de tests dans NI-DAQmx. 
Reportez-vous à l’Aide Measurement & Automation Explorer 
pour NI-DAQ traditionnel pour obtenir des instructions sur le 
fonctionnement des panneaux de tests dans NI-DAQ traditionnel.
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5. Le panneau de test affiche un message indiquant si une erreur s’est 
produite. Reportez-vous à l’Aide NI-DAQmx ou à ni.com/support 
pour obtenir des informations de dépannage.

6. Cliquez sur Fermer pour quitter le panneau de test.

Étape 14. Configurez tous les nouveaux périphériques
Si vous avez installé plus d’un périphérique DAQ, répétez Étape 9. 
Configurez les paramètres du périphérique à Étape 13. Exécutez les 
panneaux de test pour chacun d’entre eux.

Étape 15. Configurez les voies et les tâches
Cette étape ne s’applique que si vous programmez votre périphérique à 
l’aide de NI-DAQ ou d’un logiciel d’application NI.

Une voie physique est un terminal ou broche sur lequel vous pouvez 
mesurer ou générer un signal analogique ou numérique. Une voie virtuelle 
est un ensemble de paramètres, comme un nom, une voie physique, des 
connexions d’entrée, le type de mesure ou de génération et pouvant inclure 
des informations de mise à l’échelle. Dans NI-DAQmx, les voies virtuelles 
font partie intégrante de la mesure. Dans NI-DAQ traditionnel, la 
configuration des voies virtuelles est une manière possible d’enregistrer les 
voies utilisées pour différentes mesures. La figure 6 représente la manière 
de configurer des voies dans NI-DAQmx et dans NI-DAQ traditionnel.

Figure 6.  Configuration de voies et de tâches dans NI-DAQmx et dans 
NI-DAQ traditionnel

NI-DAQmx
Utilisez l'Assistant DAQ, accessible à partir de

 MAX ou du logiciel d'applications NI, pour
  configurer les voies et les tâches de mesures.

Reportez-vous à l'Aide Assistant DAQ ou à
 l'Aide de Measurement & Automation

 Explorer pour NI-DAQmx.

Vous avez installé et configuré vos périphériques.

Quelle API
utilisez-vous 

pour programmer chaque 
périphérique ?

Traditional
NI-DAQUtilisez MAX pour configurer les voies. 

Reportez-vous à l'Aide de 
Measurement & Automation Explorer 

pour la version traditionnelle de NI-DAQ.

Configurez les voies et les tâches.
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Une tâche, qui représente un nouveau concept essentiel de NI-DAQmx, 
est un ensemble d’une ou de plusieurs voies virtuelles qui inclut l’horloge, 
le déclenchement et d’autres propriétés. Fondamentalement, une tâche 
représente la mesure ou la génération que vous voulez réaliser. Vous pouvez 
définir et enregistrer toutes les informations de configuration dans une 
tâche et l’utiliser dans une application.

Dans NI-DAQmx, les voies virtuelles peuvent être définies comme faisant 
partie d’une tâche ou être configurées séparément de celle-ci. Les voies 
virtuelles créées à l’intérieur d’une tâche sont des voies locales. Les voies 
virtuelles créées à l’extérieur d’une tâche sont des voies globales. Vous 
pouvez créer des voies globales depuis MAX ou depuis votre application 
logicielle, puis les enregistrer sous MAX. Vous pouvez utiliser les voies 
globales dans n’importe quelle application ou les ajouter à d’autres tâches. 
Si vous modifiez une voie globale, les changements affectent toutes les 
tâches dans lesquelles cette voie est utilisée. Dans la plupart des cas, il est 
plus simple d’utiliser les voies locales.

Configurer une tâche dans NI-DAQmx
Lorsque vous utilisez NI-DAQmx, configurez les tâches à l’aide de 
l’Assistant DAQ. Vous devez avoir la version 7.0 ou une version ultérieure 
du logiciel d’application NI pour créer des voies et des tâches avec 
l’Assistant DAQ.

• Dans MAX, cliquez avec le bouton droit sur Voisinage de données et 
sélectionnez Créer un nouvel objet. Dans la fenêtre Créer un nouvel 
objet, sélectionnez Tâche NI-DAQmx, puis cliquez sur Suivant.

Si vous utilisez une cible RT déportée, développez la catégorie 
Systèmes déportés, recherchez et développez votre cible, puis faites 
un clic droit sur Voisinage de données et sélectionnez Créer un 
nouvel objet.

• Vous pouvez également ouvrir directement l’Assistant DAQ à partir de 
votre logiciel d’application NI :

– Dans LabVIEW :

• Déposez le VI Express Assistant DAQ sur le diagramme à 
partir de la palette “Entrée” des VIs Express, comme expliqué 
dans le manuel Initiation à LabVIEW. 

• Vous pouvez également placer la commande Nom de tâche 
DAQmx sur la face-avant pour ouvrir l’Assistant DAQ. Faites 
un clic droit sur la commande et sélectionnez Nouvelle tâche 
(Assistant DAQ). Le tutorial d’aide Prendre une mesure 
NI-DAQmx dans LabVIEW contient des instructions 
pas-à-pas pour créer une tâche à partir de la commande Nom 
de tâche DAQmx et générer le code associé à la tâche. Dans 
LabVIEW, sélectionnez Aide»Prendre une mesure 
NI-DAQmx.
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– Dans LabWindows/CVI :

1. Sélectionnez Tools»Create/Edit DAQmx Tasks. La boîte de 
dialogue Create/Edit DAQmx Tasks s’ouvre.

2. Sélectionnez Create New Task In MAX ou Create New 
Task In Project et cliquez sur OK.

– Dans Measurement Studio : 

1. Ouvrez Visual Studio .NET et le projet dans lequel vous 
voulez créer la classe de tâche DAQmx.

2. Sélectionnez Project»Add New Item. La boîte de dialogue 
Add New Item s’affiche. 

3. Dans la sous-fenêtre Categories, sélectionnez Measurement 
Studio»Assistants.

4. Dans la sous-catégorie Templates, sélectionnez DAQmx 
Task Class.

5. Spécifiez le nom du fichier de tâche DAQmx et cliquez sur 
Open. 

6. Précisez si vous voulez créer une nouvelle tâche ou faire une 
copie de projet d’une tâche globale que vous créez dans 
MAX.

7. Cliquez sur Terminer.

L’Assistant DAQ vous invite alors à créer une nouvelle tâche :

1. Sélectionnez un type d’E/S, comme par exemple, une entrée 
analogique.

2. Sélectionnez la mesure ou la génération à réaliser.

3. Sélectionnez le capteur à utiliser, le cas échéant.

4. Cliquez sur Suivant. Une boîte de dialogue s’affiche pour la tâche que 
vous avez spécifiée, comme l’illustre l’exemple suivant.
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5. Sélectionnez les voies à ajouter à la tâche. Vous pouvez sélectionner 
des voies physiques à partir desquelles vous créez des voies locales 
dans la tâche et ajouter des voies globales à la tâche. 

6. Si votre système est configuré avec un capteur TEDS, cliquez sur 
l’onglet Voies TEDS. 

a. Sélectionnez la ou les voies physiques à utiliser. L’Assistant DAQ 
importe le paramètre du capteur et crée la tâche. 

b. Cliquez sur Suivant. 

7. Tapez le nouveau nom de la tâche. Cliquez sur Terminer.

8. Si nécessaire, configurez des paramètres de mesures spécifiques, 
le cadencement, le déclenchement et les informations de mise à 
l’échelle. Si une ou plusieurs voies sont configurées pour des capteurs 
TEDS, il est possible que certains paramètres chargés à partir de TEDS 
ne puissent pas être modifiés.

9. Si vous voulez ajouter une voie à la tâche pour un type de mesure 
différent, comme des voies de température ajoutées à une tâche de 
tension, cliquez sur le bouton Ajouter.

a. Sélectionnez dans la liste déroulante le type de mesure à ajouter. 
Une boîte de dialogue fait la liste de toutes les voies valides pour 
ce type de mesure. 
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b. Sélectionnez la voie ou les voies à ajouter. 

c. Cliquez sur le bouton OK.

d. Si vous le souhaitez, répétez l’étape 9 pour ajouter des types de 
mesure et des voies supplémentaires.

10. Enregistrez la tâche.

• Si vous avez ouvert l’Assistant DAQ à partir de LabVIEW ou de 
LabWindows/CVI, cliquez sur OK.

• Si vous l’avez ouvert à partir de Measurement Studio, 
sélectionnez File»Save.

• Si vous l’avez ouvert à partir de MAX, cliquez sur Enregistrer la 
tâche.

Vous pouvez maintenant utiliser la tâche dans une application. 

Configurer des voies globales dans NI-DAQmx
Lorsque vous utilisez NI-DAQmx, configurez les voies globales à l’aide de 
l’Assistant DAQ.

• Pour ouvrir l’Assistant DAQ dans MAX, faites un clic droit sur 
Voisinage de données et sélectionnez Créer un nouvel objet.

Si vous utilisez une cible RT déportée, développez la catégorie 
Systèmes déportés, recherchez et développez votre cible, puis faites 
un clic droit sur Voisinage de données et sélectionnez Créer un 
nouvel objet.

Dans la fenêtre Créer un nouvel objet, sélectionnez Voie globale 
NI-DAQmx, puis cliquez sur Suivant.

• Vous pouvez également ouvrir directement l’Assistant DAQ à partir de 
votre logiciel d’application NI : 

– Dans LabVIEW, utilisez la commande Voie globale DAQmx pour 
ouvrir l’Assistant DAQ. Cliquez avec le bouton droit sur la 
commande et sélectionnez Nouvelle voie (Assistant DAQ).

– Dans LabWindows/CVI ou Measurement Studio, vous devez 
d’abord créer une tâche, comme expliqué précédemment. Dans 
l’Assistant DAQ, cliquez sur Ajouter des voies globales pour 
ajouter des voies globales à votre tâche. Vous devez utiliser MAX 
pour créer des voies globales.

L’Assistant DAQ vous invite alors à créer une nouvelle voie globale :

1. Sélectionnez un type d’E/S, comme par exemple, une entrée 
analogique. 

2. Sélectionnez la mesure ou la génération à réaliser. 

3. Sélectionnez le capteur à utiliser, le cas échéant. 
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4. Une boîte de dialogue pour la tâche que vous avez spécifiée vous 
invite à sélectionner les voies à ajouter à cette tâche. Vous pouvez 
sélectionner des voies physiques à partir desquelles vous créez des 
voies locales dans la tâche et ajouter des voies globales à la tâche.

Si votre système est configuré avec un capteur TEDS, cliquez sur 
l’onglet Voies TEDS. Sélectionnez la ou les voies physiques à utiliser. 
L’Assistant DAQ importe le paramètre du capteur et utilise cette 
information pour créer la tâche.

5. Configurez les paramètres de mesure spécifiques. Si une ou plusieurs 
voies sont configurées pour des capteurs TEDS, il est possible que 
certains paramètres chargés à partir de TEDS ne puissent pas être 
modifiés.

6. Enregistrez la voie.

• Si vous avez ouvert l’Assistant DAQ à partir de LabVIEW ou de 
LabWindows/CVI, cliquez sur OK.

• Si vous l’avez ouvert à partir de Measurement Studio, 
sélectionnez File»Save.

• Si vous l’avez ouvert à partir de MAX, cliquez sur Enregistrer la 
voie.

Vous pouvez maintenant utiliser la voie globale dans une application ou 
l’ajouter dans une tâche. 

Configurer des voies virtuelles pour NI-DAQ traditionnel
Lorsque vous utilisez NI-DAQ traditionnel, effectuez les étapes suivantes 
pour configurer des voies virtuelles dans MAX :

1. Ouvrez l’Assistant de Création d’une nouvelle voie. 

• Dans MAX, cliquez avec le bouton droit sur Voisinage de 
données et sélectionnez Créer un nouvel objet. Dans la fenêtre 
Créer un nouvel objet, sélectionnez Voie virtuelle NI-DAQ 
traditionnel, puis cliquez sur Terminer. 

• Si vous utilisez une cible RT déportée avec NI-DAQ traditionnel, 
sélectionnez Outils»Configuration NI-DAQ traditionnel»
Configuration DAQ déportée. Les périphériques NI-DAQ 
traditionnel d’un système déporté sont recensés dans la fenêtre 
Configuration DAQ déportée. Sélectionnez Voie et cliquez sur 
Ajouter. 
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2. Suivez les instructions de cet Assistant pour créer une nouvelle voie. 
Pour obtenir des informations complémentaires sur la manière de 
configurer des voies, reportez-vous à l’Aide Measurement & 
Automation Explorer pour NI-DAQ traditionnel.

Étape 16. Utilisez votre tâche dans une application
Effectuez les étapes suivantes pour utiliser une tâche de mesure dans votre 
application. Reportez-vous à l’Aide Assistant DAQ pour obtenir de plus 
amples informations sur la manière d’utiliser une tâche ou de générer du 
code.

LabVIEW
1. Ouvrez un VI vide dans LabVIEW. 

2. Placez la constante suivante sur le diagramme : Mesures NI»
DAQmx - Acquisition de données»Constante de nom de tâche 
DAQmx.

3. Sélectionnez la tâche dans la liste déroulante. 

4. Faites un clic droit sur le VI et sélectionnez Générer le code»
Exemple.

5. Exécutez le programme à partir de la face-avant. 

LabWindows/CVI
Reportez-vous à ni.com/info et tapez rddq73 pour obtenir des 
instructions pas à pas sur l’utilisation d’une tâche dans LabWindows/CVI. 
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Measurement Studio
Reportez-vous à ni.com/info et tapez rddqms pour obtenir des 
instructions pas à pas sur l’utilisation d’une tâche dans Measurement 
Studio.

Conseils pour le développement d’une application

Comment utiliser les exemples
Chaque API inclut un ensemble d’exemples de programmation vous 
permettant de démarrer le développement d’une application. Vous pouvez 
modifier le code d’un exemple et l’enregistrer dans une nouvelle 
application. Vous pouvez utiliser les exemples pour développer une 
nouvelle application ou ajouter le code des exemples dans une application 
existante.

Pour trouver des exemples en LabVIEW ou en LabWindows/CVI, 
sélectionnez Aide»Recherche d’exemples, afin d’ouvrir l’Outil de 
recherche d’exemples National Instruments.

Les exemples de NI-DAQmx pour les différents langages supportés par 
Measurement Studio sont dans :

• MeasurementStudioVS2003\VCNET\Examples\DAQmx 

• MeasurementStudioVS2003\DotNET\Examples\DAQmx

Les exemples de NI-DAQ traditionnel pour Visual Basic se trouvent dans 
les répertoires suivants :

• Le répertoire NI-DAQ\Examples\Visual Basic avec 
Measurement Studio contient un lien vers les exemples de 
commandes ActiveX à utiliser avec Measurement Studio.

• Le répertoire NI-DAQ\Examples\VBasic contient des exemples non 
associés à Measurement Studio.

Les exemples de NI-DAQmx en ANSI C se trouvent dans le répertoire 
NI-DAQ\Examples\DAQmx ANSI C.

Les exemples de NI-DAQ traditionnel en ANSI C se trouvent dans le 
répertoire NI-DAQ\Examples\VisualC.

Pour consulter des centaines d’autres exemples, visitez le site 
ni.com/zone.
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Informations sur les périphériques et les applications de mesure
Vous pouvez vous procurer des informations sur vos périphériques et 
applications de mesure aux endroits suivants.

LabVIEW
Si vous êtes un nouvel utilisateur, lisez la totalité du document Initiation à 
LabVIEW pour vous familiariser avec LabVIEW. Sélectionnez 
Démarrer»Programmes»National Instruments»LabVIEW 7.x»
Recherche dans les manuels PDF. 

Le manuel LabVIEW Measurements Manual contient une vue d’ensemble 
des API de NI-DAQ traditionnel et NI-DAQmx, ainsi qu’une description 
des concepts de mesure. Sélectionnez Démarrer»Programmes»National 
Instruments»LabVIEW 7.x»Recherche dans les manuels PDF.

Le tutorial d’aide Prendre une mesure NI-DAQmx dans LabVIEW contient 
des instructions pas à pas pour configurer une mesure avec LabVIEW. 
Il décrit aussi les nouvelles fonctionnalités clés de NI-DAQmx et les 
nouveaux concepts, comme l’Assistant et les tâches DAQ. Dans LabVIEW, 
sélectionnez Aide»Prendre une mesure NI-DAQmx.

L’Aide LabVIEW comprend une section Référence des VIs et des fonctions 
qui décrit les VIs LabVIEW et les propriétés pour NI-DAQmx et NI-DAQ 
traditionnel. Dans LabVIEW, sélectionnez Aide»Aide LabVIEW et 
parcourez la rubrique principale Référence des VIs et des fonctions dans 
l’onglet Sommaire pour trouver la section Référence des VIs et des 
fonctions pour l’API NI-DAQ que vous utilisez. 

Module LabVIEW Real-Time
Sélectionnez Démarrer»Programmes»National Instruments»
LabVIEW 7.x»Module Documents»Search the LabVIEW Real-Time 
Module Bookshelf pour obtenir des liens vers les documents du Module 
LabVIEW Real-Time. 

LabWindows/CVI
Si vous êtes un nouvel utilisateur, lisez la totalité du document 
Getting Started with LabWindows/CVI pour vous familiariser avec 
LabWindows/CVI. Dans LabWindows/CVI, sélectionnez Help»
LabWindows/CVI Bookshelf. 

L’aide LabWindows/CVI Help contient une référence des concepts de 
mesure et des fonctions NI-DAQmx. Dans LabWindows/CVI, sélectionnez 
Help»Contents.
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Measurement Studio
Le document NI Measurement Studio Help contient une vue d’ensemble de 
l’API de NI-DAQmx, des tâches et des concepts de mesure, ainsi qu’une 
référence des fonctions. Ce fichier d’aide est intégré dans la documentation 
de Visual Studio .NET. Dans Visual Studio .NET, sélectionnez 
Help»Contents.

Le document Measurement Studio Reference contient une vue d’ensemble 
de l’API NI-DAQ traditionnel, des concepts de mesures et une référence 
des fonctions. Dans Visual Studio .NET, sélectionnez Measurement 
Studio»Measurement Studio Reference.

ANSI C sans logiciel d’application NI
Le document Traditional NI-DAQ User Manual  et l’Aide NI-DAQmx Help 
contiennent une vue d’ensemble des API. L’Aide NI-DAQmx contient aussi 
des informations d’ordre général sur les concepts de mesures. Les 
documents Traditional NI-DAQ Function Reference Help et NI-DAQmx C 
Reference Help décrivent l’ensemble des fonctions C et des attributs. 
Sélectionnez Démarrer»Programmes»National Instruments»
NI-DAQ»titre du document pour l’API de NI-DAQ que vous utilisez.

Langages .NET sans logiciel d’application NI
Le document NI Measurement Studio Help contient une vue d’ensemble de 
l’API de NI-DAQmx, des tâches et des concepts de mesure, ainsi qu’une 
référence des fonctions. Ce fichier d’aide est intégré dans la documentation 
de Visual Studio .NET. Dans Visual Studio .NET, sélectionnez Help»
Contents.

Remarque Si vous utilisez un langage .NET sans Visual Studio .NET, il se peut que vous 
ne puissiez pas ouvrir NI Measurement Studio Help.

Documentation des périphériques
NI-DAQ 7.x comprend une documentation en ligne pour les périphériques 
et les accessoires supportés, notamment des fichiers PDF et des fichiers 
d’aide décrivant les terminaux, les spécifications, les fonctionnalités et le 
mode d’opération du périphérique. Pour trouver, afficher et imprimer les 
documents se rapportant à chaque périphérique, insérez le CD 
Documentation des périphériques NI-DAQ. Après avoir installé 
l’explorateur Device Document Browser, les documents du périphérique 
sont accessibles en allant dans Démarrer»Programmes»National 
Instruments»NI-DAQ»Browse Device Documentation.



Guide de démarrage DAQ 66 ni.com

NI 435x
Une fois que vous aurez fini de configurer et de tester le NI 435x, vous 
pourrez utiliser VirtualBench-Logger pour contrôler le NI 435x sans 
qu’aucune programmation ne soit nécessaire. Reportez-vous à Getting 
Started with VirtualBench et à ni.com/manuals pour apprendre à utiliser 
les fonctionnalités du VirtualBench-Logger.

Utilisation de NI-DAQ traditionnel et de NI-DAQmx sur le même 
ordinateur

Les applications existantes développées avec une version antérieure de 
NI-DAQ s’exécuteront avec NI-DAQ traditionnel. Vous pouvez utiliser 
simultanément les API de NI-DAQ traditionnel et NI-DAQmx sur le même 
ordinateur, à condition de respecter les restrictions suivantes :

• Une seule API contrôle un périphérique donné à un moment donné.

– Après avoir utilisé un périphérique avec NI-DAQmx, vous devez 
réinitialiser toutes les tâches NI-DAQmx qui l’ont utilisé avant de 
vous en servir avec NI-DAQ traditionnel. Si vous utilisez un 
périphérique dans NI-DAQmx, puis dans NI-DAQ traditionnel 
sans réinitialiser les tâches NI-DAQmx, le code d’erreur -10461 
est renvoyé. Pour réinitialiser les tâches NI-DAQmx, appelez les 
VIs ou fonctions DAQmx - Réinitialiser une tâche. 

– Après avoir utilisé un périphérique avec NI-DAQ traditionnel, 
vous devez le réinitialiser avant de vous en servir avec 
NI-DAQmx. Si vous utilisez un périphérique dans NI-DAQ 
traditionnel, puis dans NI-DAQmx sans le réinitialiser, le code 
d’erreur -200324 est renvoyé. 

Pour les périphériques SCXI, vous devez d’abord réinitialiser le 
périphérique DAQ dans NI-DAQ traditionnel avant de pouvoir 
l’utiliser dans NI-DAQmx. Par exemple, les périphériques DAQ 
de la série E utilisent les lignes 0, 1, 2 et 4 sur le port 0 pour 
communiquer avec le module SCXI. Le code d’erreur -200158 
est renvoyé si vous ne réinitialisez pas le périphérique de 
communication dans NI-DAQ traditionnel avant de l’utiliser dans 
NI-DAQmx, comme indiqué ci-après : 

• Appelez le VI Réinitialiser un périphérique (Device Reset.vi) 
de NI-DAQ traditionnel ou la fonction Init_DA_Brds. 

• Pour réinitialiser des périphériques dans NI-DAQ traditionnel 
à partir de MAX, vous devez d’abord réinitialiser tous les 
périphériques à la fois. Effectuez un clic droit sur le répertoire 
Périphériques NI-DAQ traditionnel dans MAX et 
sélectionnez Réinitialiser le driver pour NI-DAQ 
traditionnel. Pour une cible RT déportée, vous devez utiliser 
le VI Réinitialiser un périphérique de NI-DAQ traditionnel.
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• Dans un système d’acquisition de données SCXI, vous devez utiliser 
la même API pour programmer tous les périphériques : périphériques 
DAQ connectés et modules SCXI insérés.

Reportez-vous à l’adresse ni.com/support pour obtenir des détails et des 
instructions sur les sujets suivants :

• Comment ajouter du code NI-DAQmx dans une application NI-DAQ 
traditionnel

• Comment exécuter deux applications développées avec NI-DAQmx et 
NI-DAQ traditionnel et qui utilisent le même périphérique

Dépannage
Utilisez les ressources suivantes si vous vous heurtez à des problèmes lors 
de l’installation de votre matériel et/ou logiciel DAQ : 

• Pour consulter des instructions de dépannage, reportez-vous à la 
rubrique Hardware Installation/Configuration Troubleshooter sur 
ni.com/support/install.

• Reportez-vous à ni.com/kb pour accéder aux documents de 
dépannage se rapportant aux problèmes courants d’installation 
et de programmation, et pour obtenir les réponses aux questions 
fréquemment posées concernant les produits NI. 

• Si vous pensez avoir endommagé votre périphérique et que vous jugez 
devoir retourner votre matériel National Instruments pour le faire 
réparer ou étalonner, reportez-vous à ni.com/support et faites une 
recherche sur Sending a Board for Repair or Calibration pour savoir 
comment procéder pour obtenir une Autorisation de renvoi de 
marchandise (RMA - Return Merchandise Authorization). 

Support technique dans le monde entier
Visitez les sections suivantes du site Web de National Instruments sur 
ni.com pour obtenir une assistance technique et des services 
professionnels :

• Support : Les ressources de support technique en ligne sur 
ni.com/support comprennent notamment :

– Ressources d’auto-assistance : Pour des réponses et des 
solutions immédiates, visitez le site Web réputé de National 
Instruments pour vous procurer des drivers et des mises à jour de 
logiciels, avoir accès à une base de données (KnowledgeBase) 
dans laquelle vous pouvez effectuer des recherches, aux manuels 
sur les produits, à des assistants de dépannage, obtenir des milliers 
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d’exemples de programmes, des tutoriaux, des notes 
d’application, et bien plus encore.

– Support technique gratuit : Tous les utilisateurs enregistrés 
peuvent bénéficier du Service de base gratuit, qui vous offre la 
possibilité de contacter des centaines d’ingénieurs d’application 
dans le monde entier, dans le cadre de NI Developer Exchange sur 
ni.com/exchange. Les ingénieurs d’application de National 
Instruments veillent à répondre à chacune de vos questions.

• Formation et certification : Visitez ni.com/training pour avoir 
accès à une formation dont vous contrôlez l’allure, à des salles de cours 
d’instruction virtuelle (eLearning), vous procurer des CD interactifs et 
des informations sur le programme de certification. Vous pouvez 
également vous inscrire à des cours de formation dispensés par des 
instructeurs partout dans le monde.

• Intégrateurs : Si vous devez concilier délais serrés, ressources 
techniques limitées et toute autre contrainte, nous vous invitons à faire 
appel aux intégrateurs du Programme Alliance NI. Pour en savoir plus, 
appelez votre filiale locale ou visitez le site ni.com/alliance.

• Declaration of Conformity (DoC) : la déclaration de conformité ou 
DoC est notre déclaration de conformité avec le Conseil des 
communautés européennes et s’appuie sur la déclaration de conformité 
du fabricant. Ce système confère à l’utilisateur une protection en 
matière de compatibilité des produits électroniques (EMC). Vous 
pouvez vous procurer la DoC pour votre produit en visitant 
ni.com/certification.

• Certificat d’étalonnage : Si votre produit supporte l’étalonnage, vous 
pouvez obtenir un certificat d’étalonnage sur ni.com/calibration.

Le siège social de National Instruments est situé à cette adresse : 11500 
North Mopac Expressway, Austin, Texas, 78759-3504, États-Unis. Visitez 
la section sur les bureaux à l’échelle mondiale, sur ni.com/niglobal 
pour accéder aux sites Web des succursales internationales, afin d’obtenir 
des informations à jour sur leurs coordonnées, le numéro de téléphone et 
adresse e-mail de leur service de support technique, ainsi que des 
informations sur les événements d’actualité.

Support dans NI-DAQ 7.3
La version 7.3 de NI-DAQmx ne prend pas encore en charge la totalité de 
la gamme de périphériques de mesure NI. Les prochaines versions de 
NI-DAQ offriront un support plus étendu des nouveaux périphériques et 
des périphériques existants de NI-DAQmx, et continueront à inclure 
NI-DAQ traditionnel.



© National Instruments Corporation 69 Guide de démarrage DAQ

Support des systèmes d’exploitation
NI-DAQmx et NI-DAQ traditionnel version 7.3, et NI-SWITCH 2.3 
supportent Windows 2000/NT/XP. NI-DAQ 7.x sous Windows NT 
exige le Service Pack 6 ou plus récent.

NI-DAQmx 7.3 supporte PharLap uniquement avec le Module 
LabVIEW Real-Time 7.1. 

Measurement Studio nécessite Visual Studio .NET 2003, qui lui-même 
nécessite Windows 2000/NT 4.0/XP. 

Pour connaître les instructions d’installation spécifiques à un système 
d’exploitation, utilisez le’Hardware Installation/Configuration 
Troubleshooter à l’adresse ni.com/support/install.

Pour trouver et télécharger une version antérieure de NI-DAQ qui supporte 
les autres systèmes d’exploitation, reportez-vous à la page ni.com/
downloads. 

Support des l’environnements de développement
Le tableau 1 liste les versions des logiciels d’application supportés par 
NI-DAQmx et NI-DAQ traditionnel. Si vous n’utilisez pas un logiciel 
d’application NI, reportez-vous au tableau 2.

 
Tableau 1.  Logiciels d’application supportés par NI-DAQ 7.x

Logiciels d’application NI

Versions 
supportées par 

NI-DAQmx

Versions 
supportées par 

NI-DAQ 
traditionnel

LabVIEW  7.x 6.1–7.x

Module LabVIEW Real-Time 7.11 6.1–7.x

LabWindows/CVI  7.x 6.0–7.x

Measurement Studio  7.x 6.0–7.x 2

1 Pour utiliser le Module LabVIEW Real-Time 7.1 avec NI-DAQmx, vous devez utiliser 
NI-DAQmx version 7.2 ou version ultérieure.
2  NI-DAQ traditionnel n’inclut pas d’interfaces Measurement Studio C++ ou .NET.
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Support des langages de programmation
 

Les versions antérieures de NI-DAQ supportent d’autres versions de ces 
langages et logiciels d’application. Pour trouver et télécharger une version 
antérieure du driver, reportez-vous à la page ni.com/downloads.

Support des périphériques
Pour obtenir les noms spécifiques des périphériques, consultez le fichier 
NI-DAQ 7.x Readme du CD. Le tableau 3 recense les familles de 
périphériques supportées dans NI-DAQ 7.3 par NI-DAQmx et NI-DAQ 
traditionnel. 

Tableau 2.  Langages de programmation supportés par NI-DAQ 7.x

Langage de programmation

Versions 
supportées par 

NI-DAQmx

Versions 
supportées par 

NI-DAQ 
traditionnel

ANSI C 3 3

Microsoft Visual C++
Bibliothèques de classes
DLL C

7.x 1

6.0–7.x
—

6.0–7.x

Visual Basic 6.0 via ActiveX — 6.0

Langages Microsoft .NET
(C# et Visual Basic .NET)

.NET 1.1 —

1 Nécessite la version 7.x de Measurement Studio.

Tableau 3.  Périphériques supportés par NI-DAQ 7.3

Périphérique NI-DAQmx
NI-DAQ 

traditionnel

DAQ multifonction

Périphériques PCI et PXI de la série E, comme le NI PCI-6052E ✓ ✓

Périphériques NI DAQCard-6024E, NI DAQCard-6036E et NI DAQCard-6062E 
de la série E au format PCMCIA

✓ ✓

Série E au format AT — ✓

Périphériques classiques 16 bits NI PCI-6013/6014 ✓ ✓

Périphériques NI DAQPad-6015/6016 pour USB ✓ —

Périphériques NI DAQPad-6020E/6052E/6070E pour USB et FireWire (IEEE 1394) — ✓

Périphériques NI PCI-7041/6040E pour LabVIEW RT ✓ ✓

Périphérique NI PXI et PCI-7030 pour LabVIEW RT — ✓

Périphériques NI PXI-6132/6133 et NI PXI de la série S, et PCI-6143 ✓ —
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DAQ multifonction (suite)

Périphériques NI PCI-6110/6111 de la série S ✓ ✓

Tout autre périphérique de la série S, comme le NI PXI-6115 — ✓

Sorties/waveform analogiques

NI PXI et PCI-6711/6713 waveform ✓ ✓

PCMCIA NI DAQCard-6715 ✓ ✓

NI PXI et PCI-6722/6723 ✓ —

NI PXI et PCI-6731/6733 ✓ ✓

NI 6703/6704 — ✓

AT-AO-6/10 — ✓

Entrées analogiques : DAQCard-AI-16E-4 et DAQCard-AI-16XE-50 au format PCMCIA — ✓

Compteur

NI PCI-6601/6602 ✓ ✓

NI PXI-6602 ✓ —

NI PXI-6608 — ✓

NI PXI et PCI-6624 isolé ✓ —

DAQ haute précision : NI 4350/4351 — ✓

E/S numériques

NI 6503, NI PXI-6508, NI 6527 et NI PCI-DIO-96 ✓ ✓

NI 6509/6510/6511/6512/6513/6514/6515/6516/6517/6518/6519 et NI 6528 ✓ —

NI 653X numérique haute vitesse — ✓

NI DAQCard-DIO-24 pour PCMCIA ✓ ✓

NI DAQPad-6507/6508 pour USB — ✓

PC-DIO-24 et PC-DIO-96 — ✓

AT-DIO-32F — ✓

Acquisition du signal dynamique

NI PXI-4461 ✓ —

NI PXI-4472/4472B et PCI-4472/4474 ✓ ✓

NI PCI-4451/4452/4454 et 4551/4552 — ✓

Conditionnement du signal

Modules SCXI-1521/B et SCXI-1600 ✓ —

Tous les autres modules de conditionnement de signal SCXI ✓ ✓

Conditionnement de signal intégré NI PXI-4200/4204/4220 ✓ —

Tableau 3.  Périphériques supportés par NI-DAQ 7.3 (Suite)

Périphérique NI-DAQmx
NI-DAQ 

traditionnel
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Davantage de périphériques dans les futures 
versions de NI-DAQmx
Dans les futures versions de NI-DAQ, NI-DAQmx supportera des 
périphériques qui ne sont actuellement supportés que par NI-DAQ 
traditionnel. 

Périphériques qui ne sont plus supportés par 
NI-DAQ 7.x
Les produits suivants ne sont pas supportés par NI-DAQ 7.x (ni par 
NI-DAQmx, ni par NI-DAQ traditionnel) et ne le seront pas par les 
versions futures de NI-DAQ. Vous devez utiliser la version 6.9.x de 
NI-DAQ ou une version antérieure pour programmer ces périphériques :

Conditionnement du signal (suite)

Modules de la série SCC ✓ ✓

Périphériques TEDS : BNC-2096, boîtier SC-2350 et SCXI-1314T
Remarque :  Ces périphériques supportent la lecture et l’écriture dans les capteurs TEDS.

✓ —

Commutation (Switch)

Modules NI SCXI-1160, SCXI-1161 et SCXI-1163R ✓ ✓

Tous les autres modules de commutation SCXI ✓ —

Modules de commutation PXI ✓ —

NI AT-MIO-16F-5 NI PC-AO-2DC

NI DAQCard-500 NI PC-LPM-16/PNP

NI DAQCard-516 NI PC-OPDIO-16

NI DAQCard-700 NI PC-TIO-10

NI DAQCard-1200 NI PCI-1200

NI DAQCard-AO-2DC NI SCXI-1200

NI DAQPad-1200 NI SCXI-2000

NI DAQPad-MIO-16XE-50 NI SCXI-2400

NI Lab-PC et Lab-PC+ Modules NI VXI DAQ

NI Lab-PC-1200/AI Boîtiers et modules NI VXI-SC

NI PC-516 Blocs de connexion NI VXI-TB pour bus VXI

Tableau 3.  Périphériques supportés par NI-DAQ 7.3 (Suite)

Périphérique NI-DAQmx
NI-DAQ 

traditionnel
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DAQ-Schnellstartanleitung
In der vorliegenden Broschüre erhalten Sie eine Anleitung zur Installation 
Ihrer Datenerfassungsgeräte und der Treibersoftware NI-DAQ 7.x und 
erfahren, wie die Geräte auf Funktionstüchtigkeit überprüft werden.

NI-Schaltmodule werden in diesem Buch nicht behandelt. Lesen Sie daher 
zur Installation und Konfiguration solcher Module den NI Switches Getting 
Started Guide.
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Symbole und Darstellungen
In dieser Anleitung werden folgende Symbole und Darstellungen 
verwendet:

<> Mit eckigen Klammern sind Funktionstasten gekennzeichnet.

» Das Symbol » gibt die Reihenfolge an, in der Menübefehle und 
Dialogoptionen anzuklicken sind. So wird zum Beispiel mit der Abfolge 
Datei»Seiteneinstellungen»Optionen angezeigt, dass zunächst das Menü 
Datei zu öffnen ist, hieraus die Option Seiteneinstellungen und 
anschließend der Befehl Optionen zu wählen ist.

Dieses Symbol kennzeichnet einen Hinweis und macht auf wichtige 
Informationen aufmerksam.

Mit diesem Symbol soll vor Datenverlust, Systemabsturz oder möglichen 
Verletzungen gewarnt werden. Welche Vorsichtsmaßnahmen bei mit 
diesem Symbol gekennzeichneten Produkten zu treffen sind, wird in der 
mit dem Produkt ausgelieferten Broschüre Read Me First: Safety and 
Radio-Frequency Interference erläutert.

Bei Produkten, die mit diesem Symbol gekennzeichnet sind, besteht die 
Gefahr eines elektrischen Schlags.

Wenn dieses Symbol auf einem Produkt zu sehen ist, bedeutet das, dass 
eines der Bauteile heiß werden kann. Bei Berührung besteht die Gefahr von 
Verletzungen.
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fett In fettgedruckter Schrift sind Elemente dargestellt, die ausgewählt oder 
angeklickt werden müssen, wie beispielsweise Menüelemente oder 
Dialogoptionen. 

kursiv Kursiv sind Querverweise gedruckt, erstmals erwähnte wichtige Termini 
und Textstellen, die als Platzhalter fungieren.

monospace In Schreibmaschinenschrift sind Textstellen oder Zeichen dargestellt, die 
über die Tastatur einzugeben sind, wie Laufwerksbuchstaben, Fehlercodes, 
Pfade, Verzeichnisse, Programme, Funktionen, Dateinamen oder 
Erweiterungen.

NI-DAQ 7.x
Die Messgeräte von National Instruments werden mit dem NI-DAQ-Treiber 
ausgeliefert, der zur Programmierung der Datenerfassungsgeräte dient und 
eine Vielzahl von Funktionen und VIs für Anwendungen wie LabVIEW 
oder LabWindows™/CVI™ enthält. Datenerfassungsgeräte gehören zu den 
Messgeräten und umfassen beispielsweise Multifunktions-I/O-Geräte 
(MIO-Geräte der E-Serie), SCXI-Module zur Signalaufbereitung oder 
Schaltmodule. Zum Treiber gehört auch eine Programmieroberfläche (API) 
in Form einer Bibliothek aus VIs, Funktionen, Klassen, Attributen und 
Eigenschaften zum Erstellen messtechnischer Anwendungen.

In NI-DAQ 7.x sind zwei NI-DAQ-Treiber mit jeweils eigener Funktionen- 
und VI-Bibliothek sowie Hardware- und Softwarekonfiguration integriert. 

• Der traditionelle NI-DAQ-Treiber ist eine aktualisierte Version des 
früheren NI-DAQ-Treibers. Er unterscheidet sich nur insofern von 
NI-DAQ 6.9.3, dass er auch parallel zu NI-DAQmx verwendbar ist. 

• NI-DAQmx ist eine Neuentwicklung. Er weist gegenüber dem traditio-
nellen NI-DAQ-Treiber folgende wesentliche Vorteile auf:

– Zu NI-DAQmx gehört ein so genannter DAQ-Assistent, in dem 
Sie Kanäle und Tasks für Messungen mit einem bestimmten Gerät 
konfigurieren und diese Einstellungen in Programmcode für 
LabVIEW, LabWindows/CVI und Measurement Studio umwan-
deln lassen können.

– Leistungsfähigere Funktionen, zum Beispiel schnellere Ein- und 
Ausgabe einzelner Werte oder Multithreading.

– Einfachere, intuitiver gestaltete Programmierschnittstelle zum 
Erstellen von DAQ-Applikationen, die mit weniger VIs und 
Funktionen als frühere Versionen von NI-DAQ auskommt.

– Größere Vielfalt von LabVIEW-Funktionen, beispielsweise durch 
Eigenschaftsknoten oder Funktionen, die Signalverläufe verarbei-
ten können.
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– Ähnliche APIs und Funktionen für ANSI C, LabWindows/CVI 
und Measurement Studio, einschließlich systemeigener .NET- 
und C++-Schnittstellen.

– Verbesserte Unterstützung für das LabVIEW Real-Time Module 
und höhere Leistung in LabVIEW Real-Time.

Anwendungsbereiche von NI-DAQmx
NI-DAQmx ist zu installieren:

• Bei der Verwendung von Windows 2000/NT/XP.

• Bei der ausschließlichen Nutzung von Geräten, die von NI-DAQmx 
unterstützt werden. Eine Übersicht über alle Geräte, für die 
NI-DAQmx geeignet ist, befindet sich im Abschnitt Unterstützung in 
NI-DAQ 7.3 am Ende dieser Anleitung.

• Bei Measurement-Studio-.NET-Sprachen oder Geräten, die nur von 
NI-DAQmx unterstützt werden (beispielsweise PXI-4024, NI 4461 
oder NI 6509).

Wenn Sie NI-DAQmx mit einer Entwicklungsumgebung von National 
Instruments verwenden möchten (LabVIEW, LabWindows/CVI oder 
Measurement Studio), benötigen Sie mindestens die Version 7.x dieser 
Software oder das LabVIEW Real-Time Module 7.1.

Anwendungsbereiche des traditionellen NI-DAQ-Treibers
In folgenden Fällen sollte auf den traditionellen NI-DAQ-Treiber zurück-
gegriffen werden:

• Bei Geräten, für die sich NI-DAQmx nicht eignet (zum Beispiel bei 
Multifunktions-DAQ-Geräten der AT-E-Serie).

• Im Fall, dass Sie bisher mit NI-DAQ 6.9.x gearbeitet haben und Ihren 
Treiber jetzt aktualisieren, die erstellten Anwendungen jedoch noch 
nicht auf DAQmx umstellen möchten. 

• Bei Nutzung einer LabVIEW-, LabWindows/CVI- oder 
Measurement-Studio-Version vor 7.0.

• Bei der Verwendung von Visual Basic 6.0.

• Beim LabVIEW Real-Time Module für Mac OS.

Hinweis Anwendungsprogramme von National Instruments werden seit der Version 6.0 
des traditionellen NI-DAQ-Treibers unterstützt. Für LabVIEW, LabWindows/CVI und 
Measurement Studio 6.x kann daher auch der traditionelle NI-DAQ-Treiber auf der 
NI-DAQ-7.x-CD verwendet werden.
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Komponenten, die nicht mehr vom traditionellen DAQ-Treiber unter-
stützt werden

Folgende Komponenten sind nur noch mit NI-DAQ 6.9.3 kompatibel:

• LabVIEW-, LabWindows/CVI- oder Measurement-Studio-Versionen 
vor 6.0

• Windows Me/98/95

• Einige ältere Geräte, wie die Multifunktions-DAQ-Geräte der 1200er 
Serie, VXI-Karten zur Datenerfassung oder SCXI-Module in Netz-
werken. Eine Übersicht über alle Geräte, die mit den aktuellen 
NI-DAQ-Treibern nicht mehr ansteuerbar sind, finden Sie im 
Abschnitt Geräte, die von NI-DAQ 7.x nicht mehr unterstützt werden 
am Ende dieser Anleitung. 

Systemintegration von NI-DAQ
In Abbildung 1 wird dargestellt, in welchen Schritten in einem Messsystem 
eine physikalische Größe der Mess-Software zur Verarbeitung zugeführt 
wird.

Zunächst wird eine physikalische Größe mit Hilfe von Sensoren oder Mes-
sumwandlern erfasst. Anschließend wird das gemessene Signal von 
Baugruppen zur Signalaufbereitung so verstärkt, dass es von der Messkarte 
im PC aufgenommen werden kann, die die Messwerte für den Computer 
bereitstellt. Der gesamte Messaufbau ist softwaregesteuert. Eine bestimmte 
Software gibt der Messkarte Anweisungen, wann und auf welchen Kanälen 
Messwerte aufgenommen bzw. ausgegeben werden sollen. Außerdem 
werden aufgenommene Werte in der Software ausgewertet. Zur besseren 
Interpretation können die Messwerte grafisch dargestellt werden (zum Bei-
spiel in einem Diagramm) oder bei Bedarf in schriftlicher Form 
festgehalten werden. 
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Abbildung 1.  Aufbau eines Messsystems

Der mit sämtlicher Hard- und Software von National Instruments ausgelie-
ferte NI-DAQ-Treiber ermöglicht eine individuelle Konfiguration der 
Geräte und ihrer Funktionen, wie der Datenerfassung, -erzeugung oder des 
Datenaustauschs. Die Verwendung von NI-DAQ erspart Ihnen somit eine 
eigenständige Programmierung. Über die Anwendungssoftware (wie
LabVIEW, LabWindows/CVI oder Measurement Studio) werden wie-
derum Befehle an den Treiber übermittelt, damit dieser zum Beispiel 
Messwerte abfragt oder analysiert und anzeigt.

Der NI-DAQ-Treiber ist zu allen NI-Anwendungsprogrammen sowie allen 
Programmiersprachen kompatibel, in denen DLLs über ANSI-C-Schnitt-
stellen aufgerufen werden können. Die Zusammenarbeit zwischen Ihrer 
DAQ-Anwendung dem NI-DAQ-Treiber erfolgt jedoch unabhängig von 
der Programmierumgebung wie in Abbildung 1 dargestellt.
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Schritt 1: Installation der Anwendungssoftware
Installieren Sie Ihre NI-Anwendungssoftware. Wenn Sie NI-DAQmx zur 
Programmierung Ihrer DAQ-Hardware verwenden, installieren Sie bitte 
LabVIEW 7.x, LabWindows/CVI 7.x, Measurement Studio 7.x oder das 
LabVIEW Real-Time Module 7.1. Für den traditionellen NI-DAQ-Treiber 
ist eine Version ab 6.x ausreichend.

Von Anwendungen, die mit einer früheren Version einer NI-Entwicklungs-
umgebung oder des NI-DAQ-Treibers erstellt wurden, sollte eine 
Sicherheitskopie angelegt werden, so dass die Software und die damit 
erstellten Anwendungen risikolos modifiziert werden können.

Schritt 2: Deinstallation älterer NI-DAQ-Versionen
Zum Aktualisieren einer älteren NI-DAQ-Version auf 7.x deinstallieren 
Sie zunächst die bisherige Version. Klicken Sie dazu im Startmenü von 
Windows auf Systemsteuerung»Software.

Schritt 3: Installation von NI-DAQ 7.x 

Einlegen der CD

Vorsicht! Installieren Sie NI-DAQ 7.x nicht, wenn in Ihren Anwendungen Komponenten 
enthalten sind, die dieser Treiber nicht unterstützt. Lesen Sie bitte vor Installation der Soft-
ware den Abschnitt Unterstützung in NI-DAQ 7.3 am Ende dieser Anleitung.

Der NI-DAQ-7.x-Installationsassistent sollte sich automatisch öffnen. 
Falls nicht, wählen Sie Start»Ausführen und geben Sie x:\setup.exe 
ein (x steht dabei für den Buchstaben des CD-Laufwerks). Bei Problemen 



DAQ-Schnellstartanleitung 80 ni.com

besuchen Sie bitte unsere Website ni.com/support/install und 
befolgen die Anweisungen im Hardware Installation/Configuration 
Troubleshooter.

Installieren Sie vor dem Anschließen eines Geräts an den Computer immer 
zuerst den dazugehörigen Treiber, damit Windows die Komponente auto-
matisch erkennt.

Auswahl der zu installierenden APIs

Vorsicht! Es kann immer nur jeweils eine Version von NI-DAQ 7.x auf einem System 
installiert sein. Bei der Installation von NI-DAQ 7.x wird die vorherige Version des tradi-
tionellen NI-DAQ-Treibers einschließlich aller dazugehörigen Hilfsdateien überschrieben. 
Bei der Installation von NI-DAQmx werden alle Vorgängerversionen von NI-DAQ 
gelöscht.

In NI-DAQ 7.x sind mehrere Treiber (der traditionelle NI-DAQ-Treiber, 
NI-DAQmx und NI-SWITCH) mit der dazugehörigen API enthalten, die je 
nach Art der verwendeten Geräte einzeln oder gemeinsam installiert 
werden können. Welche Treiber für die jeweils angeschlossenen Geräte 
erforderlich sind, erfahren Sie im Abschnitt Unterstützung in NI-DAQ 7.3 
am Ende dieser Anleitung.

Für Schaltmodule von National Instruments kann sowohl NI-SWITCH als 
auch NI-DAQmx eingesetzt werden. 

Installation der Hilfsdateien
Das Installationsprogramm von NI-DAQ 7.x erkennt automatisch alle 
installierten Anwendungsprogramme von National Instruments und wählt 
automatisch die neueste Version der Software sowie des Treibers und der 
Hilfsdateien für die unterstützten Programmiersprachen von CD aus.



© National Instruments Corporation 81 DAQ-Schnellstartanleitung

 

1. Überprüfen Sie, ob das Installationsprogramm für die Entwicklungs-
umgebung bzw. Programmiersprache die richtigen Hilfsdateien und 
die korrekte Version ausgewählt hat.

NI-DAQ-7.x muss immer nach NI-Anwendungssoftware der Version 
7.x installiert werden. Wenn NI-DAQ 7.x als erstes installiert wurde, 
starten Sie das Installationsprogramm für den Treiber noch einmal.

2. Klicken Sie auf Beenden.

3. Sobald der Installationsvorgang abgeschlossen ist, werden Sie gefragt, 
ob Sie den Computer neu starten, ihn herunterfahren oder das Dialog-
feld abbrechen möchten.

• Neustart—Wenn Sie das LabVIEW Real-Time Module verwenden, 
starten Sie den Rechner neu. Laden Sie mit Hilfe des Measurement 
& Automation Explorers (MAX) NI-DAQ 7.x auf das Netzwerksy-
stem herunter. Hilfestellung erhalten Sie dazu in der Measurement 
& Automation Explorer-Hilfe zu Systemen im Netzwerk, die sich 
unter Hilfe»Hilfethemen»Netzwerkumgebung befindet.

• Beenden—Um weitere NI-Software zu installieren, verlassen 
Sie das Programm und starten Sie das jeweilige 
Installationsprogramm.

– Bei gleichzeitiger Verwendung von LabWindows/CVI, C, 
C++, Visual Basic bzw. VirtualBench-Logger und einer Karte 
des Typs NI 435x verlassen Sie das Programm und installie-
ren Sie die Software von der Treiber-CD, die mit der Karte 
mitgeliefert wurde.

– Wenn Ihr PC über eine MXI-3-Schnittstelle mit einem 
PXI-Chassis verbunden ist, verlassen Sie das Programm 
und installieren Sie die MXI-3-Software, die bei Bedarf 
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von auch der Website ni.com/downloads heruntergeladen 
werden kann.

• Herunterfahren—Wenn alles zum Anschließen des Geräts bereit 
ist, wählen Sie Herunterfahren.

Schritt 4: Auspacken der Geräte, Zusatzbauteile und 
Kabel

Ihr Modul wurde in einer antistatischen Verpackung ausgeliefert, um zu 
verhindern, dass Schäden durch elektrostatische Entladung auftreten.

Vorsicht! Sie sollten freiliegende Anschlusspins niemals mit den Fingern berühren!

Ergreifen Sie beim Auspacken folgende Vorsichtsmaßnahmen:

• Erden Sie sich mit Hilfe eines Erdungskabels oder berühren Sie ein mit 
Masse verbundenes Objekt.

• Bringen Sie die Verpackung der Karte vor dem Auspacken mit einem 
blanken Metallteil des Computergehäuses in Kontakt.

Packen Sie die Karte aus und überprüfen Sie, ob sich eventuell Teile davon 
gelöst haben, oder ob sie anderweitig beschädigt ist. Sollte die Karte schad-
haft erscheinen, setzen Sie sich bitte mit uns in Verbindung. Bauen Sie auf 
keinen Fall eine schadhafte Karte ein!

Wenn Sie die Karte nicht nutzen, bewahren Sie sie in der antistatischen Ori-
ginalverpackung auf.

Sicherheitshinweise und Informationen zur Einhaltung von Sicherheits-
standards finden Sie in den im Schritt 10: Installation der 
Gerätedokumentation beschriebenen Begleitmaterialien.

Schritt 5: Anschließen der einzelnen Komponenten
Bauen Sie alle vorhandenen DAQ-Karten ein.

Wenn Sie an Ihre DAQ-Karte ein SCXI-Modul anschließen möchten, 
installieren Sie zunächst die DAQ-Komponenten. Der Einbau von 
SCXI-Modulen wird im Schritt 11. Installation von Signalkonditionie-
rungs- oder Schaltmodulen erklärt.

Vorsicht! Vor der Installation der Hardware ist unbedingt eine Erdung gemäß VDE erfor-
derlich. Alle weiteren wichtigen Informationen zu Sicherheitsbestimmungen und den 
Sicherheitsstandards, die Ihre Karte erfüllt, finden Sie auf dem mitgelieferten Datenblatt.
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PCI-Karten
Gehen Sie zum Einbau einer PCI-Karte folgendermaßen vor:

1. Schalten Sie den Computer aus und ziehen Sie den Netzstecker.

2. Entfernen Sie das Computergehäuse und die Abdeckung für den 
Erweiterungssteckplatz.

3. Berühren Sie ein beliebiges Metallteil des Computers.

4. Führen Sie die Karte in den PCI-Steckplatz ein und drücken Sie sie 
vollständig hinein. Wenden Sie dabei keine Gewalt an!

 

Abbildung 2.  Einbau einer PCI-Karte

5. Schrauben Sie die Metallschiene der Karte an der Rückwand des Com-
puters fest.

6. Montieren Sie das Computergehäuse.

PXI-Module
PXI-Module werden folgendermaßen eingebaut:

1. Schalten Sie das PXI-Gehäuse aus und ziehen Sie den Netzstecker.

Vorsicht! Lesen Sie bitte vor dem Entfernen von Abdeckungen oder Kabeln die Broschüre 
Read Me First: Safety and Radio-Frequency Interference, die mit PXI-Gehäusen und 
-Modulen ausgeliefert wird.

2. Entfernen Sie die Blende eines freien PXI-Steckplatzes. Manche 
Karten können nur in einen bestimmten Steckplatz montiert werden. 

1 PCI-DAQ-Karte
2 PCI-Steckplatz

3 PC mit PCI-Steckplatz

1 2
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Lesen Sie dazu bitte die Dokumentation, auf die nach der Beschrei-
bung in Schritt 10: Installation der Gerätedokumentation zugegriffen 
wird.

3. Berühren Sie zur elektrostatischen Entladung ein beliebiges Metallteil 
des Gehäuses.

4. Stellen Sie sicher, dass der Arretierhebel des PXI-Moduls nicht einge-
rastet ist.

5. Schieben Sie das Modul in das Gehäuse ein.

6. Drücken Sie das Modul so weit in das Gehäuse, bis es die Steckerleiste 
berührt.

7. Wenn Sie einen Widerstand fühlen, ziehen Sie den Arretierhebel hoch 
und drücken Sie die Karte vollständig in den Steckplatz.

8. Schrauben Sie die Frontplatte am Gehäuse fest. 
 

Abbildung 3.  Einbau eines PXI-Moduls

PCMCIA-Karten
PCMCIA-Karten von National Instruments passen in alle PC-Kartensteck-
plätze des Typs II. Gehen Sie zum Einstecken einer PCMCIA-Karte 
folgendermaßen vor:

1. Entfernen Sie die Abdeckung des PCMCIA-Steckplatzes (sofern 
vorhanden).

2. Führen Sie den Busanschluss des Gerätes in den Steckplatz ein, 
bis dieser fest sitzt.

1 PXI-Gehäuse
2 PXI-Controller
3 PXI-Modul
4 Arretierhebel

5 Befestigungsschrauben für die Frontplatte
6 Führungen für die Module
7 Netzschalter
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3. Schließen Sie das Kabel an. Gehen Sie dabei vorsichtig vor. Beim Ein-
stecken und Herausziehen sollte immer der Stecker angefasst werden. 
Ziehen Sie auf keinen Fall direkt am Kabel!

Abbildung 4.  Einbau einer PCMCIA-Karte

Geräte mit USB/IEEE-1394-Schnittstelle
NI-Geräte mit USB- oder IEEE-1394-Schnittstelle werden wie folgt 
angeschlossen:

1. Schließen Sie die Kabel für die Stromversorgung an.

• Sollte es sich um ein Gerät mit BP-1-Batteriepack handeln, bauen 
Sie die Batterien der dazugehörigen Beschreibung ein.

• Einige NI-Geräte mit USB- oder IEE-1394-Anschluss benötigen 
eine externe Stromzufuhr.

– Überprüfen Sie bei Geräten mit einem Netzteil zunächst, 
ob die Netzspannung (120 oder 230 V~) und die für das Gerät 
benötigte Spannung mit den Angaben auf dem Netzteil über-
einstimmen. Schließen Sie dann das Netzteil an.

– Wenn ein Netzkabel vorhanden ist, schließen Sie das Gerät 
damit an die Steckdose an.

1 Computer mit PCMCIA-Steckplatz
2 PCMCIA-Steckplatz
3 PCMCIA-Karte

4 Abgeschirmtes Kabel
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2. Verbinden Sie das Gerät über ein USB-Kabel entweder mit dem USB- 
bzw. IEEE-1394-Anschluss des Rechners, einem Hub oder einem 
anderen Gerät. In der Abbildung 5 ist ein USB-Kabel dargestellt.

Abbildung 5.  USB-Kabel und -Stecker

3. Betätigen Sie nun den Netzschalter (sofern vorhanden). Das Gerät 
sollte automatisch vom Computer erkannt werden.

Zubehör
Das Anschließen der Zubehörteile und/oder Anschlussblöcke wird in der 
dazugehörigen Anleitung beschrieben. Für SCXI- und SCC-Systeme 
folgen Sie bitte den Anweisungen bis Schritt 11. Installation von Signal-
konditionierungs- oder Schaltmodulen.

Schritt 6: Einschalten des Computers bzw. PXI-Chassis
Nach einem Neustart des Computers wird neu angeschlossene Hardware in 
Windows automatisch erkannt. In manchen Windows-Versionen öffnet 
sich in diesem Fall das Dialogfeld “Neue Hardware gefunden”. Die Vor-
einstellung lautet: Software automatisch installieren (empfohlen). 
Klicken Sie auf Weiter bzw. Ja, um einen Treiber zu installieren, so dass 
das jeweilige Gerät von Windows beim nächsten Start erkannt wird.

Wenn ein Gerät mit USB- oder IEEE-1394-Anschluss erkannt wurde, wird 
dies durch eine aufleuchtende oder blinkende LED am Gerät signalisiert. 
Bei NI-Geräten mit IEEE-1394-Schnittstelle gibt es eine COM-LED, die 
zu blinken beginnt, wenn das Gerät gefunden wurde. Beschreibungen zu 
den einzelnen LED-Signalen finden Sie in den unter Schritt 10: Installation 
der Gerätedokumentation erläuterten Unterlagen zu Ihrem Gerät. 

Schritt 7: Starten des MAX
Klicken Sie das Symbol Measurement & Automation auf dem Desktop 
doppelt an, um den MAX zu öffnen.

1 Stecker für den Computer bzw. USB-Hub 2 Geräteseitiger Stecker

1
2
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Schritt 8: Überprüfung der automatischen Erkennung 
von Geräten

Gehen Sie dazu folgendermaßen vor:

1. Erweitern Sie in der Baumstruktur die Kategorie Geräte und Schnitt-
stellen. Bei Systemen im Netzwerk, die mit LabVIEW RT arbeiten, 
klicken Sie zunächst die Kategorie Netzwerkumgebung, dann das 
System und anschließend die Kategorie Geräte und Schnittstellen 
doppelt an.

2. Überprüfen Sie, ob das Gerät unter Geräte und Schnittstellen ange-
zeigt wird. 

Falls ein Gerät sowohl mit dem traditionellen NI-DAQ-Treiber als 
auch mit NI-DAQmx arbeitet, und beide Treiber installiert sind, wird 
es unter Mein System»Geräte und Schnittstellen mit unterschiedli-
chen Namen in beiden Kategorien aufgeführt. 

Beachten Sie bitte, dass unter Netzwerkumgebung»Geräte und 
Schnittstellen nur die NI-DAQmx-Geräte angezeigt werden. Zur 
Anzeige aller an ein System im Netzwerk angeschlossenen Geräte, die 
mit dem traditionellen DAQ-Treiber arbeiten, klicken Sie auf Werk-
zeuge»Trad. NI-DAQ-Konfiguration»RDA-DAQ-Konfiguration.

Sollte eine Komponente nicht automatisch angezeigt werden, muss die 
Anzeige unter Umständen mit der <F5>-Taste aktualisiert werden. 
Wenn das Gerät dann immer noch nicht erscheint, liegt ein Fehler vor. 
In diesem Fall ist Ihnen möglicherweise die Website ni.com/
support/install eine Hilfe.

1 Geräte, die mit dem traditionellen DAQ-Treiber arbeiten, und NI-DAQmx-Geräte
2 NI-DAQmx-Geräte

1

2
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3. Klicken Sie das zu testende Gerät mit der rechten Maustaste an. 

• Wenn das Gerät unter dem traditionellen NI-DAQ-Treiber aufge-
führt ist, wählen Sie Eigenschaften und klicken dann auf die 
Schaltfläche Ressourcen testen. Für den traditionellen 
NI-DAQ-Treiber für das LabVIEW Real-Time Module gibt es 
keine Testpanels.

• Wenn sich das Gerät unter NI-DAQmx befindet, wählen Sie 
Selbsttest.

 

Hilfe bei Schwierigkeiten während des Selbsttests des Geräts 
finden Sie in der MAX-Hilfe für NI-DAQmx, die sich unter 
Hilfe»Hilfethemen»NI-DAQmx befindet. 

4. Nach Abschluss des Selbsttests erscheint eine Meldung darüber, ob ein 
Fehler festgestellt wurde. Für Unterstützung bei der Fehlerdiagnose 
besuchen Sie bitte unsere Website ni.com/support/install.

Schritt 9: Konfiguration der Geräteeinstellungen
Konfigurieren Sie alle angeschlossenen Geräte wie nachfolgend 
beschrieben:

1. Klicken Sie mit der rechten Maustaste auf den Namen des Geräts und 
wählen Sie Eigenschaften. Vergewissern Sie sich, dass Sie das Gerät 
unter der korrekten NI-DAQ-API ausgewählt haben. Wenn Ihr Rech-
ner mit einem System im Netzwerk verbunden ist, auf dem LabVIEW 
RT läuft, werden alle daran angeschlossenen NI-DAQmx-Geräte unter 
Netzwerkumgebung»Geräte und Schnittstellen angezeigt.
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2. Nehmen Sie die gewünschten Einstellungen vor. Das heißt, wenn eine 
Komponente sowohl mit dem traditionellen NI-DAQ-Treiber als auch 
mit NI-DAQmx arbeiten soll, müssen für beide Treiber Einstellungen 
vorgenommen werden.

• Zusätzliche Bauteile können unter Zubehör angegeben werden.

• Beim traditionellen NI-DAQ-Treiber können die Einstellungen 
für AI, AO, OPC und den Netzwerkzugriff verändert werden. Die 
Grundeinstellungen finden Sie in der in Schritt 10: Installation 
der Gerätedokumentation beschriebenen Dokumentation.

• Wenn auf einem RT-System in Ihrer Netzwerkumgebung mit dem 
traditionellen DAQ-Treiber gearbeitet wird, finden Sie im MAX 
unter Hilfe»Hilfethemen»Netzwerkumgebung Hinweise zur 
Konfiguration des Systems.

Für Informationen zur Konfiguration von SCXI-Modulen, die an 
RT-Systeme im Netzwerk angeschlossen sind, besuchen Sie die 
Seite ni.com/support/install und klicken dort auf 
Real-Time (RT)»RT Configuration Wizard»SCXI on RT 
Systems.

• Dem Standard IEEE 1451.4 entsprechende Sensoren, deren 
Grunddaten in einem speziellen integrierten Speicher enthalten 
sind (Transducer Electronic Data Sheet - elektronisches Daten-
blatt zum Sensor) – sogenannten TEDS-Sensoren – sind zunächst 
zu konfigurieren, bevor entsprechende Zubehörteile hinzugefügt 
werden können. Klicken Sie auf Nach TEDS suchen. Zur
Konfiguration von TEDS-Sensoren, die direkt an ein Gerät
angeschlossen sind, klicken Sie das entsprechende Gerät mit 
der rechten Maustaste an und wählen Sie TEDS konfigurieren.

3. Klicken Sie auf OK, um die vorgenommenen Änderungen zu 
speichern.

Virtuelle Kanäle, Skalierungen und Hardwarekonfigurationen für den tra-
ditionellen DAQ-Treiber können Sie auch mit NI-DAQmx nutzen, indem 
Sie Werkzeuge»NI-DAQmx-Konfiguration»Konfiguration des tradi-
tionellen NI-DAQ nach NI-DAQmx konvertieren anklicken. Beachten 
Sie jedoch bitte, dass dies nicht für SCC-Konfigurationen gilt; diese lassen 
sich nur einzeln konvertieren. Klicken Sie für weitere Hinweise im Assi-
stenten auf die Schaltfläche Hilfe.

Schritt 10: Installation der Gerätedokumentation
Das Softwarepaket von NI-DAQ 7.x umfasst neben Direkthilfen zur Hard-
ware, die von den Treibern unterstützt wird, PDF- und Hilfedateien, in 
denen die Anschlüsse, Leistungsmerkmale und die Betriebsweise der 
Geräte erläutert und die Grunddaten zu den Geräten enthalten sind. 
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Alle Dokumente lassen sich öffnen und ausdrucken. Legen Sie dazu die CD 
mit dem Titel “Device Documentation” ein. Für einige Funktionen der 
NI-DAQ-7.x-Dokumentation wie die Hilfe oder den Device Document 
Browser nutzen zu können, muss eine Internet-Explorer-Version ab 5.0 
installiert sein. Klicken Sie zum Öffnen des Device Document Browser auf 
Start»Programme»National Instruments»NI-DAQ»Browse Device 
Documentation.

Wenn Sie die CD nicht haben, finden Sie die Beschreibungen und Hilfen 
auch unter ni.com/manuals. Der Device Document Browser kann unter 
ni.com/support heruntergeladen werden. Klicken Sie dazu auf Drivers 
and Updates»Most Popular, wählen die verwendete NI-DAQ-Version 
aus und laden sich die NI-DAQ-CD 2 herunter. Wie der Device Document 
Browser installiert wird, erfahren Sie in der Beschreibung auf der Website.

Schritt 11. Installation von Signalkonditionierungs- 
oder Schaltmodulen

Der Einbau und die Konfiguration von Signalkonditionierungs- oder 
Schaltmodulen wird in den folgenden Dokumenten beschrieben:

• SCXI-Signalkonditionierungsmodule—SCXI-Schnellstartanleitung.

• Schaltmodule—NI Switches Getting Started Guide.

• Signalkonditionierungskomponenten (SCC) wie SC-Modulträger oder 
SCC-Module—SCC Quick Start Guide.

Die nachfolgenden Anweisungen gelten nur für DAQ-Karten und 
PXI-Module mit integrierter Signalaufbereitung.

Schritt 12: Anschließen der Sensoren und 
Signalleitungen

Schließen Sie die Sensoren bzw. Signalquellen an den Anschlussblock oder 
andere Zubehörteile an. Nachfolgend wird beschrieben, wie Sie zu den ein-
zelnen Komponenten hilfreiche Informationen finden:

• Anschlüsse für Signalleitungen und Pinbelegungen:

– Im DAQ-Assistenten ist zu den NI-DAQmx-Geräten in Ihrem 
System ein Anschlussplan enthalten. Klicken Sie auf die Register-
karte Anschlussplan. Um zu sehen, wie der Sensor jeweils mit 
dem Anschlussblock zu verbinden ist, klicken Sie die einzelnen 
Kanäle im Task an. Sie sehen dann die Anschlussbezeichnungen 
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und die Nummer für jede zu erstellende Verbindung. Anschluss-
pläne sind derzeit nur für analoge Messungen und die meisten 
MIO- und SCXI-Anschlussblöcke verfügbar.

– Im Device Document Browser können Sie auf die E Series Help, 
Bedienungsanleitungen zu Geräten und zusätzliche Anleitungen 
zugreifen.

– Pinbelegungen finden Sie auch unter Device Terminals in der 
Hilfe zum Measurement & Automation Explorer für den traditio-
nellen NI-DAQ-Treiber und der Hilfe zum Measurement & 
Automation Explorer für NI-DAQmx, die über das MAX-Hilfe-
menü geöffnet werden.

• Sensoren:

– Auf der Website ni.com/sensors.

– Im LabVIEW Measurements Manual, das mit LabVIEW mitgelie-
fert wird bzw. auf der Website ni.com/manuals als PDF-Datei 
verfügbar ist. 

– Zu NI-DAQmx im Kapitel Sensors der NI-DAQmx Help, die über 
Start»Programme»National Instruments»NI-DAQ»
NI-DAQmx Help geöffnet wird. 

– Zum traditionellen NI-DAQ-Treiber im Kapitel 5, Transducer 
Conversion Functions, des Traditional NI-DAQ User Manual, 
zu finden unter Start»Programme»National Instruments»
NI-DAQ»Traditional NI-DAQ User Manual. 

– Auf unserer Website ni.com/zone zu TEDS-Sensoren (intelli-
genten Sensoren, die dem Standard IEEE 1451.4 entsprechen). 

• Schaltmodule: In den Beschreibungen der Schaltmodule finden Sie 
auch Angaben zur Gerätearchitektur.

Schritt 13: Starten der Test-Panels
Bei vielen Geräten sind Testläufe zur Überprüfung bestimmter Funktionen 
möglich, wie beispielsweise der Ein- und Ausgabe von Signalen. Ein Test-
panel wird folgendermaßen gestartet: 

1. Erweitern Sie im MAX die Kategorie Geräte und Schnittstellen»
Traditionelle NI-DAQ-Geräte oder Geräte und Schnittstellen»
NI-DAQmx-Geräte. Bei RT-Systemen im Netzwerk klicken Sie 
zunächst die Kategorie Netzwerkumgebung, dann das System und 
anschließend die Kategorie Geräte und Schnittstellen doppelt an.

2. Klicken Sie mit der rechten Maustaste auf den Namen der Kompo-
nente. Vergewissern Sie sich, dass Sie das Gerät unter der korrekten 
NI-DAQ-API ausgewählt haben.
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3. Wählen Sie anschließend die Option Test-Panel aus. Beim traditionel-
len NI-DAQ-Treiber gibt es für das LabVIEW Real-Time Module 
keine Testpanels.

In der nachstehenden Abbildung sehen Sie ein Beispiel für ein 
Testpanel. 
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4. Klicken Sie zur Überprüfung der einzelnen Funktionen des Geräts auf 
die verschiedenen Registerkarten. Hilfestellung bei der Handhabung 
der Test-Panels in NI-DAQmx erhalten Sie im Menü unter Hilfe. Der 
Umgang mit den Testpanels des traditionellen NI-DAQ-Treibers ist in 
der Hilfe zum Measurement & Automation Explorer für den traditio-
nellen NI-DAQ-Treiber beschrieben.

5. Wenn ein Fehler vorliegt, wird im Testpanel eine entsprechende 
Meldung ausgegeben. Für Hilfe in diesem Fall stehen Ihnen die 
NI-DAQmx Reference Help und die Website ni.com/support 
zur Verfügung. 

6. Klicken Sie zum Verlassen des Testpanels auf Schließen.

Schritt 14: Konfiguration aller neu angeschlossenen 
Geräte

Wenn mehrere DAQ-Karten installiert sind, müssen Sie Schritt 9: 
Konfiguration der Geräteeinstellungen bis Schritt 13: Starten der 
Test-Panels für jede Karte wiederholen. 

Schritt 15: Konfiguration der Kanäle und Tasks
Dieser Schritt ist nur dann erforderlich, wenn Sie Ihre Karte mit NI-DAQ 
oder einer Entwicklungsumgebung von National Instruments 
programmieren. 

Ein physikalischer Kanal ist ein Anschluss oder Steckkontakt, an dem ein 
analoges oder digitales Signal gemessen werden kann oder erzeugt wird. 
Ein virtueller Kanal umfasst mehrere Einstellungen zu einem physikali-
schen Kanal. Dazu gehören: Bezeichnung, verwendete Anschlüsse, Art der 
Messung/Signalerzeugung sowie die die Art und Weise der Messwertska-
lierung. Bei NI-DAQmx sind virtuelle Kanäle Bestandteil einer jeden 
Messung. Beim traditionellen NI-DAQ-Treiber bieten virtuelle Kanäle 
einen besseren Überblick darüber, welche Kanäle für welche Messungen 
genutzt werden. In Abbildung 6 wird gezeigt, wie Kanäle für NI-DAQmx 
und den traditionellen NI-DAQ-Treiber konfiguriert werden.
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Abbildung 6.  Konfiguration von Kanälen und Tasks für NI-DAQmx bzw. 
den traditionellen NI-DAQ-Treiber

Ein Task ist ein wichtiger neuer Bestandteil von NI-DAQmx. Tasks umfas-
sen mehrere virtuelle Kanäle sowie verschiedene Einstellungen, wie 
beispielsweise zum Messtakt oder zur Triggerung. Ein Task beschreibt alle 
Parameter einer durchzuführenden Messung oder Signalerzeugung. Sämt-
liche Einstellungen eines Tasks lassen sich speichern, so dass dieser auch 
in anderen Applikationen eingesetzt werden kann.

In NI-DAQmx können virtuelle Kanäle als Teil eines Tasks oder separat 
konfiguriert werden. Virtuelle Kanäle, die innerhalb eines Tasks erstellt 
wurden, werden als lokale Kanäle bezeichnet, und solche, die separat 
erstellt wurden, als globale Kanäle. Globale Kanäle können im MAX oder 
in einer Entwicklungsumgebung von National Instruments erstellt und 
anschließend im MAX gespeichert werden. Sie sind in jeder beliebigen 
Anwendung einsetzbar und können zu einer Vielzahl von Tasks hinzuge-
fügt werden. Eine Änderung an einem globalen Kanal wirkt sich auf alle 
Tasks aus, in denen der Kanal verwendet wird. In den meisten Fällen ist es 
daher einfacher, lokale Kanäle zu verwenden.

Konfiguration eines Tasks in NI-DAQmx
Tasks für NI-DAQmx werden mit Hilfe des DAQ-Assistenten konfiguriert. 
Zum Erstellen von Tasks und Kanälen mit dem DAQ-Assistenten muss ein 
Anwendungssoftwarepaket von National Instruments ab Version 7.0 instal-
liert sein.

• Klicken Sie im MAX mit der rechten Maustaste auf Datenumgebung 
und wählen Sie Neu. Wählen Sie NI-DAQmx-Task und klicken Sie 
auf Weiter.

NI-DAQmx

Sie haben Ihre Geräte installiert und konfiguriert.

Welche API verwenden
Sie zur Programmierung 

der Geräte?

Traditioneller
NI-DAQ

Kanäle und Tasks konfigurieren.

Verwenden Sie den DAQ-Assistenten, der 
über den MAX oder die NI-Applikations-

Software verfügbar ist, zur Konfiguration von 
Kanälen und Tasks.  Weitere Informationen 

erhalten Sie in der Hilfe des DAQ-Assistenten 
und in der Hilfe zum Measurement & 
Automation Explorer für NI-DAQmx.

MAX zur Konfiguration der Kanäle 
verwenden. Weitere Informationen 

erhalten Sie in der Hilfe zum 
Measurement & Automation Explorer 

für den herkömmlichen NI-DAQ-Treiber. 
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Bei Systemen im Netzwerk, die mit LabVIEW RT arbeiten, klicken 
Sie zunächst die Kategorie Netzwerkumgebung, dann das System 
und anschließend die Kategorie Datenumgebung doppelt an und 
wählen Sie Neu.

• Der DAQ-Assistent lässt sich auch direkt von einer NI-Entwicklungs-
umgebung aus öffnen.

– In LabVIEW:

• Fügen Sie entsprechend der Beschreibung unter Erste 
Schritte mit LabVIEW das Express-VI “DAQ-Assistent” in 
das Blockdiagramm ein, das sich auf der Express-Palette 
“Eingabe” befindet. 

• Fügen Sie ein Bedienelement des Typs “DAQmx-Taskname” 
in das Frontpanel ein. Klicken Sie es mit der rechten Mausta-
ste an und wählen Sie Neuer Task (DAQ-Assistent). Alle 
Schritte zum Erstellen eines Tasks einschließlich der Erstel-
lung von Blockdiagrammcode ist in der Hilfedatei 
Messungen mit NI-DAQmx in LabVIEW beschrieben, die in 
LabVIEW über Hilfe»Messungen mit NI-DAQmx in 
LabVIEW geöffnet wird.

– In LabWindows/CVI:

1. Wählen Sie Tools»Create/Edit DAQmx Tasks. Es öffnet 
sich das Dialogfeld “Create/Edit DAQmx Tasks”. 

2. Wählen Sie Create New Task In MAX oder Create New 
Task In Project und klicken Sie danach auf OK.

– In Measurement Studio:

1. Öffnen Sie Visual Studio .NET und das Projekt, in dem der 
DAQmx-Task erzeugt werden soll.

2. Wählen Sie Project»Add New Item. Sie sehen das 
Dialogfeld “Add new item”. 

3. Klicken Sie unter “Categories” auf Measurement Studio» 
Assistants.

4. Wählen Sie anschließend aus den Vorlagen DAQmx Task 
Class aus.

5. Geben Sie für die Datei zum DAQmx-Task einen Namen an 
und klicken Sie auf Open. 

6. Geben Sie an, ob Sie einen neuen Task oder eine Kopie eines 
globalen Tasks erstellen möchten, der im MAX erzeugt 
wurde.

7. Klicken Sie auf Finish.
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Nach dem Öffnen des DAQ-Assistenten kann nun auf folgende Weise ein 
Task erstellt werden:

1. Wählen Sie einen I/O-Typ aus (z. B. Analogeingabe).

2. Bestimmen Sie anschließend die zu messende bzw. zu erzeugende 
Größe.

3. Wählen Sie – sofern erforderlich – einen Sensor für die Messung aus.

4. Klicken Sie auf Weiter. Es öffnet sich ein Dialogfeld für den angege-
benen Task, wie im folgenden Beispiel dargestellt:

5. Wählen Sie die Kanäle für die Messung oder Signalerzeugung aus. 
Es können physikalische Kanäle ausgewählt werden, aus denen im 
Task lokale Kanäle erstellt werden sollen, und es können globale 
Kanäle zum Task hinzugefügt werden.

6. Wenn Sie mit einem TEDS-Sensor arbeiten, klicken Sie auf die Regi-
sterkarte TEDS-Kanäle.

a. Wählen Sie die physikalischen Kanäle aus. Der DAQ-Assistent 
importiert nun die Daten vom Sensor und erstellt den Task.

b. Klicken Sie auf Weiter.

7. Geben Sie den Namen des neuen Tasks ein. Klicken Sie auf Beenden.
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8. Nehmen Sie nun bei Bedarf Einstellungen zum Mess-/Ausgabesignal, 
-takt, -modus, zur Triggerung und zur Skalierung vor. Wenn Kanäle 
zur Messung mit TEDS-Sensoren konfiguriert wurden, können 
manche Einstellungen, die von den Sensoren übernommen wurden, 
nicht bearbeitet werden.

9. Um Kanäle zur Messung einer anderen Größe zu einem Task hinzuzu-
fügen, wie zum Beispiel Temperaturkanäle zu einem Spannungstask, 
klicken Sie auf die Schaltfläche Hinzufügen.

a. Wählen Sie aus der Liste die Art der Messung aus, die hingefügt 
werden soll. Ein Dialogfeld zeigt alle für diese Messart gültigen 
Kanäle an. 

b. Wählen Sie die hinzuzufügenden Kanäle aus.

c. Klicken Sie auf OK.

d. Zum Hinzufügen weiterer Kanäle und Messarten wiederholen Sie 
diesen Schritt so oft wie erforderlich.

10. Speichern Sie den Task.

• Wenn der DAQ-Assistent von LabVIEW oder von 
LabWindows/CVI aus geöffnet wurde, klicken Sie auf OK.

• In Measurement Studio klicken Sie auf File»Save.

• Wenn der DAQ-Assistent vom MAX aus geöffnet wurde, wählen 
Sie Task speichern.

Nun kann der Task in einer Applikation verwendet werden.

Konfiguration globaler Kanäle in NI-DAQmx
Globale Kanäle für NI-DAQmx werden mit Hilfe des DAQ-Assistenten 
erzeugt.

• Um den DAQ-Assistenten im MAX zu öffnen, klicken Sie mit der 
rechten Maustaste auf Datenumgebung und wählen Neu.

Bei Systemen im Netzwerk, die mit LabVIEW RT arbeiten, klicken 
Sie zunächst die Kategorie Netzwerkumgebung, dann das System 
und anschließend die Kategorie Datenumgebung doppelt an und 
wählen Neu.

Klicken Sie im Fenster Hinzufügen auf die Schaltfläche NI-DAQmx 
- Globaler Kanal und anschließend auf Weiter.

• Der DAQ-Assistent lässt sich auch direkt in der Anwendungssoftware 
öffnen.

– Fügen Sie dazu in LabVIEW das Element “DAQmx - Globaler 
Kanal” in das Blockdiagramm ein. Klicken Sie es mit der rechten 
Maustaste an und wählen Sie Neuer Kanal (DAQ-Assistent).
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– In LabWindows/CVI und Measurement Studio muss zunächst, 
wie zuvor beschrieben, ein Task erstellt werden. Um dem Task 
globale Kanäle hinzuzufügen, klicken Sie im DAQ-Assistenten 
auf Vorhandene globale DAQmx-Kanäle hinzufügen. Das 
Erstellen von globalen Kanälen ist allerdings nur im MAX 
möglich.

Der DAQ-Assistent fordert Sie zum Erstellen eines neuen globalen 
Kanals auf:

1. Wählen Sie einen I/O-Typ aus (z. B. Analogeingabe).

2. Bestimmen Sie anschließend die zu messende bzw. zu erzeugende 
Größe. 

3. Wählen Sie – sofern erforderlich – einen Sensor für die Messung aus. 

4. Es öffnet sich ein Dialogfeld, in dem Sie aufgefordert werden, Kanäle 
für den Task auszuwählen. Sie können entweder physikalische Kanäle 
auswählen, zu denen lokale Kanäle erstellt werden sollen, oder globale 
Kanäle hinzufügen.

Wenn Sie mit einem TEDS-Sensor arbeiten, klicken Sie auf die Regi-
sterkarte TEDS-Kanäle. Wählen Sie die physikalischen Kanäle aus. 
Der DAQ-Assistent importiert nun die Einstellungen vom Sensor und 
erstellt auf Grundlage der Daten den neuen Task.

5. Nehmen Sie alle messungsspezifischen Einstellungen vor. Wenn 
Kanäle zur Messung mit TEDS-Sensoren konfiguriert wurden, können 
manche Einstellungen, die von den Sensoren übernommen wurden, 
nicht bearbeitet werden.

6. Speichern Sie den Kanal.

• Wenn der DAQ-Assistent von LabVIEW oder von 
LabWindows/CVI aus geöffnet wurde, klicken Sie auf OK.

• In Measurement Studio klicken Sie auf File»Save.

• Wenn der DAQ-Assistent vom MAX aus geöffnet wurde, wählen 
Sie Kanal speichern.

Der globale Kanal kann nun in jeder beliebigen Applikation verwendet 
oder einem Task hinzugefügt werden.

Konfiguration virtueller Kanäle für den traditionellen NI-DAQ-Treiber
Beim traditionellen NI-DAQ-Treiber werden virtuelle Kanäle im MAX 
konfiguriert. Gehen Sie dazu wie folgt vor:

1. Öffnen Sie den Assistenten zum Erstellen neuer Kanäle.

• Klicken Sie im MAX mit der rechten Maustaste auf Datenumge-
bung und wählen Sie Neu. Wählen Sie anschließend Virtueller 
Kanal und klicken Sie auf Beenden.
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• Wenn Sie auf einem RT-System im Netzwerk mit dem traditionel-
len NI-DAQ-Treiber arbeiten, wählen Sie Werkzeuge»Trad. 
NI-DAQ-Konfiguration»RDA-DAQ-Konfiguration. Darauf-
hin öffnet sich das Fenster “DAQ-Netzwerkkonfiguration” mit 
einer Liste aller erkannten Geräte. Wählen Sie Kanal und klicken 
Sie auf Hinzufügen. 

2. Folgen Sie den Anweisungen des Assistenten. Die Konfiguration eines 
Kanals wird in der Hilfe zum Measurement & Automation Explorer für 
den traditionellen NI-DAQ-Treiber beschrieben.

Schritt 16: Verwenden eines Tasks in einer Applikation
Über die folgenden Schritte binden Sie einen Mess-Task in Ihre Applika-
tion ein. Der Einsatz von Tasks und das Erzeugen von Programmcode wird 
in der Hilfe zum DAQ-Assistenten näher erläutert.

LabVIEW
1. Öffnen Sie in LabVIEW ein leeres VI.

2. Legen Sie die folgende Konstante auf dem Blockdiagramm ab: 
NI-Messtechnik»DAQmx - Datenerfassung»DAQmx - Taskname 
(Konstante).

3. Wählen Sie aus dem Pulldown-Menü einen Task aus.

4. Klicken Sie das VI mit der rechten Maustaste an und wählen Sie 
Erzeugen von Programmcode»Beispiel.

5. Wechseln Sie zum Frontpanel und starten Sie das VI.
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LabWindows/CVI
Eine detaillierte Anleitung zur Verwendung von Tasks in 
LabWindows/CVI erhalten Sie, wenn Sie ni.com/info besuchen 
und rddq73 eingeben. 

Measurement Studio
Für Anweisungen zur Verwendung von Tasks in Measurement Studio 
geben Sie auf ni.com/info die Zeichenkombination rddqms ein. 

Erste Schritte zum Entwickeln einer Applikation

Umgang mit Beispielen
Jede API enthält Programmierbeispiele, die das Erstellen einer Applikation 
vereinfachen sollen. Diese lassen sich bearbeiten und zur Weiterverwen-
dung speichern. So kann auf Grundlage eines Beispiels eine neue 
Applikationen erstellt oder eine bestehende Applikation erweitert werden.

Zum Auffinden von LabVIEW- und LabWindows/CVI-Beispielen öffnen 
Sie über Hilfe»Beispiele suchen die Suchmaschine für Beispiele von 
National Instruments.

NI-DAQmx-Beispiele für von Measurement Studio unterstützte 
Programmiersprachen:

• MeasurementStudioVS2003\VCNET\Examples\DAQmx 

• MeasurementStudioVS2003\DotNET\Examples\DAQmx

Beispiele für den traditionellen NI-DAQ-Treiber zur Verwendung in 
Visual Basic:

• Das Verzeichnis NI-DAQ\Examples\Visual Basic mit 
Measurement Studio enthält einen Link zu den Anwendungsbei-
spielen für ActiveX-Elemente in Measurement Studio.

• Das Verzeichnis NI-DAQ\Examples\VBasic enthält von 
Measurement Studio unabhängige Beispiele.

Im Verzeichnis NI-DAQ\Examples\DAQmx ANSI C befinden sich 
NI-DAQmx-Beispiele für ANSI C und unter NI-DAQ\Examples\
VisualC Beispiele für den traditionellen NI-DAQ-Treiber für ANSI C.

Hunderte weiterer Beispiele gibt es unter ni.com/zone.
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Informationen zu Messapplikationen und -geräten
Nachfolgend einige Hinweise dazu, wo Sie Informationen über Ihre mess-
technischen Anwendungen und Geräte finden können.

LabVIEW
Neuanwender sollten sich zunächst mit dem Handbuch Erste Schritte mit 
LabVIEW befassen, um mit LabVIEW vertraut zu werden. Zum Öffnen der 
entsprechenden PDF-Datei klicken Sie auf Start»Programme»National 
Instruments»LabVIEW 7.x»Im LabVIEW-Bücherregal suchen.

Im LabVIEW Measurements Manual finden Sie API-Übersichten zum tra-
ditionellen NI-DAQ- und zum NI-DAQmx-Treiber sowie Beschreibungen 
zu Messvorgängen. Das Handbuch befindet sich ebenfalls unter Start»
Programme»National Instruments»LabVIEW 7.x»Im LabVIEW-
Bücherregal suchen.

In der Hilfedatei Messungen mit NI-DAQmx in LabVIEW wird schrittweise 
beschrieben, wie eine Messung in LabVIEW vorbereitet wird, und es 
werden die neuen NI-DAQmx-Funktionen sowie DAQmx-spezifische 
Begriffe wie “DAQ-Assistent” oder “Task” erläutert. Um die Hilfe zu öff-
nen, klicken Sie in LabVIEW auf Hilfe»Messungen mit NI-DAQmx.

In der LabVIEW-Hilfe gibt es eine Übersicht über VIs und Funktionen, 
und es werden die Eigenschaften für NI-DAQmx und den traditionellen 
NI-DAQ-Treiber beschrieben. Zum Öffnen der Datei wählen Sie in 
LabVIEW Hilfe»VI-, Funktionen- und Anwendungshilfe und klicken 
unter Inhalt auf VI- und Funktionsreferenz, um die VI-Übersicht für die 
von Ihnen verwendete NI-DAQ-API zu finden.

LabVIEW Real-Time Module
Wählen Sie Start»Programme»National Instruments»LabVIEW 7.x»
Module Documents»Search the LabVIEW Real-Time Module 
Bookshelf. Hier finden Sie Links zu LabVIEW RT-Beschreibungen.

LabWindows/CVI
Wenn Sie erstmals mit dem LabWindows/CVI arbeiten, sollten Sie sich 
zunächst mit Hilfe des Handbuchs Getting Started with LabWindows/CVI 
mit dem Programm vertraut machen. Zum Öffnen der entsprechenden 
PDF-Datei klicken Sie in LabWindows/CVI auf Help»LabWindows/CVI 
Bookshelf.

Die LabWindows/CVI Help enthält eine Übersicht über NI-DAQmx-Funk-
tionen und Beschreibungen zu Messungen in NI-DAQmx. Um die Hilfe zu 
öffnen, wählen Sie in LabWindows/CVI Help»Contents.
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Measurement Studio
Die NI Measurement Studio Help enthält eine Übersicht über die 
NI-DAQmx-API und vermittelt die wichtigsten Informationen zu Messun-
gen und Funktionen. Diese Hilfedatei ist Bestandteil der Dokumentation zu 
Visual Studio .NET. Um sie zu öffnen, klicken Sie in Visual Studio .NET 
auf Help»Contents.

Die Measurement Studio Reference verschafft Ihnen einen Überblick über 
die API des traditionellen NI-DAQ-Treibers und vermittelt Grundlagen-
wissen zu Messungen und Beschreibungen zu Funktionen. Sie wird in 
Visual Studio .NET über Measurement Studio»Measurement Studio 
Reference geöffnet.

ANSI C ohne NI-Anwendungssoftware
Übersichten über APIs finden Sie im Traditional NI-DAQ User Manual 
und in der NI-DAQmx Help. Die NI-DAQmx Help enthält zusätzlich allge-
meine Informationen zu Messvorgängen. In der Traditional NI-DAQ C 
Reference Help und der NI-DAQmx C Reference Help finden Sie eine 
Übersicht über die Funktionen und Attribute von C. Wählen Sie 
Start»Programme»National Instruments»NI-DAQ und den Titel des 
Dokuments zur verwendeten API aus.

.NET-Sprachen ohne NI-Anwendungssoftware

.NET-Programmiersprachen ohne NI-Entwicklungsumgebung: Eine 
Beschreibung der NI-DAQmx-API sowie die wichtigsten Informationen zu 
Messungen und Funktionen sind der NI Measurement Studio Help zu ent-
nehmen, die Bestandteil der Dokumentation zu Visual Studio .NET ist. 
Um sie zu öffnen, klicken Sie in Visual Studio .NET die Option Help»
Contents an.

Hinweis Bei Verwendung einer .NET-Sprache ohne Visual Studio .NET kann es vorkom-
men, dass die NI Measurement Studio Help nicht eingesehen werden kann.

Gerätedokumentation
NI-DAQ 7.x umfasst neben Direkthilfen zur Hardware, die mit dem Treiber 
unterstützt wird, PDF- und Hilfedateien, in denen die Anschlüsse, Lei-
stungsmerkmale und die Betriebsweise der Geräte erläutert werden und die 
Grunddaten zu den Geräten enthalten sind. Alle Dokumente lassen sich 
öffnen und ausdrucken. Legen Sie dazu die NI-DAQ-CD mit dem Titel 
“Device Documentation” ein. Nach der Installation kann das Programm 
über Start»Programme»National Instruments»NI-DAQ»Browse 
Device Documentation aufgerufen werden.
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NI 435x
Nach der Konfiguration und Überprüfung können PCI-Karten des Typs 
435x mit dem Programm VirtualBench-Logger gesteuert werden, so dass 
keinerlei eigenständige Programmierung Ihrerseits erforderlich ist. Wie der 
VirtualBench-Logger zu diesem Zweck einzusetzen ist, wird im Dokument 
Getting Started with VirtualBench auf ni.com/manuals beschrieben.

Verwendung des traditionellen NI-DAQ- und des NI-DAQmx-Treibers auf 
demselben Computer

Bestehende Applikationen, die mit früheren Versionen von NI-DAQ 
erstellt wurden, können auch mit der vorliegenden Version des traditionel-
len NI-DAQ-Treibers ausgeführt werden. Wenn allerdings beide APIs auf 
demselben Computer verwendet werden, gelten folgende 
Einschränkungen:

• Ein Gerät kann nur von jeweils einer API gesteuert werden.

– Nach der Verwendung eines Geräts mit NI-DAQmx müssen alle 
NI-DAQmx-Tasks, bei denen auf das Gerät zugegriffen wird, 
zurückgesetzt werden, bevor das Gerät mit dem traditionellen 
NI-DAQ-Treiber verwendet werden kann. Ansonsten wird ein 
Fehler mit dem Code -10461 ausgegeben. NI-DAQmx-Tasks 
werden mit dem VI “DAQmx - Task zurücksetzen” aufgehoben.

– Geräte, die mit dem traditionellen NI-DAQ-Treiber angesteuert 
werden, müssen vor dem Wechsel zu NI-DAQmx in den Aus-
gangszustand zurückversetzt werden. Ansonsten wird ein Fehler 
mit dem Code -200324 ausgegeben.

Bei SCXI-Modulen muss vor Verwendung von NI-DAQmx das 
Modul, durch das der Datenaustausch mit dem Rechner erfolgt, 
zurückgesetzt werden, wenn zuvor mit dem traditionellen 
NI-DAQ-Treiber gearbeitet wurde. Bei DAQ-Karten der E-Serie 
verläuft die Kommunikation mit dem SCXI-Modul beispiels-
weise über die Leitungen 0, 1, 2 und 4 des Ports 0. Wenn die Karte 
nicht über den traditionellen DAQ zurückgesetzt wird, erscheint 
eine Fehlermeldung mit dem Code -200158, wenn es in 
NI-DAQmx verwendet wird. Zum Zurücksetzen des Geräts gehen 
Sie wie folgt vor:

• Rufen Sie das VI “Gerät zurücksetzen” des traditionellen 
NI-DAQ-Treibers oder die Funktion Init_DA_Brds auf. 

• Beim traditionellen NI-DAQ-Treiber ist nur ein Zurücksetzen 
aller Geräte auf einmal möglich. Klicken Sie dazu im MAX 
die Kategorie Traditionelle NI-DAQ-Geräte mit der rech-
ten Maustaste an und wählen Sie die Option Treiber für 
traditionellen NI-DAQ zurücksetzen. Bei RT-Systemen im 
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Netzwerk ist dazu das VI “Gerät zurücksetzen” des traditio-
nellen NI-DAQ-Treibers einzusetzen.

• Bei der Datenerfassung mit SCXI müssen alle Geräte (sowohl die 
angeschlossene DAQ-Karte als auch die im Chassis befindlichen 
SCXI-Module) mit derselben API programmiert werden.

Auf der Internetseite ni.com/support finden Sie Beschreibungen und 
Anleitungen zu folgenden Themen:

• Integration von NI-DAQmx-Programmcode in Anwendungen für den 
traditionellen NI-DAQ-Treiber.

• Ausführen von Anwendungen, in denen ein Gerät sowohl mit dem tra-
ditionellen NI-DAQ-Treiber als auch mit NI-DAQmx gesteuert wird.

Fehlersuche
Nachfolgend einige Informationsquellen, die Ihnen bei Problemen mit der 
Installation Ihrer Hard- oder Software zur Datenerfassung von Nutzen sein 
können:

• Bei Problemen besuchen Sie bitte unsere Website ni.com/support/
install und gehen Sie nach den Anweisungen im Hardware Instal-
lation/Configuration Troubleshooter vor.

• Auf ni.com/kb finden Sie häufig gestellte Fragen und Hilfe bei Pro-
blemen bei der Installation oder Programmierung. 

• Falls Sie ein Gerät zur Reparatur oder Kalibrierung an National 
Instruments zurücksenden möchten, besuchen Sie bitte unsere Website 
ni.com/support und suchen Sie nach Sending a Board for Repair 
or Calibration. Hier erfahren Sie, was bei der Warenrücksendung an 
National Instruments zu beachten ist.

Weltweite technische Unterstützung
Für professionelle Serviceleistungen und technische Unterstützung lesen 
Sie bitte auf der Internetseite ni.com von National Instruments unter fol-
genden Abschnitten nach:

• Support: Die unter ni.com/support verfügbaren Ressourcen zur 
technischen Unterstützung umfassen:

– Hilfe zur Selbsthilfe: Besuchen Sie für Soforthilfe bei Fragen 
und Problemen die preisgekrönte Webseite von National 
Instruments. Hier finden Sie unter anderem Treibersoftware, 
Updates, eine umfassende Informationsdatenbank 
(Knowledgebase), Bedienungsanleitungen, schrittweise 
Anleitungen zur Problemlösung, Tausende Beispielprogramme, 
Lernhilfen, Application Notes und Instrumententreiber.



© National Instruments Corporation 105 DAQ-Schnellstartanleitung

– Kostenlose technische Unterstützung: Alle registrierten Benut-
zer können den kostenlosen Basis-Support in Anspruch nehmen, 
der unter anderem auch den Zugriff auf das Diskussionsforum 
ni.com/exchange einschließt, in dem Sie sich bei Problemen 
mit Hunderten Applikationsingenieuren weltweit austauschen 
können. Die Applikationsingenieure von National Instruments 
sorgen dafür, dass jede Ihrer Fragen beantwortet wird.

• Schulung und Zertifizierung: Auf ni.com/training finden Sie 
Lernhandbücher, virtuelle Schulungsräume, interaktive CDs und 
Informationen über Zertifizierungsprogramme. Hier können Sie sich 
auch für eine der weltweit angebotenen Software-Schulungen 
anmelden.

• System-Integration: Wenn Sie aus Zeit-, Personalmangel oder ande-
ren Gründen bei der Fertigstellung eines Projekts in Verzug geraten, 
können Ihnen die Mitglieder des NI-Alliance-Programms weiterhel-
fen. Für Informationen zu diesem Programm setzen Sie sich entweder 
telefonisch mit einer National-Instruments-Niederlassung in Ihrer 
Nähe in Verbindung oder besuchen Sie die Seite ni.com/alliance.

• Konformitätserklärung (DoC): Bescheinigt, dass die Firma National 
Instruments unter Verwendung der Konformitätserklärungen der ent-
sprechenden Hersteller die EG-Richtlinien zum Verbraucherschutz 
einhält. Dadurch werden elektromagnetische Verträglichkeit und 
Sicherheit unserer Produkte gewährleistet. Das Zertifikat zu Ihrem 
Produkt finden Sie unter ni.com/certification.

• Kalibrierungszertifikat: Wenn das von Ihnen verwendete Produkt 
kalibrierbar ist, erhalten Sie dazu unter ni.com/calibration das 
zugehörige Kalibrierungszertifikat.

Die Adresse der Hauptgeschäftsstelle von National Instruments lautet 
11500 North Mopac Expressway, Austin, Texas, 78759-3504, USA. Auf 
die Internetseiten der einzelnen Niederlassungen, auf denen Sie immer die 
aktuellen Kontaktinformationen, Telefonnummern des technischen Sup-
ports, E-Mail-Adressen und Hinweise auf aktuelle Ereignisse/
Veranstaltungen finden, gelangen Sie über ni.com/niglobal.

Unterstützung in NI-DAQ 7.3
Mit NI-DAQmx 7.3 werden noch nicht alle Messgeräte von National 
Instruments unterstützt. In den kommenden Versionen von NI-DAQ 
werden daher auch die Geräte für den traditionellen NI-DAQ-Treiber 
weiterhin unterstützt, und die Palette der NI-DAQmx-Geräte wird 
kontinuierlich erweitert.
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Unterstützte Betriebssysteme
NI-DAQmx 7.3, der traditionelle NI-DAQ-Treiber 7.3 und 
NI-SWITCH 2.3 sind nur unter Windows 2000, NT und XP lauffähig. 
Für NI-DAQ 7.x ist unter Windows NT mindestens Service Pack 6 
erforderlich.

PharLap wird von NI-DAQmx 7.3 nur mit dem LabVIEW Real-Time 
Module 7.1 unterstützt.

Für Measurement Studio wird Visual Studio .NET 2003 benötigt, was wie-
derum Windows 2000/NT 4.0/XP voraussetzt.

Für systemspezifische Installationsanweisungen sollte der Hardware 
Installation/Configuration Troubleshooter auf ni.com/support/
install genutzt werden.

Unter ni.com/downloads können frühere Versionen von NI-DAQ, 
die auch auf anderen Betriebssystemen lauffähig sind, heruntergeladen 
werden.

Unterstützte Anwendungsprogramme
In der Tabelle 1 sind alle Versionen der Anwendungssoftware von National 
Instruments aufgeführt, die zu NI-DAQmx und zum traditionellen 
NI-DAQ-Treiber kompatibel sind. Für andere Programmiersprachen 
gilt Tabelle 2.

 
Tabelle 1.  Von NI-DAQ 7.x unterstützte Anwendungssoftware

Programm NI-DAQmx
Traditioneller 

NI-DAQ-Treiber

LabVIEW  7.x 6.1–7.x

LabVIEW Real-Time Module 7.11 6.1–7.x

LabWindows/CVI  7.x 6.0–7.x

Measurement Studio  7.x 6.0–7.x2

1 Für das LabVIEW Real-Time Module 7.1 ist mindestens NI-DAQmx 7.2 erforderlich.
2 Der traditionelle NI-DAQ-Treiber hat keine Measurement-Studio-C++- oder 
.NET-Schnittstelle.
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Unterstützte Programmiersprachen
 

Ältere Versionen der Treiber, die zu anderen Versionen kompatibel sind, 
können von der Website ni.com/downloads heruntergeladen werden.

Unterstützte Hardware
Die genauen Modellbezeichnungen finden Sie in der NI-DAQ 7.x Readme 
auf der CD. In Tabelle 3 sind alle Gerätefamilien aufgeführt, die in 
NI-DAQ 7.3 mit NI-DAQmx und dem traditionellen NI-DAQ-Treiber 
unterstützt werden. 

Tabelle 2.  Von NI-DAQ 7.x unterstützte Programmiersprachen

Programmiersprache NI-DAQmx
Traditioneller 

NI-DAQ-Treiber

ANSI C 3 3

Microsoft Visual C++
Klassenbibliotheken
C-DLL

7.x1

6.0–7.x
—

6.0–7.x

Visual Basic 6.0 durch 
ActiveX-Komponenten

— 6.0

Microsoft-.NET-Sprachen
(C# und Visual Basic .NET)

.NET 1.1 —

1 Measurement Studio 7.x erforderlich.

Tabelle 3.  Von NI-DAQ 7.3 unterstützte Geräte

Gerät NI-DAQmx
Traditioneller 

NI-DAQ

Multifunktions-DAQ-Karten

PCI- und PXI-Karten der E-Serie wie NI-PCI-6052E ✓ ✓

PCMCIA-Karten der E-Serie, NI-DAQCard-6024E, NI-DAQCard-6036E und 
NI-DAQCard-6062E

✓ ✓

AT-E-Serie — ✓

NI-PCI-6013/6014 16-Bit-Karten für Grundfunktionen ✓ ✓

NI-DAQPad-6015/6016-Geräte für USB ✓ —

NI-DAQPad-6020E/6052E/6070E-Geräte für USB und FireWire (IEEE 1394) — ✓

NI-PCI-Karten des Typs 7041/6040E für LabVIEW RT ✓ ✓

NI-PXI- und PCI-7030 für LabVIEW RT — ✓

NI-PXI-6132/6133 der S-Serie sowie NI-PXI- und NI-PCI-6143 ✓ —

NI-PCI-Karten des Typs 6110/6111 der S-Serie ✓ ✓

Alle anderen Karten der S-Serie wie beispielsweise NI-PXI-6115 — ✓
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Analogausgabe/Signalverlauf

NI-PXI- und PCI-6711/6713 Signalverlauf ✓ ✓

PCMCIA-NI-DAQCard-6715 ✓ ✓

NI-PXI- und PCI-6722/6723 ✓ —

NI-PXI- und PCI-6731/6733 ✓ ✓

NI-6703/6704 — ✓

AT-AO-6/10 — ✓

Analogeingabe: PCMCIA-DAQCard-AI-16E-4 und DAQCard-AI-16XE-50 — ✓

Counter/Timer

NI-PCI-6601/6602 ✓ ✓

NI-PXI-6602 ✓ —

NI-PXI-6608 — ✓

NI-PXI- und PCI-6624 mit isolierten Eingängen ✓ —

Hochpräzise DAQ-Karten: NI 4350/4351 — ✓

Digital-I/O

NI-6503, NI-PXI-6508, NI-6527 und NI-PCI-DIO-96 ✓ ✓

NI-6509/6510/6511/6512/6513/6514/6515/6516/6517/6518/6519 und NI-6528 ✓ —

NI-653X (Hochgeschwindigkeitskarten zur digitalen I/O) — ✓

PCMCIA-NI-DAQCard-DIO-24 ✓ ✓

NI-DAQPad-6507/6508 für USB — ✓

PC-DIO-24 und PC-DIO-96 — ✓

AT-DIO-32F — ✓

Erfassung dynamischer Signale

NI-PXI-4461 ✓ —

NI-PXI-4472/4472B und PCI-4472/4474 ✓ ✓

NI-PCI-4451/4452/4454 und 4551/4552 — ✓

Signalkonditionierung

SCXI-1521/B und SCXI-1600-Module ✓ —

Alle anderen SCXI-Signalkonditionierungsmodule ✓ ✓

NI-PXI-4200/4204/4220 (Karten mit integrierter Signalaufbereitung) ✓ —

Tabelle 3.  Von NI-DAQ 7.3 unterstützte Geräte (Fortsetzung)

Gerät NI-DAQmx
Traditioneller 

NI-DAQ
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Weitere Geräte in künftigen Versionen von 
NI-DAQmx
In künftigen Versionen von NI-DAQ werden auch solche Geräte von 
NI-DAQmx unterstützt, die derzeit nur durch den traditionellen 
NI-DAQ-Treiber angesteuert werden können. 

Geräte, die von NI-DAQ 7.x nicht mehr unterstützt 
werden
Die nachfolgend aufgeführten Produkte werden nicht von NI-DAQ 7.x 
unterstützt – also weder von NI-DAQmx noch vom traditionellen 
NI-DAQ-Treiber – und werden auch in zukünftigen Versionen von 
NI-DAQ nicht mehr enthalten sein. Zur Programmierung dieser Geräte 
ist NI-DAQ 6.9.x oder eine frühere Version erforderlich.

Signalkonditionierung (Fortsetzung)

Module der SCC-Serie ✓ ✓

TEDS-Sensoren: BNC-2096, SC-2350-Anschlussblock und SCXI-1314T
Hinweis: Mit diesen Geräten können TEDS-Sensoren ausgelesen und beschrieben 
werden.

✓ —

Schaltmodule

NI-SCXI-1160, SCXI-1161 und SCXI-1163R ✓ ✓

Alle anderen SCXI-Schaltmodule ✓ —

PXI-Schaltmodule ✓ —

NI-AT-MIO-16F-5 NI-PC-AO-2DC

NI-DAQCard-500 NI-PC-LPM-16/PNP

NI-DAQCard-516 NI-PC-OPDIO-16

NI-DAQCard-700 NI-PC-TIO-10

NI-DAQCard-1200 NI-PCI-1200

NI-DAQCard-AO-2DC NI-SCXI-1200

NI-DAQPad-1200 NI-SCXI-2000

NI-DAQPad-MIO-16XE-50 NI-SCXI-2400

NI-Lab-PC und Lab-PC+ NI-VXI-DAQ-Module

NI-Lab-PC-1200/AI NI-VXI-SC (Modulträger und Module)

NI-PC-516 NI-VXI-TB (Anschlussblöcke für den VXIbus)

Tabelle 3.  Von NI-DAQ 7.3 unterstützte Geräte (Fortsetzung)

Gerät NI-DAQmx
Traditioneller 

NI-DAQ
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DAQクイックスタートガイド

この文書では、NI-DAQ 7.xドライバソフトウェアおよびデータ集録

（DAQ）デバイスのインストール、構成方法およびデバイスが適切に動作

しているかどうかを確認する方法について説明します。

この文書は NI スイッチモジュールのインストールについては説明してい

ません。NI Switch モジュールのインストールおよび構成方法について

は、『NI Switches Getting Started Guide』を参照してください。
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表記規則

このマニュアルには、以下の表記規則を使用します。

<> DBIO<3..0> のように、山括弧内の数字間にある省略符号は、ビットまた

は信号名に関連する値の範囲を示します。

→ →記号に沿って、入れ子のメニュー項目やダイアログボックスをたどって
いくと、最終的に必要な操作を実行することができます。ファイル→ペー
ジ設定→オプションという順になっている場合、まずファイルメニューを
プルダウンし、次にページ設定項目を選択して、最後のダイアログボック
スからオプションを選択します。

このアイコンは、注意すべき重要な情報があることを示しています。

注意のアイコンは、人体の損傷、データの損失、システムの破壊を防止す

るための注意事項を示します。この記号が製品に付いている場合には、

『Read Me First: Safety and Radio-Frequency Interference』をご参照

になり、事前対策についてご確認ください。

製品にこの記号が付いている場合は、電気ショックを防止するための事前

対策についての警告を示します。

製品にこの記号が付いている場合は、熱を持っている可能性があるコン

ポーネントを表します。このコンポーネントに接触すると、人体が損傷さ

れるおそれがあります。

太字 太字のテキストは、メニュー項目やダイアログボックスなど、ソフトウェ

アでユーザが選択（クリック）する必要のある項目を表します。また、フ

ロントパネル上のパラメータ名、制御器やボタン、ダイアログボックスま

たはその一部、メニュー名、パレット名も表します。
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下線 下線つきのテキストは、重要な事項を示します。

斜体 このフォントスタイルは変数を示します。または、ユーザが入力する必要

がある語または値のプレースホルダを示します。

monospace このフォントのテキストは、キーボードから入力する必要のあるテキスト

や文字、 コードの一部、プログラムサンプル、構文例を表します。また、

ディスクドライブ名、パス名、ディレクトリ名、プログラム名、サブプロ

グラム名、サブルーチン名、デバイス名、関数名、演算名、変数名、ファ

イル名と拡張子、引用するコードにも使います。ただし、日本語の文字の

入力や表示は、前後の文と区別するため、「」で囲んでいる場合もあります。

NI-DAQ 7.xソフトウェア

ナショナルインスツルメンツの計測デバイスには、LabVIEW または

LabWindows™/CVI™ など、アプリケーションソフトウェアから呼び出す

ことができる VI や関数の豊富なライブラリである NI-DAQ ドライバソフ

トウェアが同梱されており、NI の計測デバイスの機能をすべてプログラ

ムすることができます。計測デバイスには、E シリーズマルチファンク

ション I/O（MIO）デバイス、SCXI 信号調節モジュール、およびスイッ

チモジュールなどの DAQ デバイスが含まれます。また、ドライバソフト

ウェアには、デバイスのアプリケーションを作成するための、VI、関数、

クラス、属性、およびプロパティのライブラリであるアプリケーションプ

ログラミングインタフェース (API) が含まれています。

NI-DAQ 7.x には、NI-DAQ ドライバが 2 つ含まれており、それぞれのド

ライバには独自の API、ハードウェア構成、およびソフトウェア構成があ

ります。 

• 従来型 NI-DAQ は、NI-DAQ の旧バージョンがアップグレードされ

たものです。従来型 NI-DAQ には、NI-DAQmx と同じコンピュータ

で使用できるという点を除き、NI-DAQ 6.9.3 と同様に機能する VI お
よび関数が含まれています。 

• NI-DAQmx は最新の NI-DAQ ドライバで、従来型 NI-DAQ に比べ、

以下の優位点があります。

– DAQ アシスタント： LabVIEW、LabWindows/CVI、および

Measurement Studio でデバイスの制御に使用するチャンネル

および計測タスクを構成およびチャンネルとタスクに基づいて

NI-DAQmx コードを生成するグラフィカルツールです。

– 高速化シングルポイントアナログ I/O およびマルチスレッドな

ど、パフォーマンスの向上。

– NI-DAQ の旧バージョンと比べて、わずかな関数と VI で DAQ
アプリケーションを作成できる、シンプルで直感的な API。

– プロパティノードおよび波形データタイプサポートを含む、

LabVIEW のために拡張された機能。
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– ANSI C、LabWindows/CVI、ネイティブ .NET と C++ インタ

フェースを含む Measurement Studio と同様の API と機能性を

提供。

– LabVIEW Real-Time モジュールのために改善されたサポートお

よびパフォーマンス。

NI-DAQmx の使用条件
NI-DAQmx は、以下の条件を満たす場合に使用できます。

• Windows 2000/NT/XP を使用している。

• NI-DAQmx によってサポートされているデバイスのみを使用してい

る。サポートされているリストについては、この文書の最後にある

「NI-DAQ 7.3 のサポート」セクションを参照してください。

• NI アプリケーションソフトウェアを使用している場合、NI-DAQmx
を使用するには、LabVIEW、LabWindows/CVI、または

Measurement Studio バージョン 7.x、または LabVIEW Real-Time
モジュール 7.1 を使用する必要があります。

• Measurement Studio .NET 言語や、PXI-4204 モジュール、

NI 4461、または NI 6509 モジュールなど、NI-DAQmx でのみサポー

トされているデバイスを使用する場合には、必ず NI-DAQmx を使用

してください。

従来型 NI-DAQ の使用が必要な場合
以下の状況が 1 つでも該当する場合は、従来型 NI-DAQ をインストール

して使用する必要があります。

• AT E シリーズマルチファンクション DAQ デバイスなど、

NI-DAQmx でサポートされていないデバイスを使用している。

• NI-DAQ 6.9.x からアップグレードして、NI-DAQmx に移植する予定

のない既存アプリケーションがある。 

• 7.0 より前のバージョンの LabVIEW、LabWindows/CVI、または

Measurement Studio を使用している。

• Visual Basic 6.0 を使用している。

• Macintosh 用 LabVIEW Real-Time モジュールを使用している。

メモ NI-DAQ 7.0 の従来型 NI-DAQ でサポートされている NI アプリケーションソフ

トウェアで最も古いバージョンは 6.0 です。LabVIEW、LabWindows/CVI、
または Measurement Studio 6.x では、NI-DAQ 7.x から従来型 NI-DAQ を使用

できます。
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従来型 NI-DAQ でサポートが中止されたもの
下記の項目は、NI-DAQ 6.9.3 でサポートされ、従来型 NI-DAQ でサポー

トが中止されたものです。

• LabVIEW、LabWindows/CVI、または Measurement Studio アプ

リケーションソフトウェアでバージョンが 6.0 より前のもの。

• Windows Me/98/95

• 1200 シリーズマルチファンクション DAQ デバイス、VXI DAQ デバ

イス、またはリモート SCXI デバイスなどの以前のデバイス。サポー

トされていないデバイスのリストについては、この文書の最後にある

「NI-DAQ 7.x でサポートが廃止されたデバイス」セクションを参照し

てください。 

NI-DAQ のシステムの適合性
図 1 はこの計測システムの概要で、実際の物理現象がどのような流れで

計測アプリケーションに取り入れられるかを示しています。

センサとトランスデューサは物理現象を検出します。信号調節デバイス

は、物理現象を計測デバイスがデータを扱えるような電気信号に調節しま

す。コンピュータは計測デバイスからデータを受け取ります。ソフトウェ

アは計測システムを制御し、いつ、どのチャンネルからデータを集録また

は出力するかを計測デバイスに伝えます。また、ソフトウェアは生データ

を取得し、グラフ、チャートまたはレポート用ファイルのような人間が理

解できる形式で解析および表示します。 
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図 1 計測システムの概要

NI の計測デバイスおよびアプリケーションソフトウェアには、データの

構成、集録、生成、NI の計測デバイスへのデータの送信といった NI の計

測デバイスの機能をすべてプログラムするための NI-DAQ ドライバソフ

トウェアが梱包されています。NI-DAQ を使用すると、そのようなプログ

ラムを作成する時間や手間が省けます。LabVIEW、LabWindows/CVI、
および Measurement Studio のようなアプリケーションソフトウェア

は、たとえば熱電対の値を読み取って返すようなコマンドをドライバへ送

信し、集録されたデータの表示や解析をします。

NI-DAQ ドライバは、NI アプリケーションソフトウェアまたは ANSI C
インタフェースを介したダイナミックリンクライブラリ（DLL）の呼び出

しをサポートするプログラミング環境から使用できます。図 1 のように、

プログラミング環境に関係なく、DAQ アプリケーションは NI-DAQ を使

用します。
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手順 1. アプリケーションソフトウェアをインストール
する

NI アプリケーションソフトウェアをインストールします。NI-DAQmx を

使用してシステムで DAQ デバイスのプログラムを作成する場合は、

LabVIEW7.x、LabWindows/CVI 7.x、Measurement Studio 7.x、また

は LabVIEW Real-Time モジュール 7.1 をインストールしてください。従

来型 NI-DAQ を使用する場合は、NI アプリケーションソフトウェアの

6.x のバージョンを使用することができます。

旧バージョンのアプリケーション開発環境または NI-DAQ で作成された

アプリケーションが存在する場合は、そのアプリケーションのバックアッ

プコピーを作成します。その後、ソフトウェアをアップグレードして、そ

のアプリケーションを修正することができます。

手順 2. NI-DAQ の古いバージョンをアンインストール
する

NI-DAQ 7.x にアップグレードする場合、ここで NI-DAQ の旧バージョン

をアンインストールします。コントロールパネル→プログラムの追加と削

除を使用します。

手順 3. NI-DAQ 7.xソフトウェアをインストールする

CD を挿入する

注意 既存のアプリケーションがサポートされていないコンポーネントを含む場合、

NI-DAQ 7.x をインストールしないでください。ソフトウェアをインストールす

る前に、この文書の最後にあるセクションの「NI-DAQ 7.3 のサポート」を参照

してください。
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NI-DAQ 7.x のインストーラが自動的に起動します。インストーラが起動

しない場合は、スタート→ファイル名を指定して実行を選択します。

x:¥setup.exeを入力します。ここで、xは CD ドライブの文字を示し

ます。トラブルシューティングの説明については、ni.com/support/

ja/troubleshooting.htmのトラブルシューティングリソースを参照し

てください。

新しいハードウェアをインストールする前にドライバソフトウェアをイン

ストールしてください。これをインストールしないと、Windows はデバ

イスを検出しない可能性があり、ドライバのインストールを促す警告が表

示されることがあります。

インストールする API を選択する

注意 NI-DAQ 7.x は、NI-DAQ の旧バージョンと同じシステムに共存させることがで

きません。NI-DAQ 7.x をインストールすると、最新バージョンの従来型

NI-DAQ が旧バージョンの NI-DAQ を上書きします。また、旧バージョンによ

りインストールされたサポートファイルも最新のものになります。NI-DAQmx
のインストール時に、旧バージョンの NI-DAQ は削除されます。

NI-DAQ 7.x は、複数のドライバおよびその API（従来型 NI-DAQ、

NI-DAQmx、および NI-SWITCH）を含みます。ドライバのいずれかまた

はすべてのドライバをインストールするかどうかは、使用するデバイスに

よって決まります。どのドライバがシステム中のデバイスをサポートする

かについては、この文書の最後にある「NI-DAQ 7.3 のサポート」セク

ションを参照してください。

NI スイッチモジュールのプログラムを作成するには、NI-SWITCH または

NI-DAQmx を使用できます。 

サポートファイルをインストールする
以下の例に示すとおり、NI-DAQ 7.x インストーラはシステムにインス

トールされている NI ソフトウェアを検出し、最新のドライバ、アプリ

ケーションソフトウェア、および言語サポートファイルを CD から自動

的にインストールします。
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1. インストーラが正しいサポートファイル、およびアプリケーションソ

フトウェアや言語の正しいバージョンを検出して選択したかどうかを

確認します。

NI アプリケーションソフトウェア 7.x をインストールする前に

NI-DAQ 7.x をインストールする場合、NI-DAQ 7.x インストーラを再

度実行して正しいアプリケーションソフトウェアサポートをインス

トールする必要があります。

2. 終了をクリックします。

3. インストールが完了したら、今再起動、シャットダウン、または終了

するかどうかを尋ねるメッセージが表示されます。

• 再起動：LabVIEW Real-Time モジュールを実行しているシステ

ムを使用している場合、システムを再起動します。

Measurement & Automation Explorer（MAX）を使用して、

ターゲットに NI-DAQ 7.x をダウンロードします。ヘルプ→ヘル

プトピック→リモートシステムを選択し、『Measurement & 
Automation Explorer リモートシステムヘルプ』を参照してく

ださい。

• 終了：複数の NI ソフトウェアをインストールする場合は、一度

終了してからインストール作業をします。

– NI 435x デバイスを使用していて、LabWindows/CVI、C、

C++、Visual Basic、または VirtualBench-Logger を使用

している場合には、プログラムを終了し、NI 435x CD から

ソフトウェアをインストールしてください。

– PC から PXI シャーシを制御するために MXI-3 を使用してい

る場合は、DAQ デバイスを使用する前に、終了して

ni.com/jp/downloadsから入手できる MXI-3 ソフトウェ

アをインストールしてください。
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• シャットダウン：デバイスをインストールする準備ができたら、

シャットダウンします。

手順 4. デバイス、アクセサリ、およびケーブルの梱包
を解く

デバイスは、静電気によるデバイスおよびコンポーネントへの損傷

（ESD、静電破壊）を防ぐため、静電防止の梱包で出荷されます。

注意 露出しているコネクタピンには絶対に触れないでください。

このような損傷を回避するには、以下の予防措置を講じてください。

• 接地ストラップを使用したり、接地された物体に触れたりして、身体

を接地する。

• 静電防止の梱包をシャーシの金属部分に接触させてから、デバイスを

梱包箱から取り出す。

デバイスを箱から取り出し、部品がゆるんでいないかどうか、また、損傷

箇所がないかどうか調べてください。デバイスが損傷している場合は、ナ

ショナルインスツルメンツまでご連絡ください。損傷したデバイスをイン

ストールしないでください。

デバイスを使用しないときは、静電防止の梱包に保管してください。

保安と準拠については、デバイスのマニュアルの「手順 10. デバイスの文

書を参照またはインストールする」を参照してください。

手順 5. デバイス、アクセサリ、およびケーブルの梱包
をインストールする

複数の DAQ デバイスをインストールする場合には、それらのデバイスを

すべてここでインストールしてください。

DAQ デバイスに接続する SCXI モジュールがシステムに含まれる場合、

この文書を参照して DAQ コンポーネントを先にインストールします。

「手順 11. 信号調節またはスイッチデバイスをインストールする」セク

ションに SCXI モジュールをインストールする方法が記載されています。

注意 適切な静電破壊防止対策により身体が接地されていることを必ず確認してから、

ハードウェアを取り付けてください。保安と準拠に関する情報については、デ

バイスの仕様書を参照してください。
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PCI デバイス
PCI デバイスをインストールするには、以下の手順に従ってください。

1. コンピュータの電源を切り、コードを抜いてください。

2. コンピュータおよび / または拡張スロットのカバーを外します。

3. 静電気を放電するため、コンピュータの金属部分に接触します。

4. PCI システムスロットにデバイスを挿入します。そっと揺り動かしな

がら、デバイスをスロットに差し込みます。デバイスをスロットへ無

理に押し込まないでください。
 

図 2 PCI デバイスのインストール

5. デバイスの取り付け金具をコンピュータのバックパネルレールに取り

付けます。

6. 該当する場合、コンピュータのカバーを元の位置に戻します。

PXI デバイス
PXI モジュールをインストールするには、以下の手順に従ってください。

1. PXI シャーシの電源を切り、コードを抜いてください。

注意 機材のカバーの取り外し、または信号配線の接続または接続解除する前に、PXI
または SCXI シャーシまたはデバイスと一緒に梱包されている『Read Me First : 
Safety and Radio-Frequency Interference』文書を参照してください。

2. 未使用の PXI スロットのカバーパネルを外します。スロットの要件に

ついては、「手順 10. デバイスの文書を参照またはインストールする」

に記述されているデバイスの関連文書を参照してください。

1 PCI DAQ デバイス

2 PCI システムスロット
3 PCI スロットがある PC

1 2

3
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3. 静電気を放電するため、シャーシの金属部分に触れます。

4. PXI モジュールの脱着ハンドルが固定されないで自由に揺れ動く状態

にします。

5. PXI モジュールの縁をシャーシの上下にあるモジュールガイドに配置

します。

6. デバイスをシャーシ後部に接続するように、PXI スロットにデバイス

を差し込みます。

7. 抵抗を感じたら、完全にデバイスを挿入するように脱着ハンドルを引

き上げます。

8. シャーシのフロントパネル取り付けレールに、デバイスのフロントパ

ネルをネジで取り付けます。
 

図 3 PXI デバイスのインストール

PCMCIA デバイス
NI PCMCIA デバイスは、Type II の PC カードの空きスロットにインス

トールすることができます。PCMCIA デバイスをインストールするには、

以下の手順に従ってください。

1. コンピュータの PCMCIA スロットカバーを外します

（該当する場合）。

2. コネクタがしっかりと接続されるまで、PCMCIA デバイスの

PCMCIA バスコネクタをスロットに挿入します。

1 PXI シャーシ

2 PXI システムコントローラ

3 PXI モジュール

4 脱着ハンドル

5 フロントパネル取り付けネジ

6 モジュールガイド

7 電源スイッチ

3

1

2

4

PXI-1000B

7

5

6
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3. I/O ケーブルを取り付けます。ケーブルコネクタの挿入や取り外しで

は、I/O ケーブルに負担をかけないように注意してください。常に、

挿入するまたは外すケーブルのコネクタの部分をしっかりとつかんで

ください。PCMCIA デバイスから I/O ケーブルを絶対に直接引き抜

かないでください。

図 4 PCMCIA デバイスのインストール

USB/IEEE 1394 デバイス
USB または IEEE 1394 用の NI デバイスをインストールするには、以下の

手順に従ってください。

1. 電源を接続します。

• BP-1 バッテリーパックを使用している場合は、BP-1 のインス

トールガイドにあるインストール手順に従ってください。

• USB または IEEE 1394 用の NI デバイスの中には外部電源が必要

なデバイスもあります。

– デバイスに外部電源がある場合、外部電源の電圧（該当する

場合）がデバイスを使用する場所の電圧（120/230 VAC）

とデバイスに必要な電圧に一致するかどうかを確認してくだ

さい。電源の片方をコンセントに接続し、もう片方をデバイ

スに取り付けます。

– デバイスに電源コードがある場合は、電源コードの片方をデ

バイスに接続し、もう片方をコンセントに接続します。

1 PCMCIA スロットがあるコンピュータ

2 PCMCIA ソケット

3 PCMCIA デバイス

4 シールドされた I/O ケーブル

5 アクセサリ

6 信号線

®

®

1

2

4

5
6

DAQCard

3
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2. コンピュータの USB または IEEE 1394 ポート、その他のハブ、

IEEE 1394 デバイス上の使用可能な USB または IEEE 1394 ポートに

ケーブルを接続します。図 5 は USB ケーブルとそのコネクタを示し

ます。

図 5 USB ケーブルおよびコネクタ

3. USB または IEEE 1394 デバイスに電源スイッチがある場合、デバイス

の電源を入れます。コンピュータがデバイスを即座に検出します。

アクセサリ
インストールガイドの手順に従って、アクセサリやターミナルブロックを

取り付けます。SCXI および SCC 信号調節システムについては、

「手順 11. 信号調節またはスイッチデバイスをインストールする」セク

ションまでは、この文書の手順に従ってください。

手順 6. コンピュータまたは PXI シャーシに電源を入れる

Windows は、ハードウェアのインストール後に初めてコンピュータが再

起動されたときに、新しくインストールされたデバイスを認識します。一

部の Windows システムでは、インストールされたすべての NI デバイス

に対して、新しいハードウェアの検索ウィザードが起動します。デフォル

トにより、デバイスに最適なドライバを検索する（推奨）が選択されま

す。Windows がデバイスを認識するように、次へまたははいをクリック

して各デバイスのソフトウェアをインストールします。

コンピュータが USB や IEEE 1394 デバイスを認識すると、デバイスにあ

る電源の LED が点滅または点灯します。また、IEEE 1394 用 NI デバイス

には、デバイスが検出されると点滅する COM LED があります。特定の

デバイスの LED の点灯点滅パターンの説明については、デバイスの文書

の「手順 10. デバイスの文書を参照またはインストールする」を参照して

ください。 

手順 7. MAX を起動する

デスクトップにある Measurement & Automation アイコンをダブルク

リックして、MAX を開きます。

1 コンピュータ /USB ハブのコネクタ 2 デバイスのコネクタ

1
2
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手順 8. デバイスが認識されたことを確認する

次の手順に従ってください。

1. デバイスとインタフェースを開きます。リモート RT ターゲットを使

用している場合、リモートシステムを選択し、ターゲットを検索して

開き、デバイスとインタフェースを開きます。

2. デバイスとインタフェースの下に表示されるデバイスを確認します。 
従来型 NI-DAQ と NI-DAQmx の両方でデバイスがサポートされてい

て、その両方ともがインストールされている場合、同じデバイスはマ

イシステム→デバイスとインタフェースの下にある従来型 NI-DAQ
フォルダおよび NI-DAQmx フォルダの下にそれぞれ異なる名前で表

示されます。 
リモートシステム→デバイスとインタフェースの下には NI-DAQmx
デバイスのみが表示されます。従来型 NI-DAQ デバイスをリモート

システムに表示するには、ツール→従来型 NI-DAQ 構成→リモート

DAQ 構成を選択します。これにより、リモート DAQ 構成ウィンド

ウが開きます。

デバイスが表示されない場合には、<F5> キーを押して MAX の表示

を更新します。デバイスがまだ認識されないときは、ni.com/

support/ja/troubleのトラブルシューティングを参照してくだ

さい。

3. デバイスのプログラムに使用する NI-DAQ API のフォルダの下で、

テストするデバイスを右クリックします。 

• デバイスが従来型 NI-DAQ に表示される場合、プロパティを選

択して、プロパティウィンドウに表示されるリソース確認をク

1 従来型 NI-DAQ および NI-DAQmx デバイスがリストされている場合

2 NI-DAQmx デバイスのみがリストされている場合

1

2
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リックします。従来型 NI-DAQ には LabVIEW Real-Time モ

ジュールのテストパネルはありません。

• デバイスが NI-DAQmx に表示される場合は、セルフテストを選

択します。
 

セルフテスト中にヘルプの参照が必要な場合、ヘルプ→ヘルプト
ピック→ NI-DAQmx を選択して「NI-DAQmx 対応 MAX ヘル
プ」を開きます。 

4. セルフテストが終了すると、テストが成功した確認またはエラーが発

生したかどうかを示すメッセージが表示されます。エラーが発生した

場合、トラブルシューティングに関する情報については、ni.com/

support/install（英語）を参照してください。

手順 9. デバイス設定を構成する

インストールする各デバイスを構成します。

1. デバイス名を右クリックしてプロパティを選択します。デバイスを制

御する NI-DAQ API フォルダの下のデバイス名を必ずクリックしてく

ださい。リモート RT ターゲットを使用している場合、NI-DAQmx デ

バイスはリモートシステム→デバイスとインタフェースの下に表示さ

れます。

2. デバイスプロパティを構成します。従来型 NI-DAQ と NI-DAQmx の

両方でデバイスを使用するには、それぞれの API でデバイスのプロ

パティを構成する必要があります。

• アクセサリを使用している場合、アクセサリについての情報を追

加します。

• 従来型 NI-DAQ でデバイスを使用している場合、AI、AO、

OPC、またはリモートアクセスのデフォルト設定を変更できま

す。デバイスのデフォルト設定については、「手順 10. デバイス

の文書を参照またはインストールする」に記述されているデバイ

スの文書を参照してください。
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• リモート RT ターゲットおよび従来型 NI-DAQ を使用している場

合、リモート RT ターゲットの構成説明については、MAX のメ

ニューからヘルプ→ヘルプトピック→リモートシステムを選択し

ます。

LabVIEW Real-Time モジュールと従来型 NI-DAQ を実行してい

るシステムで SCXI デバイスを構成する説明については、

ni.com/support/installの「Hardware Installation/ 
Configuration Troubleshooter」 （英語）を参照してください。

Real-Time (RT) → RT Configuration Wizard → SCXI on RT 
Systems を選択します。

• IEEE 1451.4 トランスデューサ電子データシート（TEDS）センサ

およびアクセサリについては、前述の方法で、デバイスを構成し

てアクセサリを追加します。TEDS をスキャンをクリックしま

す。MAX で、デバイスに直接接続された TEDS センサを構成す

るには、デバイスとインタフェースの下にあるデバイスを右ク

リックして、TEDS を構成を選択します。

3. OK をクリックして変更を承諾します。

従来型 NI-DAQ 仮想チャンネル、スケール構成、および SCXI とアクセサ

リ構成を NI-DAQmx 構成に変換するには、ツール→ NI-DAQmx 構成→

構成を従来型 NI-DAQ から NI-DAQmx に変換を選択します。ウィザード

が SCC 構成を変換しない場合、使用する各 API に SCC 情報を構成する

必要があります。構成を変換する詳細については、ウィザードのヘルプを

クリックしてください。

手順 10. デバイスの文書を参照またはインストールする

NI-DAQ 7.x ソフトウェアキットには、サポートされているデバイスおよ

びアクセサリのオンライン文書（デバイスの端子、仕様、機能、および操

作を説明した PDF およびヘルプファイル等）が含まれます。各デバイス

の文書を検索、表示、そして印刷するには、Device Documentation 
CD を挿入します。ヘルプシステムおよび Device Document Browser
を含む NI-DAQ 7.x の文書の機能には、Internet Explorer 5.0 またはそれ

以降のバージョンのインストールが必要なものもあります。インストール

後、ブラウザおよびデバイスの文書はスタート→プログラム→ National 
Instruments → NI-DAQ → Browse Device Documentation から表示

できます。 

この CD をお持ちでない場合、デバイスのオンライン文書は ni.com/

manuals（英語）から入手できます。Device Document Browser は、

ni.com/support（英語）から、Drivers and Updates → Most 
Popular を選択し、表示されたページでご使用の NI-DAQ のバージョン

を選択して、インストール説明のウェブページを開きます。NI-DAQ CD 
2 をダウンロードして NI-DAQ Device Documentation Browser をイ

ンストールする説明に従ってください。
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手順 11. 信号調節またはスイッチデバイスをインストー
ルする

信号調節またはスイッチモジュールなど、システムに追加デバイスが含ま

れる場合は、以下の文書を参照して信号調節やスイッチのハードウェアを

インストールおよび構成してください。

• SCXI 信号調節モジュール：『SCXI クィックスタートガイド』を参照。

• スイッチモジュール：『NI Switches Getting Started Guide』を参

照。

• SC キャリアおよび SCC モジュールなど、SCC（信号調節コンポー

ネント）SCXI 信号調節モジュール：『SCC Quick Start Guide』を

参照。

このガイドの後の部分は DAQ または PXI 信号調節実装デバイスのみに適

用されます。

手順 12. センサと信号線を取り付ける

センサと信号線をターミナルブロックまたはアクセサリ端子に配線しま

す。その際に役に立つ情報を以下に示します。 

• 信号および端子の接続 :

– DAQ アシスタントを介して、システムにある NI-DAQmx デバ

イスの接続ダイアグラムを表示できます。接続ダイアグラムタブ

をクリックします。センサからコネクタブロックへの必要な接続

を表示するには、タスク中の各チャンネルを選択します。各接続

の端子名および番号が記載されています。接続ダイアグラムは現

在アナログ入力計測とほとんどの MIO および SCXI アクセサリ

をサポートします。

– 『E Series Help』、デバイスのユーザマニュアルやアクセサリの

文書は、Device Document Browser から参照することができ

ます。

– ピンの並び順については、MAX のヘルプメニューから表示でき

る『従来型 NI-DAQ 対応 MAX ヘルプ』および『NI-DAQmx 対

応 MAX ヘルプ』の「デバイス端子」のトピックに記載されてい

ます。

• センサ :

– ni.com/sensorsを参照してください。

– LabVIEW を使用する場合は、LabVIEW に同梱されている

『LabVIEW Measurements Manual』または ni.com/jp/

manualsを参照してください。 
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– NI-DAQmx を使用する場合には、スタート→プログラム→

National Instruments → NI-DAQ → NI-DAQmx Help から表

示できる『NI-DAQmx Help』の「Sensors」のトピックを参照

してください。 

– 従来型 NI-DAQ を使用する場合には、スタート→プログラム→

National Instruments → NI-DAQ → Traditional NI-DAQ User 
Manual から表示できる『Traditional NI-DAQ User Manual』
の Chapter 5「Transducer Conversion Functions」を参照し

てください。 

– IEEE 1451.4 TEDS スマートセンサの情報については、ni.com/

zone（英語）を参照してください。 

• スイッチ：スイッチの仕様にはデバイスのトポロジーが含まれています。

手順 13. テストパネルを実行する

多くのデバイスには、信号の集録や生成などの特定のデバイス機能をテス

トするためのテストパネルがあります。 

1. MAX で、デバイスとインタフェース→従来型 NI-DAQ デバイス、ま

たはデバイスとインタフェース→ NI-DAQmx デバイスを開きます。

リモート RT ターゲットを使用している場合、リモートシステムを選

択し、ターゲットを検索して開き、デバイスとインタフェースを開き

ます。

2. テストするには、デバイスを右クリックします。デバイスを使用する

NI-DAQ API フォルダの下のデバイス名を必ずクリックしてください。

3. 選択されたデバイスのテストパネルを開くには、 テストパネルを選択

します。従来型 NI-DAQ には LabVIEW Real-Time モジュールのテ

ストパネルはありません。
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テストパネルの例を以下の図に示します。 

4. デバイスのさまざまな機能をテストするには、タブをクリックしま

す。NI-DAQmx でのテストパネルの操作については、ヘルプを参照

してください。従来型 NI-DAQ のテストパネルの操作については、

『Measurement & Automation Explorer の従来型 NI-DAQ 対応ヘ

ルプ』を参照してください。

5. テストパネルには、エラーが発生したかどうかを示すメッセージが表

示されます。その場合は、トラブルシューティングについては、

『NI-DAQmx ヘルプ』または ni.com/support/jaを参照してくだ

さい。 

6. テストパネルを終了するには、閉じるをクリックします。

手順 14. 追加の新しいデバイスを構成する

複数の DAQ デバイスをインストールする場合、各デバイスごとに手順

「手順 9. デバイス設定を構成する」～「手順 13. テストパネルを実行す

る」を繰り返します。 
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手順 15. チャンネルの構成とタスクの設定

この手順は、NI-DAQ または NI アプリケーションソフトウェアを使用し

てデバイスをプログラムする場合のみに適用されます。 

物理チャンネルとは、アナログ信号またはデジタル信号を計測または生成

できる端子やピンのことです。これに対して、仮想チャンネルとは、名

前、物理チャンネル、入力端子接続、計測または生成のタイプを集めたも

ので、スケール情報も含むことができます。NI-DAQmx では、仮想チャ

ンネルはすべての計測に不可欠です。従来型 NI-DAQ では、仮想チャン

ネルの構成は、チャンネルごとに計測によって設定を行い保存するための

任意の機能でした。図 6 は NI-DAQmx と従来型 NI-DAQ でチャンネルを

構成する方法について説明します。

図 6 NI-DAQmx と従来型 NI-DAQ でチャンネルとタスクを構成する

タスクとは、NI-DAQmx の新しい重要な概念で、タイミング、トリガ、

その他のプロパティを備えた単一または複数の仮想チャンネルを集めたも

のです。概念としては、タスクは実行する計測または生成を意味していま

す。タスク内の構成情報はすべて設定または保存して、アプリケーション

で使用することができます。

NI-DAQmx では、仮想チャンネルをタスクの一部として、またはタスク

から切り離して構成できます。タスク内に作成した仮想チャンネルは、

ローカルチャンネルです。タスク外に定義した仮想チャンネルは、グロー

バルチャンネルです。グローバルチャンネルは、MAX 内あるいはアプリ

ケーションソフトウェア内に作成して、MAX に保存することができま

す。また、どのアプリケーションでも使用することができる上、さまざま

なタスクにそれらを追加することもできます。グローバルチャンネルを変

更した場合は、その変更がそのグローバルチャンネルに関連するすべての

タスクに影響を及ぼします。通常、ローカルチャンネルを使用するほうが

簡単です。
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NI-DAQmx でタスクを設定する
NI-DAQmx を使用する場合、DAQ アシスタントでタスクを構成します。

DAQ アシスタントでタスクおよびチャンネルを作成するには、NI アプリ

ケーションソフトウェアパッケージの 7.0 またはそれ以降のバージョンを

必ず使用してください。

• MAX でデータ設定を右クリックして、新規作成を選択します。新規

作成ウィンドウで NI-DAQmx タスクを選択して、次へをクリックし

ます。

リモート RT ターゲットを使用している場合、リモートシステムを選

択し、ターゲットを検索して開き、データ設定を右クリックして新規

作成を選択します。

• また、NI アプリケーションソフトウェアの中から直接 DAQ アシス

タントを開くこともできます。

– LabVIEW では :

• 『LabVIEW 入門』の説明に従って、Express 入力パレット

から「DAQ アシスタント（DAQ Assistant）」Express VI を
ブロックダイアグラムに配置します。 

• DAQmx タスク名制御器をフロントパネルに配置して、

DAQ アシスタントを開くこともできます。制御器を右ク

リックして、新規タスク（DAQ アシスタント）を選択しま

す。『LabVIEW における NI-DAQmx 計測』チュートリアル

には、DAQmx タスク名制御器からタスクを作成する方法

およびタスクに基づいたコードを生成する方法が段階的に説

明してあります。LabVIEW では、ヘルプ→ LabVIEW にお

ける NI-DAQmx 計測を選択します。

– LabWindows/CVI では :

1. Tools → Create/Edit DAQmx Tasks を選択します。

Create/Edit DAQmx Tasks ダイアログボックスが開きます。

2. Create New Task In MAX または Create New Task In 
Project を選択して、OK をクリックします。

– Measurement Studio では :

1. DAQmx タスクのクラスを作成する Visual Studio 
.NET およびプロジェクトを開きます。

2. Project → Add New Item を選択します。Add New Item
ダイアログボックスが開きます。 

3. Categories ぺーンで、Measurement Studio →

Assistants を選択します。

4. Templates ぺーンでは、DAQmx Task Class を選択します。

5. DAQmx タスクファイルの名前を指定して、Open をク
リックします。 

6. 新規タスクまたは MAX で作成したグローバルタスクのプロ
ジェクトコピーを作成するかどうかを指定します。

7. Finish をクリックします。
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DAQ アシスタントでは、新規タスクを作成するプロンプトが表示され

ます。

1. アナログ入力などの I/O タイプを選択します。

2. 実行する計測または生成を選択します。

3. 使用するセンサを選択します（その計測に該当する場合）。

4. 次へをクリックします。以下の例のとおり、指定したタスクにダイア

ログボックスが開きます。

5. チャンネルを選択して、タスクを追加します。タスクのローカルチャ

ンネルを作成する物理チャンネルを選択して、タスクにグローバル

チャンネルを追加できます。 

6. TEDS センサと一緒にシステムが構成されている場合、TEDS チャン

ネルタブをクリックします。 

a. 物理チャンネルを選択します。DAQ アシスタントがセンサから

設定をインポートして、タスクを作成します。 

b. 次へをクリックします。 

7. 新規タスク名を入力します。終了をクリックします。

8. 必要に応じて、その計測に適した設定、タイミング、トリガ、および

スケールを設定します。1 つあるいは複数のチャンネルが TEDS セン

サ用に構成されている場合、TEDS からロードされるいくつかの設定

は編集可能ではありません。
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9. 温度チャンネルから電圧タスクなど、タスクに異なる測定タイプの

チャンネルを追加する場合は、追加ボタンをクリックします。

a. ドロップダウンリストから追加する測定タイプを選択します。ダ

イアログボックスに、測定タイプに有効なチャンネルのリストが

すべて表示されます。 

b. 追加するチャンネルを選択します。

c. OK をクリックします。

d. 必要に応じて、ステップ 9 を繰り返し、他の測定タイプとチャ

ンネルを追加します。

10. タスクを保存します。

• LabVIEW または LabWindows/CVI から DAQ アシスタントを

開いた場合には、OK をクリックします。 

• Measurement Studio から DAQ アシスタントを開いた場合は、

File → Save を選択します。 

• MAX から DAQ アシスタントを開いた場合には、タスクを保存

をクリックします。 

これで、アプリケーションからタスクを使用することができます。 

NI-DAQmx のグローバルチャンネルを構成する
NI-DAQmx を使用する場合、DAQ アシスタントでグローバルチャンネ

ルを構成します。

• MAX で DAQ アシスタントを開くには、データ設定を右クリックし

て新規作成を選択します。 
リモート RT ターゲットを使用している場合、リモートシステムを選

択し、ターゲットを検索して開き、データ設定を右クリックして新規

作成を選択します。

新規作成ウィンドウで、NI-DAQmx クローバルチャンネルを選択し

て、次へをクリックします。

• また、NI アプリケーションソフトウェアの中から直接 DAQ アシス

タントを開くこともできます。 

– LabVIEW では、DAQmx グローバルチャンネル制御器を使用し

て DAQ アシスタントを開きます。制御器を右クリックして、

新規チャンネル（DAQ アシスタント）を選択します。

– LabWindows/CVI または Measurement Studio では、前述の

ように最初にタスクを必ず作成してください。DAQ アシスタン

トでは、Add Existing DAQmx Global Channels をクリック

して、タスクにグローバルチャンネルを追加します。グローバル

チャンネルを作成するには、MAX を必ず使用してください。
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DAQ アシスタントでは、新規グローバルチャンネルを作成するプロンプ

トが表示されます。

1. アナログ入力などの I/O タイプを選択します。 

2. 実行する計測または生成を選択します。 

3. 使用するセンサを選択します（その計測に該当する場合）。 

4. 指定したタスクのダイアログボックスでは、タスクに追加するチャン

ネルを選択するプロンプトが表示されます。タスク内のローカルチャ

ンネルを作成する物理チャンネルを選択できます。また、タスクにグ

ローバルチャンネルを追加します。 

TEDS センサと一緒にシステムが構成されている場合、TEDS チャン

ネルタブをクリックします。物理チャンネルを選択します。DAQ ア

シスタントは、センサから設定をインポートしてタスクを作成するた

めに情報を使用します。

5. その計測に適した設定を構成します。1 つあるいは複数のチャンネル

が TEDS センサ用に構成されている場合、TEDS からロードされるい

くつかの設定は編集可能ではありません。

6. チャンネルを保存します。

• LabVIEW または LabWindows/CVI から DAQ アシスタントを

開いた場合には、OK をクリックします。 

• Measurement Studio から DAQ アシスタントを開いた場合は、

File → Save を選択します。 

• MAX から DAQ アシスタントを開いた場合には、チャンネルを

保存をクリックします。 

これで、アプリケーションでのグローバルチャンネルの使用およびグロー

バルチャンネルのタスクへの追加ができるようになりました。 

従来型 NI-DAQ で仮想チャンネルを構成する
従来型 NI-DAQ を使用する際は、以下の手順に従って MAX で仮想チャ

ンネルを構成してください。

1. 新規チャンネルウィザードを開きます。 

• MAX でデータ設定を右クリックして、新規作成を選択します。

新規作成ウィンドウで従来型 NI-DAQ 仮想チャンネルを選択し

て、次へをクリックします。 

• 従来型 NI-DAQ でリモート RT ターゲットを使用している場合、

ツール→従来型 NI-DAQ 構成→リモート DAQ 構成を選択しま

す。リモートシステムの従来型 NI-DAQ デバイスは、リモート

DAQ 構成ウィンドウに表示されます。チャンネルを選択して、

追加をクリックします。 
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2. 新規作成チャンネルウィザードの説明に従って、新しいチャンネルを

作成します。チャンネル構成の詳細については、『Measurement & 
Automation Explorer の従来型 NI-DAQ 対応ヘルプ』を参照してく

ださい。

手順 16. アプリケーションでタスクを使用する

アプリケーションで計測タスクを使用するには、以下の手順に従ってくだ

さい。タスクやコード生成についての詳細は、『DAQ アシスタントヘル

プ』を参照するか、アプリケーションソフトウェアのマニュアルを参照し

てください。

LabVIEW
1. LabVIEW でブランク VI を開きます。 

2. NI Measurement → DAQmx - データ集録 → DAQmx タスク名定数

からブロックダイアグラムに定数を配置します。 

3. プルダウンメニューからタスクを選択します。 

4. VI を右クリックしてコードを生成→サンプルを選択します。 

5. フロントパネルからプログラムを実行します。 

LabWindows/CVI
LabWindows/CVI でタスクを使用する手順については、ni.com/info

（英語）にアクセスして rddq73と入力してください。 
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Measurement Studio
Measurement Studio でタスクを使用する手順については、ni.com/

info（英語）にアクセスして rddqmsと入力してください。 

アプリケーション開発を開始する

サンプルを使用する
各 API にはプログラミングサンプルのコレクションが含まれており、ア

プリケーション開発を手がける際に役立ちます。サンプルのコードは、変

更したり、アプリケーションに保存したりすることができます。サンプル

を使用して、新しいアプリケーションを開発したり、サンプルのコードを

既存のアプリケーションに加えたりすることができます。

LabVIEW および LabWindows/CVI のサンプルを確認するには、ヘルプ→

サンプルを検索を選択して、NI サンプルファインダを開きます。

Measurement Studio でサポートされる言語の NI-DAQmx のサンプル

は、以下のディレクトリにあります。

• MeasurementStudioVS2003¥VCNET¥Examples¥DAQmx 

• MeasurementStudioVS2003¥DotNET¥Examples¥DAQmx

Visual Basic 用の従来型 NI-DAQ サンプルは、以下のとおりです。

• NI-DAQ¥Examples¥Visual Basic with Measurement Studioディ

レクトリには、Measurement Studio と併用する ActiveX コント

ロールのサンプルへのリンクがあります。

• NI-DAQ¥Examples¥VBasicディレクトリには、Measurement 
Studio を使用しないサンプルがあります。

ANSI C 用 NI-DAQmx サンプルは、NI-DAQ¥Examples¥DAQmx ANSI C
ディレクトリにあります。

ANSI C 用従来型 NI-DAQ サンプルは、NI-DAQ¥Examples¥VisualC

ディレクトリにあります。

その他数多くのサンプルについては、ni.com/zone（英語）を参照して

ください。
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計測アプリケーションとデバイスの情報
計測アプリケーションおよびデバイスについての情報は以下の場所で検索

できます。

LabVIEW
はじめてご使用になる場合には、『LabVIEW 入門』で LabVIEW の基本

操作を確認してください。スタート→プログラム→ National 
Instruments → LabVIEW 7.x→ドキュメントライブラリを検索を選択し

ます。 

『LabVIEW Measurements Manual』には、従来型 NI-DAQ および

NI-DAQmx の API の概要が記載されており、計測の概念が説明されていま

す。スタート→プログラム→ National Instruments → LabVIEW 7.x→

ドキュメントライブラリを検索を選択します。

『LabVIEW における NI-DAQmx 計測』では、DAQ アシスタントおよび

タスクなど、LabVIEW での計測をセットアップする方法が段階ごとの説

明および新しい重要な特徴や概念も記載してあります。LabVIEW の、

ヘルプ→ LabVIEW における NI-DAQmx 計測を選択してください。

『LabVIEW Help』には「VI および関数のリファレンス」セクションが含

まれていて、NI-DAQmx と従来型 NI-DAQ に使用する LabVIEW の VI
およびプロパティについての説明があります。LabVIEW では、ヘルプ→

オンラインヘルプリファレンスを選択して、目次タブで「VI および関数

のリファレンス」項を開いてご使用の NI-DAQ API 用の VI リファレンス

ヘルプセクションを検索します。 

LabVIEW Real-Time モジュール
LabVIEW Real-Time モジュールの文書のリンクについては、スタート→

プログラム→ National Instruments → LabVIEW 7.x→ Module 
Documents → LabVIEW Real-Time モジュールライブラリを検索するを

選択します。 

LabWindows/CVI
はじめてご使用になる場合には、『Getting Started with 
LabWindows/CVI』で LabWindows/CVI. の基本操作を確認してくだ

さい。LabWindows/CVI では、Help → LabWindows/CVI Bookshelf
を選択します。 

『LabWindows/CVI Help』には、NI-DAQmx 計測の概念および関数リ

ファレンスが記載されています。LabWindows/CVI では、Help →

Contents を選択します。
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Measurement Studio
『NI Measurement Studio Help』には、NI-DAQmx API の概念、計測タ

スクおよび概念、関数リファレンスが記載されています。このヘルプファ

イルは Visual Studio .NET のマニュアルに統合されています。Visual 
Studio .NET では、Help → Contents を選択します。

Measurement Studio Reference には、従来型 NI-DAQ API の概要や、

計測の概念、関数リファレンスが記載されています。Visual Studio .NET
では、Measurement Studio → Measurement Studio Reference を選

択します。

NI アプリケーションソフトウェア不使用の
ANSI C

『Traditional NI-DAQ User Manual 』および『NI-DAQmx Help』は API
の概念が記載されています。『 NI-DAQmx Help』にも、計測の概念につ

いての一般情報が記載されています。『Traditional NI-DAQ 
C Reference Help』および『NI-DAQmx C Reference Help』には、

C 関数と属性についての説明が記載されています。スタート→プログラ

ム→ National Instruments → NI-DAQ を選択して、使用している

NI-DAQ API のマニュアルのタイトルを選択します。

NI アプリケーションソフトウェア不使用の .NET
言語 

『NI Measurement Studio Help』には、NI-DAQmx API の概念、計測タ

スクおよび概念、関数リファレンスが記載されています。このヘルプファ

イルは Visual Studio .NET のマニュアルに統合されています。Visual 
Studio .NET では、Help → Contents を選択します。

メモ Visual Studio .NET を使わずに .NET 言語を使用する場合は、

『NI Measurement Studio Help』を表示できない可能性があります。

デバイスの文書
NI-DAQ 7.x には、サポートされているデバイスおよびアクセサリのオン

ライン文書（デバイスの端子、仕様、機能、および操作を説明した PDF
およびヘルプファイル等）が含まれます。各デバイスの文書を検索、表

示、印刷するには、NI-DAQ Device Documentation CD を挿入しま

す。Device Document Browser のインストール後に、デバイスの文書

はスタート→プログラム→ National Instruments → NI-DAQ → Browse 
Device Documentation から表示できます。
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NI 435x
NI 435x の構成とテストが終了したら、VirtualBench-Logger を使用し

てプログラミングをせずに NI 435x を制御することができます。

ni.com/manuals（英語）の『Getting Started with VirtualBench』を

参照して、VirtualBench-Logger の機能の使用方法を確認してください。

従来型 NI-DAQ と NI-DAQmx を同じコンピュータで使用する
NI-DAQ の旧バージョンで開発された既存のアプリケーションは従来型

NI-DAQ で動作します。従来型 NI-DAQ API および NI-DAQmx API の同

じコンピュータでの使用については、以下の制約があります。

• 一度に 1 つの API しかデバイスを制御できません。

– NI-DAQmx でデバイスを使用後、従来型 NI-DAQ でデバイスを

使用する前に、そのデバイスを使用しているすべての

NI-DAQmx のタスクを解除する必要があります。デバイスを

NI-DAQmx で使用した後で、NI-DAQmx のタスクを予約解除せ

ずに従来型 NI-DAQ で使用すると、エラーコード -10461が返

されます。NI-DAQmx タスクを解除するには、DAQmx Clear 
Task VI または関数を呼び出します。 

– 従来型 NI-DAQ でデバイスを使用した後は、NI-DAQmx でデバ

イスを使用する前にそのデバイスをリセットする必要がありま

す。デバイスを従来型 NI-DAQ で使用した後で、デバイスをリ

セットせずに NI-DAQmx で使用すると、エラーコード -200324

が返されます。 

SCXI デバイスでは、通信中の DAQ デバイスは NI-DAQmx で使

用する前に従来型 NI-DAQ で必ずリセットしてください。たと

えば、E シリーズ DAQ デバイスではポート 0 のライン 0、1、
2、および 4 を使用して SCXI モジュールと通信します。以下の

とおり、NI-DAQmx で使用する前に従来型 NI-DAQ で通信中の

デバイスをリセットしないと、エラーコード -200158が返され

ます。 

• 従来型 NI-DAQ デバイスリセット VI または Init_DA_Brds

関数を呼び出します。 

• MAX から従来型 NI-DAQ でデバイスをリセットする際は、

必ずすべてのデバイスを同時に行ってください。MAX の従

来型 NI-DAQ デバイスフォルダを右クリックして、従来型

NI-DAQ 用にドライバをリセットを選択します。リモート

RT ターゲットについては、Traditional NI-DAQ Device 
Reset VI を使用する必要があります。

• 1 つの SCXI データ集録システムのすべてのデバイス（接続された

DAQ デバイスおよび挿入された SCXI モジュール）のプログラムを

作成するには、同じ API を使用する必要があります。
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以下のトピックの詳細と説明については、ni.com/support（英語）を参

照してください。

• 従来型 NI-DAQ アプリケーションに NI-DAQmx コードを追加する方法

• 同じデバイスを使用する、従来型 NI-DAQ アプリケーションおよび

NI-DAQmx アプリケーションの両方を実行する方法

トラブルシューティング

DAQ ハードウェアおよび / またはソフトウェアのインストールで問題が

ある場合、以下のリソースを参照してください。 

• トラブルシューティングの説明については、ni.com/support/

ja/troubleshooting.htmのトラブルシューティングリソースを参

照してください。

• 一般的なインストールやプログラミングに関する問題のトラブル

シューティング、および NI 製品についてよくある質問（FAQ) の回

答に関する文書については、ni.com/jp/kbを参照してください。 

• デバイスが損傷した可能性があり、ナショナルインスツルメンツの

ハードウェアを修理またはキャリブレーションのために返却する必要

がある場合、日本ナショナルインスツルメンツ テクニカルサポート

へお電話ください。 電話番号：03-5472-2981　（平日　9：00-12：00 
13：00-17：00） 

世界各国の技術サポート

技術サポートおよびサービスについては、日本ナショナルインスツルメンツ

のウェブサイト（ni.com/jp）の下記のセクションを参照してください。

• サポート：オンライン 技術サポートリソース（ni.com/support/

ja）には以下の内容が含まれます。

– 技術サポート：即時の回答およびソリューションについてはナ

ショナルインスツルメンツのウェブサイトを参照してください。

ソフトウェアドライバとそのアップデート、検索可能な技術サ

ポートデータベース、製品マニュアル、段階的なトラブルシュー

ティングウィザード、数千ものサンプルプログラム、チュートリ

アル、アプリケーションノート、計測器ドライバなどに関する情

報があります。

– 無料技術サポート：登録しているすべてのユーザは、ni.com/

exchange/jaの技術者の情報交換サイトから世界各地の多数の

アプリケーションエンジニアへのアクセスを含む無料の基本サー

ビスを受けることができます。ナショナルインスツルメンツのア

プリケーションエンジニアがそれぞれの質問に対して必ず回答を

いたします。
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• トレーニングおよび認定：個人のペースでのトレーニング、認定プロ

グラム情報については、ni.com/jp/trainingを参照してくださ

い。また、世界各地で開催されている講師によるハンズオントレーニ

ングコースに登録することもできます。

• システムインテグレーション：時間削減、限られた人数の社内技術

者、その他プロジェクトの課題などの問題がある場合、NI アライア

ンスパートナーが支援を行います。詳細については、日本ナショナル

インスツルメンツへ電話（電話番号：03-5472-2970　平日　

9：00-12：00　13：00-17：00）でお問い合わせいただくか、または

ni.com/jp/allianceを参照してください。

• 適合宣言 (DoC)：DoC は製造元の適合宣言を使用した Council of 
the European Communities に準拠する主張です。このシステムは

ユーザに電磁環境両立性（EMC）に関する保護と製品の安全性を提

供します。ni.com/certification（英語）からご使用の製品の

DoC を取得できます。

• Calibration Certificate：ご使用の製品がキャリブレーションをサ

ポートする場合、ni.com/calibrationから Calibration 
Certificate （英語）を取得できます。

ナショナルインスツルメンツ本社は 11500 North Mopac Expressway, 
Austin, Texas, 78759-3504 にあります。最新のコンタクト情報、サポー

トの電話番号、電子メールアドレス、および現在のイベントの情報を提供

する海外オフィスのウェブサイトにアクセスするには、

ni.com/niglobal（英語）を参照してください。

NI-DAQ 7.3 のサポート

現在、NI-DAQmx 7.3 ではすべての NI 計測デバイス製品がサポートされ

ているわけではありません。将来の NI-DAQ のリリースでは、新規デバ

イスおよび既存デバイス用の NI-DAQmx のサポートが追加されます。

また、引き続き従来型 NI-DAQ もサポートします。

オペレーティングシステムサポート
NI-DAQmx および従来型 NI-DAQ バージョン 7.3 および NI-SWITCH 2.3
は Windows 2000/NT/XP をサポートします。Windows NT で

NI-DAQ 7.x を使用するには、Service Pack 6 またはそれ以降が必要

です。

NI-DAQmx 7.3 は、LabVIEW Real-Time モジュール 7.1 でのみ

PharLap をサポートします。 

Measurement Studio には Windows 2000/NT 4.0/XP で動作する

Visual Studio .NET 2003 が必要です。 

特定のオペレーティングシステムのインストールの説明を参照するには、

ni.com/support/install（英語）でハードウェアインストールウィ

ザードをご利用ください。
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他のオペレーティングシステムをサポートする NI-DAQ の旧バージョン

をダウンロードするには、ni.com/support/ja/downloadを参照して

ください。 

アプリケーションソフトウェアサポート
表 1 は、NI-DAQmx および従来型 NI-DAQ でサポートされるアプリケー

ションソフトウェアのバージョンです。NI のアプリケーションソフト

ウェアを使用しない場合は、表 2 を参照してください。
 

プログラミング言語サポート
 

NI-DAQ の旧バージョンは他のアプリケーションソフトウェアおよび他の

言語のバージョンをサポートします。ドライバの旧バージョンをダウン

ロードするには、ni.com/support/ja/downloadを参照してください。

表 1 NI-DAQ 7.x アプリケーションソフトウェアサポート

NI アプリケーションソフトウェア

NI-DAQmx でサ

ポートされてい

るバージョン

従来型 NI-DAQ で

サポートされてい

るバージョン

LabVIEW 7.x 6.1 － 7.x

LabVIEW Real-Time モジュール 7.11 6.1 － 7.x

LabWindows/CVI 7.x 6.0－ 7.x

Measurement Studio 7.x 6.0－ 7.x 2

1 NI-DAQmx とともに LabVIEW Real-Time モジュール 7.1 を使用するには、

NI-DAQmx バージョン 7.2 以上を使用する必要があります。
2 従来型 NI-DAQ には Measurement Studio C++ や .NET インタフェースは含

まれません。

表 2 NI-DAQ 7.x プログラミング言語サポート

プログラミング言語

NI-DAQmx でサ

ポートされてい

るバージョン

従来型 NI-DAQ で

サポートされてい

るバージョン

ANSI C 3 3

Microsoft Visual C++
Class ライブラリ
C DLL

7.x1

6.0－ 7.x
—

6.0－ 7.x

Visual Basic 6.0（ActiveX 使用） — 6.0

Microsoft .NET 言語

（C# および Visual Basic .NET）
.NET 1.1 —

1 Measurement Studio 7.x が必要です。
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デバイスサポート
特定のデバイスのモデル名については、CD にある『NI-DAQ 7.x 
Readme』を参照してください。表 3 は、NI-DAQmx および従来型

NI-DAQ によって NI-DAQ 7.3 でサポートされるデバイスの種類です。 

表 3 NI-DAQ 7.3 デバイスサポート

デバイス NI-DAQmx
従来型

NI-DAQ

マルチファンクション DAQ

NI PCI-6052E などの PCI/PXI E シリーズのデバイス ✓ ✓

PCMCIA E シリーズ NI DAQCard-6024E、NI DAQCard-6036E、および
NI DAQCard-6062E

✓ ✓

AT E シリーズ — ✓

NI PCI-6013/6014 16 ビットベーシックデバイス ✓ ✓

USB 対応 NI DAQPad-6015/6016 デバイス ✓ —

USB および FireWire (IEEE1394) 対応 NI DAQPad-6020E/6052E/6070E
デバイス

— ✓

LabVIEW RT 対応 NI PCI-7041/6040E デバイス ✓ ✓

LabVIEW RT 対応 NI PXI および PCI-7030 デバイス — ✓

S シリーズ NI PXI-6132/6133 および NI PXI と PCI-6143 ✓ —

S シリーズ NI PCI-6110/6111 ✓ ✓

その他すべての NI PXI-6115 などの S シリーズ — ✓

アナログ出力／波形

NI PXI および PCI-6711/6713 波形 ✓ ✓

PCMCIA NI DAQCard-6715 ✓ ✓

NI PXI および PCI-6722/6723 ✓ —

NI PXI および PCI-6731/6733 ✓ ✓

NI 6703/6704 — ✓

AT-AO-6/10 — ✓

アナログ入力 : PCMCIA DAQCard-AI-16E-4/DAQCard-AI-16XE-50 — ✓

カウンタ／タイマ

NI PCI-6601/6602 ✓ ✓

NI PXI-6602 ✓ —

NI PXI-6608 — ✓

NI PXI および PCI-6624 光絶縁 ✓ —
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NI-DAQmx の今後のリリースでサポートされる
デバイス
NI-DAQ の今後のリリースでは、現在は従来型 NI-DAQ でのみサポート

されているデバイスを NI-DAQmx でサポートします。 

高精度 DAQ: NI 4350/4351 — ✓

デジタル I/O

NI 6503、NI PXI-6508、NI 6527、および NI PCI-DIO-96 ✓ ✓

NI 6509/6510/6511/6512/6513/6514/6515/6516/6517/6518/6519 および
NI 6528 

✓ —

NI 653X デジタル波形生成／アナライザ — ✓

PCMCIA 対応 NI DAQCard DIO-24 ✓ ✓

USB 対応 NI DAQPad-6507/6508 — ✓

PC-DIO-24 および PC-DIO-96 — ✓

AT-DIO-32F — ✓

ダイナミック信号集録

NI PXI-4461 ✓ —

NI PXI-4472/4472B および PCI-4472/4474 ✓ ✓

NI PCI-4451/4452/4454 および 4551/4552 — ✓

信号調節

SCXI-1521/B および SCXI-1600 モジュール ✓ —

その他すべての SCXI 信号調節モジュール ✓ ✓

NI PXI-4200/4204/4220 信号調節実装 ✓ —

SCC シリーズモジュール ✓ ✓

TEDS デバイス : BNC-2096、SC-2350 キャリア、および SCXI-1314T
メモ : これらのデバイスは TEDS センサの読み取りおよび書き込みをサポートし

ています。

✓ —

スイッチ

NI SCXI-1160/SCXI-1161/SCXI-1163R モジュール ✓ ✓

その他すべての SCXI スイッチモジュール ✓ —

PXI スイッチモジュール ✓ —

表 3 NI-DAQ 7.3 デバイスサポート（続き）

デバイス NI-DAQmx
従来型

NI-DAQ
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NI-DAQ 7.xでサポートが廃止されたデバイス
以下の製品は NI-DAQ 7.x（NI-DAQmx または従来型 NI-DAQ）ではサ

ポートされません。NI-DAQ の今後のバージョンでもサポートされませ

ん。これらのデバイスをプログラムするには、NI-DAQ 6.9.x またはそれ

以前のバージョンが必要です。

NI AT-MIO-16F-5 NI PC-AO-2DC

NI DAQCard-500 NI PC-LPM-16/PNP

NI DAQCard-516 NI PC-OPDIO-16

NI DAQCard-700 NI PC-TIO-10

NI DAQCard-1200 NI PCI-1200

NI DAQCard-AO-2DC NI SCXI-1200

NI DAQPad-1200 NI SCXI-2000

NI DAQPad-MIO-16XE-50 NI SCXI-2400

NI Lab-PC および Lab-PC+ NI VXI DAQ モジュール

NI Lab-PC-1200/AI NI VXI-SC キャリアおよびモジュール

NI PC-516 NI VXI バス対応 VXI-TB ターミナルブ

ロック
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